• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

tModLoader Nihilism - Empties the game

BarryTheGuy

Terrarian
Hello. I have run into a few problems while setting up nihilism.
- Before the update, nihilism did not work at all and no matter what I did it still set the blacklist to the default (including copper coins).
- After the update, nihilism allows custom blacklists but still won't get rid of the default setup even when the entire config is empty. For example, equipment can't be used due to the "blacklist all equipment" default.
Things I have done:
- Cleared the list, set the cleared list as the default, reset to default, enabled nihilism. [Mod's default including blacklisted equipment were disabled, as in they disabled usage of the items.]
- Added blacklists, enabled nihilism. [Mod's default + blacklisted items were disabled.]
On an additional note, setting the config inside the game is barely functional, I was unable to search for items because it would simply not allow for letters to be input into the item menu when searching for items to blacklist. Groups worked fine.
 

BarryTheGuy

Terrarian
I have done some more things. The problem appears to be that the true default (what you get from resetting configs to their initial state, the one with the lack of equipment) seems to overwrite anything and everything with no way to disable it.
Things I have done:
- Reset to true default, added wood as a blacklisted item, enabled nihilism. Wood alongside the default configs are blacklisted.
- Cleared the config list, meaning no wood nor default configs are blacklisted. As to be expected, nothing will happen until I reset it.
- Typed /nih-defaults-reset. Default config is blacklisted, wood is not. The config menu is still empty, however.

- Repeated first two actions mentioned above.
- Typed /nih-defaults-set.
- Typed /nih-defaults-reset. Wood alongside defaults were blacklisted, but wood was not blacklisted after I removed wood from the config list and typing /nih-defaults-reset.

- Cleared the config list.
- Typed /nih-clear
- Added wood to blacklisted items, rest of config is still empty.
- Typed /nih-defaults-set
- Typed /nih-defaults-reset. Wood is blacklisted, but so are the defaults.
This is the common theme of the problem, the default list never gets disabled no matter what is done, the only way to properly activate nihilism is to also activate the default blacklists/whitelists and so on. Maybe you can find the problem starting there.
 

hamstar

Steampunker
Any word on a possible fix, or the progress of it?
Working on one now. I'll just remove the default "sample" config stuff, since I'm just not in the mood for monkeying with config defaults nonsense right now, and no one cares about those anyway.

Edit: Try v3.1.3.
 
Last edited:

BarryTheGuy

Terrarian
I have tested the update and it works great.
I have done /nih-defaults-set after every config change and then /nih-defaults-reset, which has properly blacklisted the items in the config. Thank you for taking your time to resolve the problem. I will let you know if there is any other issue.
 
Top Bottom