tModLoader Official tModLoader Help Thread

J4FG

Terrarian
So i have a tiny problem and i dont know how to fix it.

I play Calamity with a few other mods and i am unable to catch critter such as worms or grasshoppers with my bugnet.
The pickup text pops up as if i picked it up but when i look in my inventory there isnt anything. :/

thx in advance for the help!

edit: sometimes some items vanish after i pick them up. same thing with the pickup text like above. ( mined mutant statue with the blue star from fargo and only have star in inventory)
 
Last edited:

sagspum

Terrarian
I get this every time I open tmod, I've deleted the tmodloader files and terraria files multiple times, no change.
 

Attachments

  • image_2022-07-27_161439800.png
    image_2022-07-27_161439800.png
    17.8 KB · Views: 42

CausticWarrior

The Destroyer
hello, I have a mod and I accidentally deleted it and didn't back it up. I didn't enable PBD or show code in the build. All it shows when I extract it is the "Extract" folder. Does anyone know how I can get my mod back? I spent a really long time on it, and want to get it back. Any help appreciated!
 

Simple

Official Terrarian
How do you make an NPC do something upon collision with a tile? Specifically, how can you make an NPC convert a tile into a different type on collision?
 

Jokadrian

Skeletron
How do I animate a sword

This is my current code

using Terraria;
using Terraria.ID;
using Terraria.ModLoader;

namespace Gradient.Items
{
public class Masamuree : ModItem
{
public override void SetStaticDefaults()
{
// DisplayName.SetDefault("Masamuree"); // By default, capitalization in classnames will add spaces to the display name. You can customize the display name here by uncommenting this line.
Tooltip.SetDefault("Great for impersonating devs!");
}

public override void SetDefaults()
{
Item.damage = 15000;
Item.DamageType = DamageClass.Melee;
Item.width = 40;
Item.height = 76;
Item.useTime = 11;
Item.useAnimation = 11;
Item.useStyle = 1;
Item.knockBack = 13;
Item.value = 0;
Item.rare = 9;
Item.UseSound = SoundID.Item1;
Item.autoReuse = false;
}

public override void AddRecipes()
{
Recipe recipe = CreateRecipe();
recipe.AddIngredient(ModContent.ItemType<Items.SnackticalsHeart>(), 1);
recipe.AddTile(TileID.WorkBenches);
recipe.Register();
}
}
}

And this is the sprite I want to use
Main.RegisterItemAnimation(Item.type, new DrawAnimationVertical(12, 11));
Also anyone know how to make a projectile shoot another projectile at all?
 

hecko

Terrarian
Hello, I'm not sure if this is the right place to ask for help, but my tModloader has been crashing on launch consistently. I haven't played the game in about two weeks, and I'm met with the error message below every time. I have tried clean reinstallations, updating graphics drivers, and running steam as an administrator, and none of these solutions have had any success. I can't find any other solutions, so help would be greatly appreciated.

8/13/2022 11:56:21 AM
System.Exception: Multiple extensions for asset Localization\en-US, (.json, )
at ReLogic.Content.Sources.ContentSource.SetAssetNames(IEnumerable`1 paths) in D:\a\tModLoader\tModLoader\src\tModLoader\ReLogic\Content\Sources\ContentSource.cs:line 28
at ReLogic.Content.Sources.FileSystemContentSource..ctor(String basePath) in D:\a\tModLoader\tModLoader\src\tModLoader\ReLogic\Content\Sources\FileSystemContentSource.cs:line 20
at Terraria.IO.ResourcePack.GetContentSource() in tModLoader\Terraria\IO\ResourcePack.cs:line 97
at Terraria.GameContent.AssetSourceController.<>c.<UseResourcePacks>b__13_1(ResourcePack pack) in tModLoader\Terraria\GameContent\AssetSourceController.cs:line 47
at System.Linq.Enumerable.SelectIPartitionIterator`2.MoveNext()
at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)
at Terraria.GameContent.AssetSourceController.UseResourcePacks(ResourcePackList resourcePacks) in tModLoader\Terraria\GameContent\AssetSourceController.cs:line 45
at Terraria.Main.LoadContent() in tModLoader\Terraria\Main.cs:line 8620
at Terraria.Main.Initialize() in tModLoader\Terraria\Main.cs:line 5167
at Microsoft.Xna.Framework.Game.DoInitialize() in D:\a\tModLoader\tModLoader\FNA\src\Game.cs:line 779
at Microsoft.Xna.Framework.Game.Run() in D:\a\tModLoader\tModLoader\FNA\src\Game.cs:line 411
at Terraria.Program.LaunchGame_(Boolean isServer) in tModLoader\Terraria\Program.cs:line 235
 

Lumeside

Terrarian
im having issues with my server

[22:51:22.244] [.NET ThreadPool Worker/ERROR] [tML]: Unhandled Exception
System.IO.IOException: The process cannot access the file 'C:\Users\Lumeside\Documents\My Games\Terraria\tModLoader\Worlds\Takuache_Truck_MEET.wld' because it is being used by another process.
at Microsoft.Win32.SafeHandles.SafeFileHandle.CreateFile(String fullPath, FileMode mode, FileAccess access, FileShare share, FileOptions options)
at Microsoft.Win32.SafeHandles.SafeFileHandle.Open(String fullPath, FileMode mode, FileAccess access, FileShare share, FileOptions options, Int64 preallocationSize)
at System.IO.Strategies.OSFileStreamStrategy..ctor(String path, FileMode mode, FileAccess access, FileShare share, FileOptions options, Int64 preallocationSize)
at System.IO.Strategies.FileStreamHelpers.ChooseStrategy(FileStream fileStream, String path, FileMode mode, FileAccess access, FileShare share, Int32 bufferSize, FileOptions options, Int64 preallocationSize)
at System.IO.File.ReadAllBytes(String path)
at Terraria.Utilities.FileUtilities.ReadAllBytes(String path, Boolean cloud) in tModLoader\Terraria\Utilities\FileUtilities.cs:line 70
at Terraria.IO.WorldFile.InternalSaveWorld(Boolean useCloudSaving, Boolean resetTime) in tModLoader\Terraria\IO\WorldFile.cs:line 544
at Terraria.IO.WorldFile.<>c__DisplayClass57_0.<SaveWorld>b__0() in tModLoader\Terraria\IO\WorldFile.cs:line 500
at Terraria.Utilities.FileUtilities.ProtectedInvoke(Action action) in tModLoader\Terraria\Utilities\FileUtilities.cs:line 170
at Terraria.IO.WorldFile.SaveWorld(Boolean useCloudSaving, Boolean resetTime) in tModLoader\Terraria\IO\WorldFile.cs:line 499
at Terraria.IO.WorldFile.SaveWorld() in tModLoader\Terraria\IO\WorldFile.cs:line 476
at Terraria.WorldGen.saveAndPlayCallBack(Object threadContext) in tModLoader\Terraria\WorldGen.cs:line 2630
at System.Threading.QueueUserWorkItemCallback.Execute()
at System.Threading.ThreadPoolWorkQueue.Dispatch()
at System.Threading.PortableThreadPool.WorkerThread.WorkerThreadStart()
at System.Threading.Thread.StartCallback()


kinda just confused what this all means
 

aSnek147

Terrarian
Is promoting a mod that ports old-gen content back into 1.4 allowed on the forums? I've read the pinned posts but am still confused on this. If this isn't the right place to ask sorry but I don't know where else to
 

Sir Snakeboat

Duke Fishron
Is promoting a mod that ports old-gen content back into 1.4 allowed on the forums? I've read the pinned posts but am still confused on this. If this isn't the right place to ask sorry but I don't know where else to

It used to be illegal to link to mods on the forums that had old gen items in them, but after 1.3 I think, the restriction was lifted and now they're allowed
 

UnluckySport

Terrarian
So I downloaded Tmodloader from steam and when I open it, it looks like this. I have tried reinstalling it. Verifying files on both Terraria and Tmodloader but I can't make it work. I need help. I'm running Windows 7 Ultimate 64bit 4Gb Ram. Terraria works just fine.
 

Attachments

  • 20220818_004110.jpg
    20220818_004110.jpg
    1.1 MB · Views: 32

Mushrooom

Terrarian
Hi. I have a problem with the BusyBox. When I want to run tML it crashes and a BusyBox appears instead. Idk what it says (BusyBox appears just for a couple of seconds), tML still does not start. Checking on Steam shows that all the files are in place, so its inscriptions that something is missing are stupid :[
tml.png
 

ToxicToaster

Terrarian
So im wanting to make an upgraded zenith and im new to modding, i want it to have the same attack animation but dont know what to do. this is what i have so far. Ingame it still swings the sword in hand, and also the attack animation is small, centered on the player, and has no other swords in it.
 

Attachments

  • Screenshot 2022-08-28 214957.png
    Screenshot 2022-08-28 214957.png
    90.6 KB · Views: 22

adi.moise21

Terrarian
Hey, i got this error on tmod loader, tried fresh installing tmod, terraria and steam, but nothing worked. Any help please?
8/29/2022 6:01:34 PM
System.DllNotFoundException: Unable to load DLL 'C:\Users\Adrian\Desktop\tModLoader\Libraries\Native\Windows\FAudio.dll' or one of its dependencies: The specified module could not be found. (0x8007007E)
at System.Runtime.InteropServices.NativeLibrary.LoadFromPath(String libraryName, Boolean throwOnError)
at System.Runtime.InteropServices.NativeLibrary.Load(String libraryPath)
at MonoLaunch.ResolveNativeLibrary(Assembly assembly, String name) in tModLoader\Terraria\MonoLaunch.cs:line 86
at System.Runtime.Loader.AssemblyLoadContext.GetResolvedUnmanagedDll(Assembly assembly, String unmanagedDllName)
at System.Runtime.Loader.AssemblyLoadContext.ResolveUnmanagedDllUsingEvent(String unmanagedDllName, Assembly assembly, IntPtr gchManagedAssemblyLoadContext)
at FAudio.FAudioLinkedVersion()
at Terraria.ModLoader.Engine.FNALogging.RedirectLogs() in tModLoader\Terraria\ModLoader\Engine\FNALogging.cs:line 88
at Terraria.ModLoader.Logging.LogStartup(Boolean dedServ) in tModLoader\Terraria\ModLoader\Logging.cs:line 88
at Terraria.Program.LaunchGame(String[] args, Boolean monoArgs) in tModLoader\Terraria\Program.cs:line 187
 
Top Bottom