• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

tModLoader Reduced Grinding

Galadows

Terrarian
Hello !
It's been a while since I use this mod in every modpack I make on terraria, love everything, but for an unknown reasons, during all the playthroughs I did since the stationary merchant was added, he always keep an empty inventory...anyone already had a similar problem ?
 

dragon3025

Terrarian
Hello !
It's been a while since I use this mod in every modpack I make on terraria, love everything, but for an unknown reasons, during all the playthroughs I did since the stationary merchant was added, he always keep an empty inventory...anyone already had a similar problem ?
He adds items overtime and the further your into the game, the faster he will add. Did he still have an empty inventory by the end of the game?
 

Galadows

Terrarian
He adds items overtime and the further your into the game, the faster he will add. Did he still have an empty inventory by the end of the game?
Well, we're actually in hardmod, wich, if i understood correctly, makes his chances to get an item from the traveling merchant everytime he spawns to 100%, but he still doesn't have anything in any of his shop ...
 

dragon3025

Terrarian
Well, we're actually in hardmod, wich, if i understood correctly, makes his chances to get an item from the traveling merchant everytime he spawns to 100%, but he still doesn't have anything in any of his shop ...
I need to update my description page. I made a change earlier that made it so the Restock Order is always available. The Stationary Merchant will only restock if you have it in your inventory. If you do have it in your inventory, then it could be that tModLoader 0.11 broke it. I actually just fixed all parts of my mod that broke from v0.11 with this next update:

NEW UPDATE version 5.0 for tModLoader 0.11.5
  • Parts of my mod broken from the 0.11 update and are now fixed.
  • tModLoader 0.11 made it so that while in a server, clients' game will use the host's configurations. Because of this, I removed the ridiculously large part of that mod that struggled to keep it compatibility with multiplayer. Now tModLoader handles that compatibility.
Before this I had to copy my configuration lines about 5 different times in different parts of my mod, alter them, then add some more added coding in between. The whole thing was a mess, and I still had to remove some configurations that were impossible to be compatible. I'm curious if my mod has the record for the most configurations available. If so, I can definitely see why, it was pain. tModLoader 0.11 really helps my mod. I might even be able to add other configurations I removed, back into the mod (for example: recipe configurations). I'll track down everything I removed though.
 

kriig

Terrarian
hey, ive been struggling to make the expert change potion, the recipe wont show up even when im on singleplayer, what gives?
 

dragon3025

Terrarian
hey, ive been struggling to make the expert change potion, the recipe wont show up even when im on singleplayer, what gives?
That used to be craftable but I had to change it to being sold by the Merchant in singleplayer only while being non-configurable in order to fix multiplayer incompatibilities. With tModLoader 0.11 I'll make it configurable and available for multiplayer again.
 

Cadmium

Terrarian
The configured drop rates are additive, right? They just add to the vanilla rates?
I was trying to get a rod of discord and steadily increasing the rates, eventually I just said screw it at set the rate to 1.00, but the damn thing's still not dropping. Am I doing something wrong? It is the LootRodofDiscordIncrease variable right?
I am in expert mode but I thought that didn't make a difference.
 

dragon3025

Terrarian
The configured drop rates are additive, right? They just add to the vanilla rates?
I was trying to get a rod of discord and steadily increasing the rates, eventually I just said screw it at set the rate to 1.00, but the damn thing's still not dropping. Am I doing something wrong? It is the LootRodofDiscordIncrease variable right?
I am in expert mode but I thought that didn't make a difference.
I put it at 100% and it dropped each time. You're killing
Chaos Elementals right? Are you editing the right configuration file (right now it's "Reduced Grinding v4.67.json").
 

dragon3025

Terrarian
Wait aren't you up to v5.0 now? I was using v4.67 but the mod says 5.0.
It's at 5.0, but the configuration settings didn't get updated with the last update, so the configuration is still at 4.67. Updating the configuration file number would disable everyone's previous configuration files which will undo any changes they've made for no reason, so I don't update the number unless there has been configuration changes.
 

Anonymous Ally

Terrarian
Um, I want to point out that the sundials and moondials don't work anymore. I haven't tampered with the code and I also deleted and redownloaded the mod. I don't know if it's a mod in the modpack I'm using, but I know they were working in our early tests of using the mudpack. The recent update screwed them up, perhaps?
 

dragon3025

Terrarian
Um, I want to point out that the sundials and moondials don't work anymore. I haven't tampered with the code and I also deleted and redownloaded the mod. I don't know if it's a mod in the modpack I'm using, but I know they were working in our early tests of using the mudpack. The recent update screwed them up, perhaps?
Thanks for reporting this. tModLoader 0.11 seemed to have broke this part of my mod. I'm currently trying to get help for this in Discord.
 

dragon3025

Terrarian
love the mod
Thanks, I'm glad you do.

Um, I want to point out that the sundials and moondials don't work anymore. I haven't tampered with the code and I also deleted and redownloaded the mod. I don't know if it's a mod in the modpack I'm using, but I know they were working in our early tests of using the mudpack. The recent update screwed them up, perhaps?
Okay, I fixed it in this udpate:

Update 5.1
  • Fixed tiles using old right click coding.
  • Fixed dials not working in multiplayer.
 
Top Bottom