tModLoader Terraria Overhaul - Gameplay enhancements and much more


It's been two days, God is angry, please send ships!

(Did ya'all know there's a reason rainfall is measured in millimeters?)

Ok now I'm in winter and I've had maybe 10% weather that wasn't snowstorm in 5 days...

I think the weather events need to be toned down and shortened just a smidge.
Last edited:
Oi Mirsario you got to overhaul extragungear mod its lit and with out the cool firing and reload its kind of boring to play with overhaul and make scopes and in this mod muzzle acutely go onto the guns plz this mod is so cool I wound love it to be overhaul I know you just got done with 2.0 and you might not want to do anything but this mod just has to be overhaul so when you have time Plz do this thx BAI <3 P.S Love this mod its the best mod out there but sorry I cant be a patreon.
It's not supposed to be a ship. I was asking for rescue ships

Anyway I've confirmed with Mirsario that it's a bug that happens because of frameskip.
It does look like a ship tho. If you leave the water around it there and just get rid of the water on the inside, and make an anti rain area around the platforms into it, it would be able to pass as a ship.
Hey again me, there's a issue i can't found a clue on it, sometimes when a boss is too close to you, the camera just stop following the player and goes in a side of the map, and you can't do anything about it. you can't change weapons, you can't move, show map, nothing. Then the game crash with no logs. Now i'am stuck in my game because i can't kill "The hive mind" from Calamity mod, i restart terraria and tried again, still same bug, he jumps on me and the camera stop following me, and get stuck in a part of the map then crash. Any fixes?
Failed to resolve Terraria.GameInput.InputMode
bei Mono.Cecil.Mixin.CheckedResolve(TypeReference self)
bei Mono.Cecil.MetadataBuilder.GetConstantType(TypeReference constant_type, Object constant)
bei Mono.Cecil.MetadataBuilder.AddConstant(IConstantProvider owner, TypeReference type)
bei Mono.Cecil.MetadataBuilder.AddParameter(UInt16 sequence, ParameterDefinition parameter, ParamTable table)
bei Mono.Cecil.MetadataBuilder.AddParameters(MethodDefinition method)
bei Mono.Cecil.MetadataBuilder.AddMethod(MethodDefinition method)
bei Mono.Cecil.MetadataBuilder.AddMethods(TypeDefinition type)
bei Mono.Cecil.MetadataBuilder.AddType(TypeDefinition type)
bei Mono.Cecil.MetadataBuilder.AddTypeDefs()
bei Mono.Cecil.MetadataBuilder.BuildTypes()
bei Mono.Cecil.MetadataBuilder.BuildModule()
bei Mono.Cecil.ModuleWriter.<>c.<BuildMetadata>b__1_0(MetadataBuilder builder, MetadataReader _)
bei Mono.Cecil.ModuleDefinition.Read[TItem,TRet](TItem item, Func`3 read)
bei Mono.Cecil.ModuleWriter.BuildMetadata(ModuleDefinition module, MetadataBuilder metadata)
bei Mono.Cecil.ModuleWriter.WriteModuleTo(ModuleDefinition module, Stream stream, WriterParameters parameters)
bei Mono.Cecil.ModuleDefinition.Write(Stream stream, WriterParameters parameters)
bei Terraria.ModLoader.AssemblyManager.LoadedMod.EncapsulateReferences(Byte[] code)
bei Terraria.ModLoader.AssemblyManager.LoadedMod.LoadAssemblies()
bei Terraria.ModLoader.AssemblyManager.InstantiateMods(List`1 modsToLoad)
I am not sure what this means exactly, but isn't this some controls error?
I have tModLoader and Windows 10 which has a newer version than .NET Framework 4.6 automatically installed.
Im still having no luck with the god forsaken bug that i have.
I'm playing on a windows machine
with the latest tmodloader.

however, when i try to load the mod, even without enabling any other mod this message appears
Failed to resolve Terraria.GameInput.InputMode
en Mono.Cecil.Mixin.CheckedResolve(TypeReference self)
en Mono.Cecil.MetadataBuilder.GetConstantType(TypeReference constant_type, Object constant)
en Mono.Cecil.MetadataBuilder.AddConstant(IConstantProvider owner, TypeReference type)
en Mono.Cecil.MetadataBuilder.AddParameter(UInt16 sequence, ParameterDefinition parameter, ParamTable table)
en Mono.Cecil.MetadataBuilder.AddParameters(MethodDefinition method)
en Mono.Cecil.MetadataBuilder.AddMethod(MethodDefinition method)
en Mono.Cecil.MetadataBuilder.AddMethods(TypeDefinition type)
en Mono.Cecil.MetadataBuilder.AddType(TypeDefinition type)
en Mono.Cecil.MetadataBuilder.AddTypeDefs()
en Mono.Cecil.MetadataBuilder.BuildTypes()
en Mono.Cecil.MetadataBuilder.BuildModule()
en Mono.Cecil.ModuleWriter.<>c.<BuildMetadata>b__1_0(MetadataBuilder builder, MetadataReader _)
en Mono.Cecil.ModuleDefinition.Read[TItem,TRet](TItem item, Func`3 read)
en Mono.Cecil.ModuleWriter.BuildMetadata(ModuleDefinition module, MetadataBuilder metadata)
en Mono.Cecil.ModuleWriter.WriteModuleTo(ModuleDefinition module, Stream stream, WriterParameters parameters)
en Mono.Cecil.ModuleDefinition.Write(Stream stream, WriterParameters parameters)
en Terraria.ModLoader.AssemblyManager.LoadedMod.EncapsulateReferences(Byte[] code)
en Terraria.ModLoader.AssemblyManager.LoadedMod.LoadAssemblies()
en Terraria.ModLoader.AssemblyManager.InstantiateMods(List`1 modsToLoad)

I have no idea what's causing this bug, please fix it. ive waited for the 2.0 update for so long and i'm desperate to try it out. :dryadcry:
I always get this error while trying to enable this; i'm not using any other mod tho (i tried to download some others just for testing if is something with tModLoader cuz the log mentions it, but everything works fine, i even re-downloaded and reinstalled both tModLoader and Terraria Overhaul several times just to be sure if wasn't corrupted data or something like that)
The type initializer for 'System.Drawing.GDIPlus' threw an exception.
  at System.Drawing.Image.InitFromStream (System.IO.Stream stream) [0x00077] in <360d2c78ba5a464c84ab987e916718c3>:0
  at System.Drawing.Image.LoadFromStream (System.IO.Stream stream, System.Boolean keepAlive) [0x00011] in <360d2c78ba5a464c84ab987e916718c3>:0
  at System.Drawing.Image.FromStream (System.IO.Stream stream) [0x00000] in <360d2c78ba5a464c84ab987e916718c3>:0
  at TerrariaOverhaul.BitmapTexture..ctor (System.String modPath) [0x00026] in <5e5ca51a3f634471baaaf59ed03e3b23>:0
  at TerrariaOverhaul.OverhaulMod.InitEmotes () [0x00014] in <5e5ca51a3f634471baaaf59ed03e3b23>:0
  at TerrariaOverhaul.OverhaulMod.Load () [0x000e9] in <5e5ca51a3f634471baaaf59ed03e3b23>:0
  at Terraria.ModLoader.ModLoader.do_Load (System.Object threadContext) [0x00075] in <48fe00d690d54a8aa025ae62623b99b8>:0

Inner Exception:
  at (wrapper managed-to-native) System.Drawing.GDIPlus:GdiplusStartup (ulong&,System.Drawing.GdiplusStartupInput&,System.Drawing.GdiplusStartupOutput&)
  at System.Drawing.GDIPlus..cctor () [0x000cc] in <360d2c78ba5a464c84ab987e916718c3>:0

i'm running Linux tho (more specifically Manjaro Linux), tModLoader is in the latest version and Overhaul too
also i found very weird the DLL that popped on the log, cuz, well, i'm not in Windows...

sorry if i wasn't clear, i created this account just to report this, and English isn't my primary, so yeah... Peace and thank you for sharing this awesome work!
The mod is so great! But I met a question when I translate the mod. For example, I can't understand the meaning of "idfk". Could you tell me what it means?
The mod is so great! But I met a question when I translate the mod. For example, I can't understand the meaning of "idfk". Could you tell me what it means?
you can check it on urban dictionary. it's a swearing, don't know what else you excepted from cut content.
cant remember if it was in the patchnotes but, is it normal that the screen shakes at the cavern layer? that didnt happen in the first version of the mod, it just had the creepy sounds. i have the screen shake in default so its pretty weird.
i am currently having an issue with running multiple content mods at once with overhaul, i keep receiving error messages and dont know what they mean and sometimes my terraria will crash but that is ONLY WITH OVERHAUL installed plz help
Not sure I like the 'Sharknadoes'. It does make farming much easier, but it is impossible to avoid unless you were quite underground, Since it will ignore terrain. This to me makes the game far more challenging than it should reasonably be. Being able to extract mini-hearts helps, but even then, it's only a matter of time before you're dead, multiple times. Good luck playing on hardcore mode.

One thing I would change about the mechanic is to make it only be a threat on the surface by preventing the debris from passing through solid terrain. That way, when the storm hits, at least you can burrow into the ground and be relatively safe.
Hey, question. I made a mod and added my first piece of armor. Its a chestplate, but when I hold a gun. The texture on the arms glitches out, and I don't know why. Maybe you have some info on how to? I remember seeing something about adding extra arms but I dunno. Help?
Last edited:
this mod seriously needs an update because i kept receiving error logs even though i have disabled EVERY MOD EXCEPT OVERHAUL, plz help
Top Bottom