tModLoader The Thorium Mod

Koros

Terrarian
Thorium breaks piercing. Every projectile that should pierce is despawned upon contact.
- Tested with water bolt and star cannon

It's also altering how melee weapons work. They deal damage every frame instead of every swing.
- Noticed this with reaver shark.

I'm using Tmod 64 bit.
I'm guessing it's messing with Invincibility frames?
 

direwolf420

Terrarian
Thorium breaks piercing. Every projectile that should pierce is despawned upon contact.
- Tested with water bolt and star cannon

It's also altering how melee weapons work. They deal damage every frame instead of every swing.
- Noticed this with reaver shark.

I'm using Tmod 64 bit.
I'm guessing it's messing with Invincibility frames?

 

MrShjet

Terrarian
Anyone happening to get lags in Thorium multiplayer? I'm playing with a friend on tModloader and hosting a server with steam servers (Host and Play option). During play time sometimes it starts randomly lagging (in terms of not FPS lag, but like internet connection lags), but to my understanding when I'm hosting I shouldn't be lagging. We tried checking the memory usage on task manager, server logs, client logs, client console but on the time of lags happening there is nothing appearing in any of that. Also we were talking for the whole time on Discord and we weren't disconnected or anything so the Internet connection wasn't the case.
It is weird but lags appear to happen whenever we enter the naturally generated Hallow biome and the Dungeon and that is happening like 90% of the time, but sometimes lags appear totally random. During those lags items don't drop from the broken tiles, enemies are teleporting back and forth getting damaged and healing back, items laying on the ground cannot be picked up and these things last for like 15s to even a full 1min. After the lag disappears sometimes we get like doubled or tripled items which were laying on the ground.
Mods that we're using:
Lan's Shared Map v0.2
Thorium Mod v1.6.3.13
Pre-hardmode Teleportation v0.3.4
Pylon NPC v1.0
Sleep Mod v1.2.1.1
VeinMiner v1.3.1
AlchemistNPC v9.3
Yet Another Boss Health Bar v1.3.2
Use Control to Quick Trash (From 1.4) v1.1
Smart Doors (from 1.4) v1.3.3
Boss checklist v1.1.4.1
Recipe Browser && Magic Storage v1.0.0.4
Magic Storage v0.4.3.5
Recipe Browser v0.8.7
I have to also mention that we were playing on Calamity Mod v1.4.5.7 and we didn't have any lags at all through the whole gameplay and we've played with the same mods excluding Lan's Sharde Map v0.2, but we already tried playing Thorium with that mod turned off and the problem persisted.
The world was generated with only those mods active and we tried playing without the Shared map on the other world but it didn't work aswell.
I'm attaching yesterday's server logs and today's client logs when I was trying out if being alone on server fixes anything but after a like a minute of being in Hallow biome I got some lags which were shorter than those when playing with a friend but still happening (same ones described above). Lags were happening earlier aswell but we're out of options how to fix this.
Please help
 

Attachments

  • 2021-03-25-1.zip
    4.7 KB · Views: 90
  • 2021-03-25-2.zip
    3.1 KB · Views: 71
  • 2021-03-25-3.zip
    4.8 KB · Views: 81
  • 2021-03-25-4.zip
    2.6 KB · Views: 74
  • 2021-03-25-5.zip
    2.8 KB · Views: 81
  • client.log
    19.1 KB · Views: 75

Serpentarius

Terrarian
I am having a rather frustrating issue with the Boreal Strider and Coznix, The Fallen Beholder. The fight proceeds as expected up until their form changes are supposed to happen, then they just... disappear. In the case of the Boreal Strider it leaves behind its minions, but Coznix just poofs into nothing, in both cases the fights just end with no resolution. I would appreciate any ideas on how to fix this because I honestly have no idea what's going on.

EDIT: Never mind found the issue, the "No boss distance respawn" mod I was using was screwing with the phase transitions. Removing the mod fixed it instantly.
 
Last edited:

Naharie

Terrarian
This should now be resolved with v0.8 (the current mod browser release). So if you could give it another whirl, that would be great. It works on my machine, but that's no guarantee for you, so any feedback on that point is appreciated.

(I'm the author of the No Boss Distance Despawn (NBDD) mod).
 
Hey, just figured I'd ask, but if I end up having the motivation to work on a mod I've been thinking about, would you be OK with me adding some recipes using Thorium materials? It's unlikely I'll ever end up figuring out how to actually mod good, but if I do, this is one of my goals (if you're fine with it, that is).
 

Schattiz

Terrarian
Hey guys. First, thanks for an awesome mod. But I was wondering if theres something wrong with some of the droprates/items? First, Golem. I´ve killed him about 60 times and not a single Picksaw drop. Terraria wiki says it should be 25%. And then Turtle shell drops. probably killed hundreds and not a single shell. :) Thanks!
 

Bluevegas02

Terrarian
Anyone else running into a small situation where both The Lich boss and Abyssion, The Forgotten One drop nothing after being defeated? Even in the Boss Checklist book, they are still grayed/silhouette out even after being defeated?

It's not game breaking or anything like that, but just curious if anyone experienced this from their recent or previous playthroughs?
 

direwolf420

Terrarian
This can happen if other mods cause exceptions on kill
Check your client.log, and also server.log if you play in multiplayer and you are the host

Windows Logs: %UserProfile%\Documents\My Games\Terraria\ModLoader\Logs (This is typically found in C:\Documents\)
Linux Logs: ~/.local/share/Terraria/ModLoader/Logs/ or $XDG_DATA_HOME/Terraria/ModLoader/Logs/
Mac Logs: ~/Library/Application support/Terraria/ModLoader/Logs/
 

Bluevegas02

Terrarian
This can happen if other mods cause exceptions on kill
Check your client.log, and also server.log if you play in multiplayer and you are the host

Windows Logs: %UserProfile%\Documents\My Games\Terraria\ModLoader\Logs (This is typically found in C:\Documents\)
Linux Logs: ~/.local/share/Terraria/ModLoader/Logs/ or $XDG_DATA_HOME/Terraria/ModLoader/Logs/
Mac Logs: ~/Library/Application support/Terraria/ModLoader/Logs/
Well not sure what I was suppose to find, but you did help me think about 1 particular mod I had...maybe 3, who knows. I disabled them and as soon as I did that, both bosses began dropping loot after kill so thank you.
 
Last edited:

direwolf420

Terrarian
Well not sure what I was suppose to find, but you did help me think about 1 particular mod I had...maybe 3, who knows. I disabled them and as soon as I did that, both bosses began dropping loot after kill so thank you.
Yes, post the logs here after you experience issues
 

ZanKlain

Terrarian
Hey everyone, I'm trying to setup a tModLoader Thorium server on my RPI4 to no avail. I've managed to get it working with other mods, but if I enable Thorium I get a weird error (even if it's only Thorium).
This is the console excerpt of the error.
Initializing: ThoriumMod v1.6.5.0
Setting up...
An error occurred while loading
The mod responsible is unknown and tModLoader must be restarted.

System.NullReferenceException: Object reference not set to an instance of an object.
at System.Collections.Generic.LargeArrayBuilder[T].GetBuffer (Int32 index) [0x00022] in System.Core.dll
at System.Collections.Generic.LargeArrayBuilder[T].CopyTo (CopyPosition position, T[] array, Int32 arrayIndex, Int32 count) [0x00041] in System.Core.dll
at System.Collections.Generic.SparseArrayBuilder[T].CopyTo (T[] array, Int32 arrayIndex, Int32 count) [0x0009a] in System.Core.dll
at System.Collections.Generic.SparseArrayBuilder[T].ToArray () [0x00028] in System.Core.dll
at System.Linq.Enumerable+Concat2Iterator[TSource].ToArray () [0x00024] in System.Core.dll
at System.Linq.Enumerable.ToArray[TSource] (IEnumerable[T] source) [0x00021] in System.Core.dll
at Terraria.ModLoader.ItemLoader.ResizeArrays (Boolean unloading) [0x00372] in tModLoaderServer.exe
at Terraria.ModLoader.ModContent.ResizeArrays (Boolean unloading) [0x00000] in tModLoaderServer.exe
at Terraria.ModLoader.ModContent.Load (CancellationToken token) [0x00050] in tModLoaderServer.exe
at Terraria.ModLoader.ModLoader.Load (CancellationToken token) [0x00098] in tModLoaderServer.exe
At this point Im' pretty much stumped, and I'm not really an experienced user to really understand error logs (or even how Mono works)...
Any insights or ideas would be really appreciated. I really want to play Thorium, it looks very cool.
 

direwolf420

Terrarian
Hey everyone, I'm trying to setup a tModLoader Thorium server on my RPI4 to no avail. I've managed to get it working with other mods, but if I enable Thorium I get a weird error (even if it's only Thorium).
This is the console excerpt of the error.

At this point Im' pretty much stumped, and I'm not really an experienced user to really understand error logs (or even how Mono works)...
Any insights or ideas would be really appreciated. I really want to play Thorium, it looks very cool.
to my knowledge this is an issue with mono. Verify that you have the latest versions of mono, mono-complete, and maybe get mono-develop aswell
 

Damien Lucas

Terrarian
Interesting mod , does Thorium also make some changes to Reforging system ? As far as I remember weak weapons always stay :red: even after reforging so I would be able to use it later in the game.
Correct me if I'm wrong but I think reforging only slightly improves the weapon which after 10 minutes of playing it becomes useless:/
 

direwolf420

Terrarian
Interesting mod , does Thorium also make some changes to Reforging system ? As far as I remember weak weapons always stay :red: even after reforging so I would be able to use it later in the game.
Correct me if I'm wrong but I think reforging only slightly improves the weapon which after 10 minutes of playing it becomes useless:/
No, the mod does not change the reforging system
 
Top Bottom