• PC NEWS: update is out! More info here. Report bugs here
  • CONSOLE 1.4 LAUNCHES SEP 30: The official launch date for Journey's End to arrive on Xbox and PlayStation is September 30th! Click here for more info. The plan is to have the update on Switch out later this year. Stay up to date with console news here.
  • MOBILE NEWS: Stay up to date with the latest mobile news here. Report mobile bugs here

PC Troubleshooting Terraria Issues

Grumpy Squid

Systems Administrator
Staff member
i fixed my game not launching issue with the dlls (thanks) but after that for the first time of my 7 years of loving this game i get no sound and terraria doesnt even pop up in the sound mixer which i think does the music stuck at 0 problem i have launched the game with all kinds of settings all drivers are up to date it also leads to calamity and any other mod with sound not to work... help me please

Please try reinstalling DirectX, in the case of Windows 10 run the installer and select the "repair" function. Once that finishes uninstall and reinstall XNA Framework.


yes i have had other it worked on them it also worked on theese headphones i also have a big speaker with small speakers has worked on them before i have tryed deleting config.json the whole documents my games terraria folder reinstalling but i think its because 1 it for some reason cant read the sounds or 2 doesnt show up in the sound mixer... can you help me ? have you heard of it not showing up in the sound mixer? or it isnt showing up in the sound mixer because it cant read them so 1 reason and 2 combined ?????


so i tryed to play them outside of terraria and it sais this file isnt playable......so they are corrupted when i download them ? reinstalled and they are still corrupted........
Last edited:

Grumpy Squid

Systems Administrator
Staff member
So wait when you currently use other audio devices, if you were to go get your speakers and plug them in, does it work on them since the problem started occurring?


no it doesnt work on them but it used too. i really dont know what happend i stopped playing for like 6 months i come back on the same version and game doesnt launch (which you fixed) and then audio doesnt work.

Grumpy Squid

Systems Administrator
Staff member
no it doesnt work on them but it used too. i really dont know what happend i stopped playing for like 6 months i come back on the same version and game doesnt launch (which you fixed) and then audio doesnt work.

Got a question, if you were to install TModLoader (even if you don't plan on using any mods) does the audio come back? I've had a user with a similar problem to yours resolve it that way. In addition do sound or wavpacks play?

Let me know if you need assistance in either of these, if you do, we'll take it to a PM to keep this thread clear.


it is the absolute same thing if i were to get tmodloader no sound and i also cant play the sounds from the folder outside of terraria you know the sounds in the game files.which leads to mods with sounds not to enable because there is no sound even without the mods... so yea we can maybe not fill up the whole thread with this.


I got some frame problems mid game it happened to someone before and he changed drivers to solve it but I cant find older drivers, can someone give me a hand with that

Toasty Engineer


Terraria Launch Failures
If Terraria fails to launch successfully during Steam, there are a few steps that should be taken into consideration in order to avoid repetitive responses and questions about the current setup of the system it is running on. Be absolutely sure that Microsoft .NET Framework (4.0, 4.5, 4.5.1, or 4.5.2), Microsoft XNA Framework Redistributable 4.0, and Microsoft Visual C++ 2010 Redistributable Package (x86 or x64) are installed on the system.

[How do i know if i have any of these files?]
Oh and what does deleting the config.json do?
Last edited:


Why i dont have that config.json terraria dont make folder on C:\profile\games


  • Bez tytułu.png
    Bez tytułu.png
    36.9 KB · Views: 88


Hello! I've seen a few people getting this problem, but mine is slightly different (doens't have the '.Graphics.dll') and I've tried all I've seen on this subject and nothing has worked yet.

My error:
Exceção Sem Tratamento: System.BadImageFormatException: Não foi possível carregar arquivo ou assembly 'Microsoft.Xna.Framework.dll' ou uma de suas dependências. não é um aplicativo Win32 válido. (Exceção de HRESULT: 0x800700C1)
em Terraria.Program.LaunchGame(String[] args, Boolean monoArgs)
em Terraria.WindowsLaunch.Main(String[] args)

List of things that I've tried:
  • Reinstalling Terraria;
  • Verifying integrity of files on steam;
  • Reinstalling Microsoft XNA;
  • Restarting the PC;
  • This:
    Thank you for including all the possible information I could ask for.

    We are going to slightly retrace a step you took. We're going to make sure that ALL 32 bits AND 64 bits are placed into their correct system folder for all the Non-Windows dependencies. We're doing this just to be safe, if we rule out it's none of these that means it's a Windows system file causing the issue. The in-place upgrade doesn't touch files that do not need to be touched, so it's very possible it didn't fix the system files that we needed fix.

    Your options here if this doesn't work is to do a clean reinstall of the OS or boot off of another OS and manually replace the files yourself. If you consider yourself an advanced user I recommend the second option. If you are not so sure then do the first option.

    Remember your 64 bit DLL's go in System32 and your 32 bit DLL's go in SysWow64.

    32 Bit D3D8THK.dll goes in C:\Windows\SysWOW64

    64 Bit D3D8THK.dll goes in C:\Windows\System32

    32 Bit D3D9.dll goes in C:\Windows\SysWOW64

    64 Bit D3D9.dll goes in C:\Windows\System32

    32 Bit D3DX9_41.dll goes in C:\Windows\SysWOW64

    64 Bit D3DX9_41.dll goes in C:\Windows\System32

    32 Bit MSVCR100.dll goes in C:\Windows\SysWOW64

    64 Bit MSVCR100.dll goes in C:\Windows\System32

    32 Bit MSVCRT.dll goes in C:\Windows\SysWOW64

    64 Bit MSVCRT.dll goes in C:\Windows\System32

    Download link to DLL Package.
This seems to be everything, so far.

I'm running on Windows 10, 64 bit.


Hi me and my girlfriend are trying to play terraria together and once we try to join one another via steam it will get to the password then instantly after says connection lost? We have tried verifying the files and clearing steam cache. I have tried redownloading it and have tried the ip method. I looked up a server list and when I try to join one in my region is gets stuck on the connecting to part. I really just want to be able to play on a world together, pleas help. Thank You


I'm having a problem in which when I launch terraria the game starts on a black screen then closes. I've checked the client crash log and got this error:

Ionic.Zip.BadCrcException: CRC error: the file being extracted appears to be corrupted. Expected 0x70F436EA, Actual 0x576BA5CE
at Ionic.Zip.ZipEntry.VerifyCrcAfterExtract(Int32 actualCrc32)
at Ionic.Zip.ZipEntry.InternalExtract(String baseDir, Stream outstream, String password)
at ReLogic.Content.Sources.ZipContentSource.OpenStream(String assetName)
at ReLogic.Content.AssetLoader.TryLoad[T](String assetName, IContentSource source, T& resultAsset)
at ReLogic.Content.AssetRepository.TryLoadingAsset[T](Asset`1 asset, AssetRequestMode mode)
at ReLogic.Content.AssetRepository.LoadAsset[T](Asset`1 asset, AssetRequestMode mode)
at ReLogic.Content.AssetRepository.Request[T](String assetName, AssetRequestMode mode)
at Terraria.Initializers.AssetInitializer.LoadAsset[T](String assetName, AssetRequestMode mode)
at Terraria.Initializers.AssetInitializer.LoadTextures(AssetRequestMode mode)
at Terraria.Initializers.AssetInitializer.LoadAssetsWhileInInitialBlackScreen()
at Terraria.Main.<LoadContent_Deferred>d__1164.MoveNext()
at Terraria.Main.DrawSplash(GameTime gameTime)
at Terraria.Main.DoDraw(GameTime gameTime)
at Terraria.Main.Draw(GameTime gameTime)
at Microsoft.Xna.Framework.Game.DrawFrame()
at Microsoft.Xna.Framework.Game.Tick()
at Microsoft.Xna.Framework.Game.HostIdle(Object sender, EventArgs e)
at Microsoft.Xna.Framework.GameHost.OnIdle()
at Microsoft.Xna.Framework.WindowsGameHost.RunOneFrame()
at Microsoft.Xna.Framework.WindowsGameHost.ApplicationIdle(Object sender, EventArgs e)
at System.Windows.Forms.Application.ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FDoIdle(Int32 grfidlef)
at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
at System.Windows.Forms.Application.Run(Form mainForm)
at Microsoft.Xna.Framework.WindowsGameHost.Run()
at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
at Terraria.Program.LaunchGame(String[] args, Boolean monoArgs)

I've played the game only 24 hours ago and it was doing fine, I've deleted completely, reinstalled, didn't help. I've never had mods before and I don't know what to do.

Can anyone help
Top Bottom