Xbox One Unable to import old Gen world

Discussion in 'Console Bug Reports' started by Redsparx, Dec 27, 2018.

  1. Redsparx

    Redsparx Terrarian

    I don’t know what the problem is, but when I try to import my old world, it will start to work, but then it crashes, but not before becoming a buzzy annoyance. Please tell me what is going on.
     
  2. Unit One

    Unit One Moderator Staff Member Moderator

    Hi @Redsparx, it seems to be happening to others as well. I’m sorry that I don’t know of any workarounds. I suggest sending in your info to Pipeworks (the console developers) here: https://fs30.formsite.com/505games/form15/index.html

    They look over every bug report, but will likely not reply. Do you have any items in the old world that might prevent it from converting properly (previously unobtainable items like Red’s Wings, Gravity Globe, etc?)
     
  3. Redsparx

    Redsparx Terrarian

    I am not aware of any unobtainable weapons, but I have several items that would disappear if I loaded the world. Souls of blight, dragon armor, etc. My brother had reds wings on another drive, but it wasn’t on the same drive as the world I exported it from. It was from a 32GB flash drive, and the other drive with reds wings was on an 8GB drive adjacent to it. Is there a list of items that are unobtainable in Xbox? I have already posted 4 bugs to them.
     
  4. Unit One

    Unit One Moderator Staff Member Moderator

    I’m not sure that previously unobtainable items are a problem, just a thought and grasping at straws a bit. Because most, if not all, the previously unobtainable stuff in 360 is now obtainable in Xbox One.

    That’s great that you were able to send in a bug report to Pipeworks. Hopefully there can be a fix for it. Are you able to play in new worlds, just not that old one?
     
  5. Redsparx

    Redsparx Terrarian

    I was able to play in new worlds just fine there for a while, but when I played it on another friends console, I tried to load it and it caused it to crash. Now I am stuck with only an expert world, with little to nothing but what’s in my inventory. I have asked around but I have not gotten a solution to the problem. I uninstalled and reinstalled the game, and that didn’t work. And it isn’t just the one world I try to import. I have a world that is virtually unchanged except for traps above the main spawn point for event grinding, and even that world doesn’t work.
     
  6. Nodever2

    Nodever2 Steampunker

    Hi, I just wanted to say that I am having the same issue. I did some experimenting with the worlds:

    I created a brand new world on the xbox 360 and converted it to the xbox one. It worked successfully.
    I found that if I died in this world and then tried to convert it to xbox one, it did not work. This was because of the tombstone that was left behind - destroying that made it work again.
    Furthermore, the conversion would crash if I placed a sign or renamed a chest.

    If it's possible for you to go through and remove every sign, tombstone, and renamed chest (you can also just delete the chest's name and it will work again) then you could try that and it might make your worlds successfully convert. For my worlds, though, I have died several times deep underground and it's virtually impossible to get rid of all of the gravestones, so I am out of options until the glitch is fixed.

    I have already reported this using that bug report form that you linked above. Note that it is possible that this is not the exact same issue that you are having, but my experimentation on my setup showed that it was causing the game to crash for me.
     
  7. Unit One

    Unit One Moderator Staff Member Moderator

    Great info @Nodever2ks, thanks for sharing this.
     
  8. Redsparx

    Redsparx Terrarian

    Thing is, I made a brand new world. No tombstones or special chest. Failure.