• PC 1.4.3: An eye for an eye, the Terraria x Don't Starve Together Crossover Update! Get all the details here. Found some bugs? Report them with as much detail as possible here.
  • Xbox & PS 1.4: NEW PATCH released Dec 7 - read the details here. Get all the info on the Journey's End update by clicking here. Known Issues and FAQ can be read here. For any other bugs, report them (with as much detail as possible) here.
  • Switch 1.4: Journey's End will launch on Switch January 4, 2022! More details here.
  • Mobile News: Stay up to date with the latest mobile news here. Report mobile bugs here

tModLoader Fargo's Mods

the crimson enchant is bugged, at least if you're using force of nature. if you get hit with it on, you can't heal. not with nurse, not with regeneration, not with potion. is this something with my game or just in general? and is there a way to disable it for now while it's bugged for me?
 
I really don't understand the reasoning behind the Eternity minion damage nerfs - summoner isn't really a class which can hold it's own without other weapons to contribute to the damage (even with soul mod summons based upon my experience).

Especially considering every damn accessory in the game gives you a minion, and with the damage nerf all they do is reduce DPS thanks to immunity frames.... Meaning you have to disable them in the config, which is rather annoying because it means you are artificially restricted from an accessories true potential without restricting yourself to a summoner playthrough. All i really see this damage nerf being is a copy of Calamity's already idiotic policy of summon nerfing w/ another weapon in hand (which especially makes itself apparent when it stacks with Eternity's summon nerf when i try to play Deathmode/Eternity mode at the same time). It is especially annoying because the thing I most enjoy about Souls mod IS the (imo) amazing accessory minions since summoner is my favorite class.

But that is pretty much my only complaint about Souls mod, other than that it's probably my favorite mod and thoroughly enjoyable.
 

Tepig125

Duke Fishron
I'm not sure whether this would go here or if there's a better forum thread for this, but I've done some testing with the Souls DLC mod and Thorium mod, and several of the Thorium mod's Enchantments and almost all of the Thorium Forces (as well as the Soul of Yggdrasil) are missing many effects from their components.
For example, the Berserker Enchantment does not mention having the Molten Spear Tip's effects, despite the fact that it uses the Magma Enchantment as a component, which in turn uses the Molten Spear Tip as a component. The Berserker Enchantment does still have the effects of the Molten Spear Tip, despite not mentioning it in the tooltip, however.
Additionally, a few items either use old names for their components (like Danger Enchantment calling the Nightshade Flower the Night Shade Petal, and the Fallen Paladin Enchantment calling the Prydwen the Wynebgwrthucher) and the Demon Blood Enchantment uses the Demon Blood Badge (which was recently made null in a recent Thorium update), making that item- and, by proxy, the Force of Helheim, Soul of Yggdrasil, and Soul of Eternity- unobtainable without using cheats

I've compiled a list of all the items that have inaccuracies like this into a google document so that if/when Fargo gets around to fixing the inaccuracies they'll have an easier time finding what needs to be changed: Fargo's Souls DLC Tooltip Oddities
Hopefully this can be fixed soon, but if not, it's no big deal; the mod is still easily one of my favorites even if it has some oddities like this! I can understand why this stuff happens, with how many items there are to keep track of and how frequently Thorium gets updated and changes things
 

Zolpidem

Terrarian
I came back to my Eternity Mode run recently, and I have a huge problem with Plantera.
I'm battling her as a meele character (Squire armor + Mythril/Adamantite/Frozen Enchatments + Twinrangs) and when Plantera hits ~40k the game freezes. I can't even change windows as it is totally frozen. I've been facing this since yesterday all day long. I can't produce a error log (I think?) to post here tho. :(
And thank you for the mods, Eternity mode has been really challenging <3
 

a lee

Terrarian
Can you add an insta-two-house like this?
屏幕截图 2021-09-17 121733.png

Can you move Top Hat Squirrel and Golden Dipping Vat to Fargo's Mutant Mod?
 
Last edited:

SquidgyBug942

Terrarian
Hi I'm new to fargo's soul mod and was wondering about the eternity mode drop the "skull Charm". Does it drop from doctor bones as I have killed him over 600 times and not had a drop yet. Is there something I'm doing wrong or is it just some bad luck?
Thank you for the mod its absolutely amazing.
 

Coschaos

Terrarian
Trying to create Soul of Yggdrasil from scratch but unable to craft the demon blood enchantment as due to Demon Blood Badge being removed from Thorium. It is possible to just remove this item from the enhancement crafting?

Thanks for the mod~!
 

Pewee

Terrarian
Hi, here some logs from my dedicated server. It started not to load your mod after I installed Apachii's Classes Mod. I notified them but I thought you might be interrested too since in it it looks like the bugs come from Mutant mod even if its not true.
Thank for your mods as their are most usefull!
Sorry for the bad english!
 

Attachments

  • server2.log
    28.8 KB · Views: 25

LiRoX93

Terrarian
Can you please disable zoom on right click on item Bionomic Cluster or turn it off by visible item? Most useless bonus, and cannot be disabled
UPD. Found it in Configure Accesory Effects)
 
Last edited:

-Nymaurae-

Terrarian
Hello, I was playing Terraria with a bunch of mods and Fargo's mod was one of them along with the souls and dlc, but when I tried to use an older character I couldn't move, I can still use the UI's and select items but not use them, I can also still equip/unequip accessories, so I tried removing my accessories one by one and found out that the the Soul of Yggdrasil was the cause, but I wanted to narrow it down even further by trying out the souls that are used to craft it and found out that the Force of Niflheim also caused it, so I tried out the souls that make up the Force of Niflheim and found out that the Cyber Punk Enchantment was probably the main culprit, I tried its materials from the Thorium mod but they were working fine and didn't cause me to freeze. I tried equipping a new character with the enchantment and it froze too, so I don't think its because my accessories are incompatible or something. I still couldn't move whenever I equip it, and I don't know how to fix it, so I'm asking here instead.
 

Deadl7

Terrarian
Do not use InstaHouse near chests/important structures if you dont want to lose them. I just lost 3 chests with all my loot 😩😰
 

SciFiGuy102

Terrarian
I am playing on an extra large world and no meteors are falling. I have broken multiple shadow orbs and defeated the eater of worlds a couple of times. I have Fargo's DLC and all of the related mods, and a lot more. I will provide all of the mods if needed, but can someone help me with this issue? I'd like to actually be able to progress in the game.
 

NightSkye

Terrarian
discord link has a manual install here: Discord - A New Way to Chat with Friends & Communities

EDIT: Bug error report:
System.NullReferenceException: Object reference not set to an instance of an object.
at Terraria.NPC.SetDefaults(Int32 Type, Single scaleOverride)
at AQMod.Common.AQNPC.Sets.LoadSets() in AQMod\Common\AQNPC.cs:line 397
at AQMod.AQMod.PostSetupContent() in AQMod.cs:line 405
at DMD<Terraria.ModLoader.ModContent::LoadModContent>(CancellationToken , Action`1 )
at Fargowiltas.Fargowiltas.LoadHook(Action`2 orig, CancellationToken token, Action`1 loadAction) in Fargowiltas.cs:line 639
at DMD<DMD<Hook<Terraria.ModLoader.ModContent::LoadModContent>?10855742>?66118162::Hook<Terraria.ModLoader.ModContent::LoadModContent>?10855742>(CancellationToken , Action`1 )
at DMD<Terraria.ModLoader.ModContent::Load>(CancellationToken )
at Terraria.ModLoader.ModLoader.Load(CancellationToken token)
at System.Threading.Tasks.Task.Execute()
at System.Threading.ExecutionContext.RunInternal(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.ExecutionContext.Run(ExecutionContext executionContext, ContextCallback callback, Object state, Boolean preserveSyncCtx)
at System.Threading.Tasks.Task.ExecuteWithThreadLocal(Task& currentTaskSlot)
at System.Threading.Tasks.Task.ExecuteEntry(Boolean bPreventDoubleExecution)
at System.Threading.ThreadPoolWorkQueue.Dispatch()
 
Last edited:

Buckethell

Plantera
The Overloaded Destroyer consumable doesn't works (when you use it, the Destroyers bodies appears for a frame, and then gets immediately destroyed right after)
 
Top Bottom