• PC 1.4.3: An eye for an eye, the Terraria x Don't Starve Together Crossover Update! Get all the details here. Found some bugs? Report them with as much detail as possible here.
  • Xbox & PS 1.4: NEW PATCH released Dec 7 - read the details here. Get all the info on the Journey's End update by clicking here. Known Issues and FAQ can be read here. For any other bugs, report them (with as much detail as possible) here.
  • Switch 1.4: Journey's End will launch on Switch January 4, 2022! More details here.
  • Mobile News: Stay up to date with the latest mobile news here. Report mobile bugs here

Mobile Gamepad issues

yodabeto

Terrarian
Your Terraria Device
Xiami Redmi Note 9
Mobile Bug Priority
Normal
Mobile OS
Android 11
Hello,
I recently bought an 8bit do SN30 pro gamepad with the purpose of playing terraria and some retro games, this gamepad has basically two types of bluetooth connection I can use Dinput or Xinput. The gamepad seems to work correctly with everything except terraria. I tested different android games, emulators and even gamepad tester apps and all of them indicate the controller(all buttons, including triggers and thumbsticks) is working correctly. I know that currently there are many people facing gamepad issues with android 11 update and some "accesibility" settings as well and it might be related. This gamepad issue on terraria is a bit complex so the whole story is explained below.

Initially:
First try (tried with both Dinput and Xinput, same result), all gamepad buttons were not recognized in game except for L1 which actually was the only button detected ingame. When tried to "Edit controller Settings" terraria didn't allow me to change any control. Next, I tried using the menu option "setup controller hardware", it appeared only when turning off then turn on gamepad (small bug?), so... in this "setup controller hardware" menu option terraria said I had a Controller: "Virtual" and it only detected and was able to remap D-pad, both Thumbsticks (sometimes called L3 and R3), select,start and A,B,X,Y buttons, in the other hand both joysticks left and right horizontal and vertical axis were not recognized also the shoulders L1,L2 and triggers R1,R2 were not recognized as well. Note: Take notice that here Thumbsticks are recognized by the hardware mapping menu.

Next try:
I heard there was an android 11 issue so applied the "workaround" disabling all accessibility features I had enabled. Now, If you remember my gamepad can connect in Dinput or Xinput mode. So, I tried with both configurations and it seemed that they both worked good and exactly the same (except A and B, and X and Y being inverted in each case, not much of an issue really), now both joysticks left and right were completely functional but then I started doing deeper tests and hell I was wrong, there are still issues. I found two sets of behavior, one for Dinput and other for Xinput

Xinput: All buttons work, except L2,R2(Triggers) and L3,R3 (thumbsticks buttons)
Dinput: All buttons work, except L3, R3 (thumbsticks buttons)

In summary, it seems that this game controller issue in terraria is somewhat related to the buggy android 11 update since it improves using the workaround but...it still seems to be a terraria issue because any other game, gamepad tester, emulators correctly detected the controller even though I had the accesibility settings enabled. Terraria was the only thing requiring me to apply the android 11 "workaround".
I know you have told multiple times that not all controllers are supported but for this gamepad I think this is not the case since android 11 workaround + Dinput configuration allowed this gamepad to be almost 100% functional except for the L3 and R3 buttons
 

BubbleGum

Terrarian
Hello i've read the post and I have 8BitDo Pro2 and like you my Dinput does not register my L3,R3 (thumbstick buttons)
 

yodabeto

Terrarian
Yes. It is only with Terreria. Other applications work good, could be related to the android 11 gamepad issues. Let's see if it is possible to be fixed.
 
Top Bottom