1. For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
    Dismiss Notice

tAPI Mod Creation Tools

Discussion in 'Released' started by PoroCYon, Sep 29, 2014.

Thread Status:
Not open for further replies.
Thread was lock by: Jeckel
Reason: Locked at Thread Creator request.
Lock date: 00:51 05-08-2016
  1. PoroCYon

    PoroCYon Terrarian

    You have to run it from CMD.

    Press Windows+R, type 'cmd', hit enter.
    Type 'mct --help' and hit enter again.
    That's weird, the message should only appear when the -DEBUG parameter is passed to tAPI.exe.
    Also, the PoroCYon.MCT.tapi file is unused, the installer does not deploy it anymore (I hope).
     
  2. Toidiedud

    Toidiedud Terrarian

    Just downloaded to confirm that. However, i am still getting the file and it is still being put into unsorted which i find peculiar because when i'm downloading the zip the .tapi isn't there.

    Ok, and i have gotten rid of it. Ill check the update and post success or issues (hope none).
     
    Last edited: Oct 16, 2014
  3. PoroCYon

    PoroCYon Terrarian

    The .tapi is not needed at all. I (tried to) fix the issues, a new update will be uploaded soon (now, I think).
     
  4. Toidiedud

    Toidiedud Terrarian

    I can confirm that there is no message telling you there is an update available. Also the Debug message has gone too. Aswell as no .tapi. I still have issues with ICM but i'm checking if its my side only. If not ill leave a message of whats wrong in the other thread but for now all is good. Thank you!

    ICM is working fine for me now. But if anyone claims its not loading the ICM interface they may need to re download. Don't know why that's the case but doing that made it perfectly fine for me. Once again, thanks.
     
    Last edited: Oct 16, 2014
    PoroCYon likes this.
  5. Eikester

    Eikester Official Terrarian

    the following error can be fixed by manually creating the "templates" folder but might be something to look at
    [​IMG]
     
    Flashkirby99 likes this.
  6. Flashkirby99

    Flashkirby99 Skeletron

    [​IMG]
     
  7. Fangodus

    Fangodus Terrarian

    Whenever I run MCT Installer it gives me:
    MCT Error.PNG
    Though I have tAPI installed in my terraria, I can see it right now I just can't use the mod I wanted to use (In-game inventory editor).
    Sorry if this is a stupid mistake made by me haha.
     
  8. Toidiedud

    Toidiedud Terrarian

    Haha. Don't worry i had the issue initially, it seems rather than tAPI making an exe called "tAPI.exe" it now takes the name "Terraria" and renames the original Terraria.exe to Terraria.bak.exe (a backup of the original). To fix the installation just rename "Terraria" to "tAPI" and also rename "Terraria.Bak" to "Terraria". The reason for this is that i believe the installer is looking for tAPI.exe but the tAPI seems to have changed it. Quick fix and you should be all good :)
     
    Last edited: Oct 17, 2014
  9. Fangodus

    Fangodus Terrarian

    Ohhh I see, thanks! :)
     
  10. PoroCYon

    PoroCYon Terrarian

    Welp, directories are messing up, it should be in your VS directory...
    For now, try to install without any templates.
    EDIT2: fixed, but not pushed the update yet.
    You are not giving enough parameters, you need to mention WHAT to build/decompile, I should've add checks for the arguments length.
    EDIT: fixed, but not pushed the update yet.

    EDIT3: everything is fixed and updated!
     
    Last edited: Oct 17, 2014
  11. Windy-Sama

    Windy-Sama Terrarian

    Perfect!
     
  12. Bedlam_and_Chaos

    Bedlam_and_Chaos Terrarian

    How do I use this exactly? I understand the command line tool, but the dll's and such? Are there any coding examples?
     
  13. PoroCYon

    PoroCYon Terrarian

    This is meant for usage with Visual Studio. Add the DLL as a reference to the project, then build your mod with MSBuild (using the MCT compiler).
     
  14. NegativeZero

    NegativeZero Terrarian

    How do I install the MCT with GL? I just gives me an error even though I have everything installed.
     
  15. Bedlam_and_Chaos

    Bedlam_and_Chaos Terrarian

    Could use post a sample project? I'm C++ guy from the VS2008 world.. all of this seems so different to me, especially considering I've been out of software engineering for years, and years.
     
  16. PoroCYon

    PoroCYon Terrarian

    The MCT is VS10+, but it does include a template project (tAPI\Empty tAPI Mod).
    It's only for C#, though. (Except if you can manage to let my compiler work with C++/CLR, good luck with that)
     
  17. Bedlam_and_Chaos

    Bedlam_and_Chaos Terrarian

    I was just saying what my background was. I have VS2012 full and VS2013 express. I seem to like the latter more though. I want to learn the latest and greatest, including C#, .net, etc, which was the whole point of getting into Terraria modding for me (besides being a huge fan of the game). Like anyone, I'd like to ease into it in the easiest way possible. I'm trying to get back into coding again, kick start my career again, after being away from it for years due to illness, psychotic divorce, and so on.

    I was just messing around with the template project, running into this when doing a build:
    Code:
    Warning 1    The 'configuration' element is not declared.
    Error     2    System.InvalidOperationException: The JsonData instance has to be initialized first
    Error     3    The command "mct compile <snipped path>" exited with code -1.   
    
     
  18. PoroCYon

    PoroCYon Terrarian

    I hate this error, it's (usually) a bug in JsonData, or something that got messed up in your JSON file...
     
  19. SpyroForever

    SpyroForever Terrarian

    Why this don't work?
     
  20. Wall of Steel

    Wall of Steel Terrarian

    The installer tells me that I don't have Terraria installed on Steam (which I clearly do), so I can't install. And I can't find a Terraria.bak file to rename either.
    What do?
     
Thread Status:
Not open for further replies.