1. For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
    Dismiss Notice

tAPI Mod Creation Tools

Discussion in 'Released' started by PoroCYon, Sep 29, 2014.

Thread Status:
Not open for further replies.
Thread was lock by: Jeckel
Reason: Locked at Thread Creator request.
Lock date: 00:51 05-08-2016
  1. tAPIModder

    tAPIModder Terrarian

    Hey PoroCYon ı tried to install mct with with all the stuff needed but it says: You do not have tAPI r14 installed!
    But installed and played it what shall ı do?
     
  2. felipejoys

    felipejoys Terrarian

    I have sucessfuly installed it, however I have no clue as of what it does. Is there a tutorial?
     
  3. PoroCYon

    PoroCYon Terrarian

    It's a utility library, it does nothing on its own. You'll need some konwledge of C# (or any other CLR-compliant language) to use it.
     
  4. joshmulhern

    joshmulhern Terrarian

    please fix this, or update it, i have r14a, i try using r14 even, but my mct wont work, i want to use the ingame cheat menu but it wont work so please update it or make the ingame cheat menu not need it, so please, reply if you cant or atleast try to make a cheat menu that works, please!
     
  5. Dean Hippo

    Dean Hippo Terrarian

    Cheers PoroCYon, awesome Mod, really helps with building everything. I had a problem with installing MCT at first, so I downloaded the DLL's, followed your instructions in the readme file and it worked perfectly. So i don't understand the headaches in this room ;D.
    Peace.
     
    Nopezal and PoroCYon like this.
  6. Frostburn

    Frostburn Terrarian

    I'm trying to get this installed, however, when I try to, it results in an error message saying, "You do not have tAPI r14 installed" or something along those lines. I installed the version of tAPI it wanted me to, however, I didn't uninstall tAPI r14a (which may have caused an issue). I had it installed, however, I still get the same error message from attempting to load it. Do you have any idea what caused this?

    Just a note for anybody else having this problem (I see your comments...), using the manual installer works for me.
     
    Last edited: Mar 20, 2015
  7. I have tAPI r14 like it say's i need and terraria steam i also have that but it say's i need terraria steam and tAPI r14
     
  8. samufinland

    samufinland Terrarian

    I keep getting a message that says I don't have tapi installed... Is there any apps desinged to make mods? Something that shows the swing animation when setting it. And easy item making, click the detail you want to add(Buffs etc.)
     
  9. ML0078

    ML0078 Terrarian

    When I try to download MCT it says I don't have tapi r14 but I downloaded it twice and I have tapi r14a. Anyone know why.
     
  10. Theo

    Theo Steampunker

    I'm trying to update, but this shows up:
    Ashampoo_Snap_2015.03.15_16h10m51s_003_Mod Creation Tools Installer.jpg
    Yes, I DO have tAPI installed.
     
    Last edited: Apr 4, 2015
  11. Feralwolf44

    Feralwolf44 Terrarian

    From what I can see, a small update from TAPI has made this program unusable to new downloaders, as it has become uninstallable. It does not work with the most recent version of TAPI, and the people at TAPI are not making older versions of their own program available.

    To put it bluntly- DO NOT DOWNLOAD THIS PROGRAM. IT IS REDACTED.
     
  12. Chasing Specters

    Chasing Specters Spazmatism

    Excuse me, but, It won't let me install because it says I don't have tAPI r14... but I do.

    What he said. ^^^
     
  13. mc4477

    mc4477 Terrarian

    ^^^^^^^^^^
    Same problem.

    edit:
    So the only working cheat menu for tAPI is uninstallible because of this thing not working with the newest version of tAPI? :/
     
  14. Feralwolf44

    Feralwolf44 Terrarian

  15. Nopezal

    Nopezal Skeletron Prime

    This mod is outdated, and the author isn't updating it. I know him very well, so you can take my word on this.
     
  16. Zekeram12

    Zekeram12 Golem

    update this to work for r15
     
  17. XApplejackX

    XApplejackX Terrarian

    Just install r15 and install MCT manually, worked fine for the In game cheat menu mod.
     
  18. PH0U3YY0U3Y

    PH0U3YY0U3Y Steampunker

    Mine says i don't have tAPI when i have all it needs
     
  19. MarioKart7z

    MarioKart7z Plantera

    Y U NO READ PREVIOUS POSTS
    |
    V
     
    Nopezal likes this.
  20. FiendishCatz

    FiendishCatz Eye of Cthulhu

    "You do ot have tAPI installed." I DO!!! WHAT? LIAR! :p
     
Thread Status:
Not open for further replies.