tModLoader Mod of Redemption

Did you ever actually use Mod of Randomness?


  • Total voters
    410
Ok, so I have found a bug, it happens upon world gen, and it happens with the Abandoned Lab



Here:
[12:29:05] [33/ERROR] [tML]: A problem was encountered during world generation
Abandoned Lab
System.NullReferenceException: Object reference not set to an instance of an object.
at Terraria.TileObject.CanPlace(Int32 x, Int32 y, Int32 type, Int32 style, Int32 dir, TileObject& objectData, Boolean onlyCheck, Boolean checkStay)
at Terraria.WorldGen.PlaceObject(Int32 x, Int32 y, Int32 type, Boolean mute, Int32 style, Int32 alternate, Int32 random, Int32 direction)
at Redemption.WorldGeneration.AbandonedLab.Place(Point origin, StructureMap structures) in Redemption\WorldGeneration\LabGen.cs:line 186
at Redemption.RedeLab.Lab() in Redemption\RedeLab.cs:line 62
at Redemption.RedeLab.<ModifyWorldGenTasks>b__0_4(GenerationProgress progress) in Redemption\RedeLab.cs:line 47
at Terraria.GameContent.Generation.PassLegacy.Apply(GenerationProgress progress)
at Terraria.World.Generation.WorldGenerator.GenerateWorld(GenerationProgress progress)
[12:29:05] [33/ERROR] [Terraria]: A problem was encountered during world generation
System.NullReferenceException: Object reference not set to an instance of an object.
at Terraria.World.Generation.WorldGenerator.GenerateWorld(GenerationProgress progress)
at Terraria.WorldGen.generateWorld(Int32 seed, GenerationProgress customProgressObject)
at Terraria.WorldGen.do_worldGenCallBack(Object threadContext)
at Terraria.WorldGen.worldGenCallBack(Object threadContext)
[12:29:09] [1/DEBUG] [Terraria]: Device Reset, Profile: HiDef, Width: 1920, Height: 1080, Fullscreen: True, Display: \\.\DISPLAY1
[12:29:13] [1/DEBUG] [tML]: Process.Start (UseShellExecute = True): "C:\Users\djhaw\Documents\My Games\Terraria\ModLoader\Logs\client.log"
 
This mod is amazing, I love just about everything, especially the lab - bar 1 or 2 things.

please for all that is holy add decorative lab tubes and tanks they look so cool and i want to build with them but i cannot so please
 
Yes more lore your The Keeper lore is sooo cool, also can u PLEASE make a no cuss version, wouldn’t take many code changes! It’s because I’m not comftterabek with swear words.
I’m replying to my old post because it got buried as the last post on page 29
 
Ok, so I have found a bug, it happens upon world gen, and it happens with the Abandoned Lab



Here:
[12:29:05] [33/ERROR] [tML]: A problem was encountered during world generation
Abandoned Lab
System.NullReferenceException: Object reference not set to an instance of an object.
at Terraria.TileObject.CanPlace(Int32 x, Int32 y, Int32 type, Int32 style, Int32 dir, TileObject& objectData, Boolean onlyCheck, Boolean checkStay)
at Terraria.WorldGen.PlaceObject(Int32 x, Int32 y, Int32 type, Boolean mute, Int32 style, Int32 alternate, Int32 random, Int32 direction)
at Redemption.WorldGeneration.AbandonedLab.Place(Point origin, StructureMap structures) in Redemption\WorldGeneration\LabGen.cs:line 186
at Redemption.RedeLab.Lab() in Redemption\RedeLab.cs:line 62
at Redemption.RedeLab.<ModifyWorldGenTasks>b__0_4(GenerationProgress progress) in Redemption\RedeLab.cs:line 47
at Terraria.GameContent.Generation.PassLegacy.Apply(GenerationProgress progress)
at Terraria.World.Generation.WorldGenerator.GenerateWorld(GenerationProgress progress)
[12:29:05] [33/ERROR] [Terraria]: A problem was encountered during world generation
System.NullReferenceException: Object reference not set to an instance of an object.
at Terraria.World.Generation.WorldGenerator.GenerateWorld(GenerationProgress progress)
at Terraria.WorldGen.generateWorld(Int32 seed, GenerationProgress customProgressObject)
at Terraria.WorldGen.do_worldGenCallBack(Object threadContext)
at Terraria.WorldGen.worldGenCallBack(Object threadContext)
[12:29:09] [1/DEBUG] [Terraria]: Device Reset, Profile: HiDef, Width: 1920, Height: 1080, Fullscreen: True, Display: \\.\DISPLAY1
[12:29:13] [1/DEBUG] [tML]: Process.Start (UseShellExecute = True): "C:\Users\djhaw\Documents\My Games\Terraria\ModLoader\Logs\client.log"


I was having this problem too for two medium corruption worlds. I enabled Zelda-Style boss titles in the mod config and changed world evil to random and it worked.
 
Ritto Gaming has started a druid playthrough of this mod. Maybe he should be added to the videos section of the first post?
 
A buddy of mine recommends we add this to our next world.
I know nothing about this mod, or the mod it is a revamp of.
So I have to ask: will the conflict with any other mods, such as (but not limited to) Calamity, Fargo's, and/or Thorium?


Edit: I am guessing there's some type of conflict somewhere, because once I tried to add this mod in and try it for myself... it just kept crashing the game due to lack of memory =\
1603817283229.png1603817303394.png

Had to hit cancel on start up, exit & disable. The only thing added was this mod. Sadly I am to tired to go through and figure out what's going on... so I will drop this here and hope someone might have an answer before I dive in to an hour or 5 of mod compatibility tests...

P.S. the Thorium mod only uses a small chunk of memory, so I *was* going to attempt a quick new world load but didn't even get that far...
1603817469961.png
 
Last edited:
Finally narrows it down.
It, for whatever reason, causes the memory crash whenever Calamity Mod Music is enabled. Not even Calamity (No Music). I am unsure as to how or why, especially since the buddy who recommended this mod is not having this problem. And it's above my knowledge to figure out a more in depth cause for it. I am unsure if this is a crash on both ends, or on one side only. I do know that me and my buddies had some issues with the Calamity Mod Music in the past that prevented us from joining the same world for whatever reason (I am usually the host and either one or the other friend would crash out because of Calamity Mod Music being enabled). So we played without it for a while, and then randomly re-enabled it and we had 0 issues. There was no patch, there was no update, nothing.

I have a feeling it might be a repeat with a different twist, but I am bringing it up here just in case. Because the game works fine without Redemption, and I will assume it works fine if I do it with Redemption but without the Calamity music. If anyone knows of the cause, potential fix, or anything... I would like to know XD

Edit: in an attempt to try and figure out what could cause it, and just in case something didn't properly update, I uninstalled both Calamity and the Calamity Mod Music. When I went to reload after only reinstalling Calamity, it gave me a full crash log for Redemption as well as the memory crash. Will be linking that here in hopes that whatever is going on can be fixed.
 

Attachments

  • client Redemption Crash.txt
    31.7 KB · Views: 188
Last edited:
Finally narrows it down.
It, for whatever reason, causes the memory crash whenever Calamity Mod Music is enabled. Not even Calamity (No Music). I am unsure as to how or why, especially since the buddy who recommended this mod is not having this problem. And it's above my knowledge to figure out a more in depth cause for it. I am unsure if this is a crash on both ends, or on one side only. I do know that me and my buddies had some issues with the Calamity Mod Music in the past that prevented us from joining the same world for whatever reason (I am usually the host and either one or the other friend would crash out because of Calamity Mod Music being enabled). So we played without it for a while, and then randomly re-enabled it and we had 0 issues. There was no patch, there was no update, nothing.

I have a feeling it might be a repeat with a different twist, but I am bringing it up here just in case. Because the game works fine without Redemption, and I will assume it works fine if I do it with Redemption but without the Calamity music. If anyone knows of the cause, potential fix, or anything... I would like to know XD

Edit: in an attempt to try and figure out what could cause it, and just in case something didn't properly update, I uninstalled both Calamity and the Calamity Mod Music. When I went to reload after only reinstalling Calamity, it gave me a full crash log for Redemption as well as the memory crash. Will be linking that here in hopes that whatever is going on can be fixed.
Terraria is 32-bit so it only has 2GB of memory, so it'll get the out of memory errors if you have too many big mods. I recommend installing TModLoader 64-bit as that'll remove the 2GB limit from Terraria. Standalone - [1.3] tModLoader FNA (32bit/64bit) (Branch of tML)
 
Terraria is 32-bit so it only has 2GB of memory, so it'll get the out of memory errors if you have too many big mods. I recommend installing TModLoader 64-bit as that'll remove the 2GB limit from Terraria. Standalone - [1.3] tModLoader FNA (32bit/64bit) (Branch of tML)

I am just using the TModLoader via the Steam Library, and it actually has a 4gb memory limit, which is causing a lot of that problem. Honestly, it still doesn't make much sense to me, because they worked fine prior (earlier in the year) and I am only now experiencing this memory limit crash after trying to install and enable Redemption. Now it won't even let me run Calamity + Thorium for whatever reason =\

If you know how to transition the Steam version to the 64bit (will still attempt it, as I am actually unsure which one it uses) and that fixes it, I will be sure to thank you directly. Otherwise, I am holding off of manually doing TMod on vanilla for now until TMod updates to 1.4.1.
 
Terraria is 32-bit so it only has 2GB of memory, so it'll get the out of memory errors if you have too many big mods. I recommend installing TModLoader 64-bit as that'll remove the 2GB limit from Terraria. Standalone - [1.3] tModLoader FNA (32bit/64bit) (Branch of tML)

I got bored of trying to figure it out and did the thing with that 64bit whatsit. TMod now utilizes my full 16 gigs, was able to enable Redemption, Thorium, Calamity, etc etc and haven't gotten an error. So, hopefully, I can create a new world and have no issues >_>

Greatly appreciate the link, btw. Your advice has hopefully helped, and will be finding out if my buddy can still join me or if he also has to "upgrade" in order to have the stuff match up. Still find it strange that he has no problems with any of this though, but different hardware I guess... Idk much about Mac's, that's what he runs. Just really confused why my system kept giving me that memory shortage error when I sure as hell have the specs and then some to run this earlier in the year.
 
So, I am curious, will the wiki be updated or do I have to join the Discord to figure out what things do from this mod? Asking because some various things on the wiki are rather incomplete or just don't exist, and it seems like the wiki hasn't been updated in a while. Just found the Cursed Gem, and the only thing I can use it to make is the Chalice currently... But I don't know what the whole Alignment portion is about or how to affect it in any way. The Alignment page doesn't exist on the wiki.
 
So, I am curious, will the wiki be updated or do I have to join the Discord to figure out what things do from this mod? Asking because some various things on the wiki are rather incomplete or just don't exist, and it seems like the wiki hasn't been updated in a while. Just found the Cursed Gem, and the only thing I can use it to make is the Chalice currently... But I don't know what the whole Alignment portion is about or how to affect it in any way. The Alignment page doesn't exist on the wiki.
Alignment is a mechanic that currently isn't implemented (aside from some code for it.) It will become more relevant in future updates
 
I've been having a problem with staves and the buffs randomly disappearing when you right click. Does anyone know what could be causing this? I have not changed any keybinds or messed with any configuration files

Edit: Turns out the problem has to do with trying to use staves on multiplayer servers. It seems that only the host of the server can use them properly, otherwise the right-click function only rarely works, and the buff is immediately cancelled by the user. This would be something I hope to see fixed in the future because I was hoping to be able to use the druid class, but I'm not a big fan of the seedbags and spirits overall feel weak and very linearly with the combinations of weapons and accessories
 
Last edited:
The Quest NPC doesn't remember where you are in the quest progression between game loads (and possibly if you cycle his shop or close the dialog with him). This results in having to finish the quests like:
  1. Bucket of Chicken
  2. Bucket of Chicken, Crystal Skull
  3. Bucket of Chicken, Crystal Skull, The Ultimate Feast
Which is super frustrating if you don't know the quest progression or anything of that sort, because obviously once you find out the next item in the quest progression, you have to go back and obtain all previous quest items (Crystal Skull is bad enough with a 1/500 drop rate for the vanity item). Since you always seem to get the same reward bag, you may as well just farm chickens with battle potions and such and turn in tons of buckets of chickens and not even bother with the rest of the quest line.

I'm doing this on a multiplayer server.
 
The Quest NPC doesn't remember where you are in the quest progression between game loads (and possibly if you cycle his shop or close the dialog with him). This results in having to finish the quests like:
  1. Bucket of Chicken
  2. Bucket of Chicken, Crystal Skull
  3. Bucket of Chicken, Crystal Skull, The Ultimate Feast
Which is super frustrating if you don't know the quest progression or anything of that sort, because obviously once you find out the next item in the quest progression, you have to go back and obtain all previous quest items (Crystal Skull is bad enough with a 1/500 drop rate for the vanity item). Since you always seem to get the same reward bag, you may as well just farm chickens with battle potions and such and turn in tons of buckets of chickens and not even bother with the rest of the quest line.

I'm doing this on a multiplayer server.
thats a multiplayer issue only, also the wayfarer sells a hatchet specifically for the skull quest that makes slain skeletons have a lot higher chance of dropping a skull
 
thats a multiplayer issue only, also the wayfarer sells a hatchet specifically for the skull quest that makes slain skeletons have a lot higher chance of dropping a skull
I can understand you, multiplayer stuff is so stupid and I hate fixing it. Seriously, it is hard to test (no friends joke hahaha) and boring to fix. hate it.
 
Pls don't yell at me if this is obvious but i think that EVE from the lab logs is Girus. Because we know that she rebelled when she found out about the other robots and that she ''loved'' adam. The friendly T-bot happens to be called adam and when speaking to the V-defender or whatever his name is in the lab , he says he doesn't know why Girus doesn't just assimilate and destroy Adam despite adam being a potential threat. I think that that reason is because she can't bring herself to kill him because she loves him. We also know that she is an AI that can learn so she could probably learn how to code the ''sword'' the ''worm'' and the Omega oblitorator.
 
by the way , on my first world the lab bugged and there were no background wall so i could destroy the summons for the bosses. Even those i didnt destroy didnt work when i wanted to summon them. just thought i should say that.
 
Back
Top Bottom