• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

tModLoader Mounted Magic Mirrors - Fast travel!

hamstar

Steampunker
Hey there! First off I just wanted to say that I absolutely love this mod, and it really makes life easier.

Unfortunately as soon as I went into hardmode I started encountering problems. I tested this multiple times between different worlds and found something interesting. For the sake of expediency I will use the phrase HM World 1, HM World 2, and Regular World

If I start out in HM World 1 with mirrors that are discovered and collected, I can leave and load up Regular World, then leave and return to HM World 1 without losing any mirror data.
If I start out in HM World 1 and go to HM World 2, all mirrors will reset and when I enter HM World 2 any mirrors there will be undiscovered, and if I go back to HM World 1, all the mirrors there are undiscovered too.

Conclusion: Something about changing hardmode worlds is the root of the problem. I have no idea how to attach more data of what's happening but if you need I can try to look into it.
Thanks for your lovely mod and your time :)
Yes, I think I know what's going on. I'm working on a fix for this, presently.
 

Nakano15

Duke Fishron
That looks awesome! The only problem is finding the magic mirrors though, I've been having bad luck. Hehe.
 

R-TEAM

Terrarian
Nice mod - will it work on world generated with Large-world-enabler mod ?
(as the serverside-char mod have here problems too with teleporting .. because of changed cordinates)
 

Saint Sigma X

Terrarian
Just wanted to say that even with the lastest update map icons when using the mirrors scale with the map, so when you are zoomed out they become very tiny. and you have to zoom way in to see them. this makes finding them very difficult unless you already have an idea of where to look.

Hoping you can make it so the icons stay the same relative size when zooming, like npc and player heads. or at least make an option to do so. Otherwise I've been loving it so far. Thanks for the great mod :)
 

hamstar

Steampunker
Nice mod - will it work on world generated with Large-world-enabler mod ?
(as the serverside-char mod have here problems too with teleporting .. because of changed cordinates)
Should.
Just wanted to say that even with the lastest update map icons when using the mirrors scale with the map, so when you are zoomed out they become very tiny. and you have to zoom way in to see them. this makes finding them very difficult unless you already have an idea of where to look.

Hoping you can make it so the icons stay the same relative size when zooming, like npc and player heads. or at least make an option to do so. Otherwise I've been loving it so far. Thanks for the great mod :)
I'll try to address that soon.
 

Cheeyev

Official Terrarian
Hey; I just wanted to say that this is a pretty spectacular mod and very useful for quick transportation, although I did encounter a bug with the latest update in that whenever the cursor hovers over a mounted magic mirror, my player will freeze in mid-air and lose their vanity clothing and accessories, and it doesn't let me right click on it. Hovering off of it makes my character return to normal. I hope you can fix this bug soon, since it'll probably get annoying for players to not be able to use them.
 

hamstar

Steampunker
Hey; I just wanted to say that this is a pretty spectacular mod and very useful for quick transportation, although I did encounter a bug with the latest update in that whenever the cursor hovers over a mounted magic mirror, my player will freeze in mid-air and lose their vanity clothing and accessories, and it doesn't let me right click on it. Hovering off of it makes my character return to normal. I hope you can fix this bug soon, since it'll probably get annoying for players to not be able to use them.
Can you post your client.log file the moment this happens?
 

Zairin

Terrarian
I have a few things I've found. It's really fun and unique thus far. Really enjoying it.
  • When scrolled way out, there's a very very specific tile you need to hover over to get the mirror to pop up. A little annoying, but would be nice to have it register over the whole mirror icon.
  • In multiplayer, after disconnecting and reconnecting to a server, saved locations seem to disappear from the map. Is this intended, or is it required to find them over again after reconnecting?
Mounted Magic Mirrors v1.1.2.2, using tModLoaderServer.exe, v0.11.6.2
 

hamstar

Steampunker
I have a few things I've found. It's really fun and unique thus far. Really enjoying it.
  • When scrolled way out, there's a very very specific tile you need to hover over to get the mirror to pop up. A little annoying, but would be nice to have it register over the whole mirror icon.
  • In multiplayer, after disconnecting and reconnecting to a server, saved locations seem to disappear from the map. Is this intended, or is it required to find them over again after reconnecting?
Mounted Magic Mirrors v1.1.2.2, using tModLoaderServer.exe, v0.11.6.2
Those are both bugs.

Edit: Can you clarify #1? UI zoom? Map zoom?

Edit 2: I cannot replicate the multiplayer bug in a local MP test.
 
Last edited:

Zairin

Terrarian
Here's the hover issue. It seems to be whenever there's other hoverable things like NPCs, other players, yourself, nearby.
1581374121400.png


Here's a picture of my world after a fresh host and log in.
1581374180163.png


Here's after I refind the mirrors.
1581374960984.png
 

hamstar

Steampunker
Here's the hover issue. It seems to be whenever there's other hoverable things like NPCs, other players, yourself, nearby.
View attachment 235719

Here's a picture of my world after a fresh host and log in.
View attachment 235720

Here's after I refind the mirrors.
View attachment 235722
At full zoom, the detection radius shrinks for the icon. I'll try to address that at some point.

I'm still working on the client saving issue.

Edit: Yeah, I can't get this issue to replicate. Mind sending me your client.log and server.log when you encounter this issue (and after you exit a game)?
 
Last edited:

Zairin

Terrarian
Try only enabling the mirrors mod (and Mod Helpers, with it).
I've done some testing. Turned off ALL the mods, then turned them back on again, and it seems to work. However the actual issue is weird.

Any OLD mirrors placed down, don't work. So I made a NEW character and a NEW world, and my OLD character can go into the NEW world and see the NEW mirrors.

However the NEW character can go into the OLD world and the NEW mirror stays, but any found OLD mirrors that were placed before, doesn't retain after logging out.

EDIT: There's an island on a floating island, which for some reason disappears when I check my home mirror. Going over to it refinds it. HOWEVER, when I load in, and dont hover over or find my home mirror, and go to the island mirror, it's not found, as if I already found it before. I'm so confused and don't know why this is happening. Sometimes they work, others they stop for no reason.

Is it because of where they're placed? Do they need any specific criteria to maintain working? I feel like the distance from spawn may be influencing whether mirrors work or not.
 
Last edited:
Top Bottom