• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Begin your search for Journey's End information here and here. Please report bugs and issues for Journey's End here.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

Switch Switch World not loading

Akradon

Terrarian
So I've been playing an expert world on the Switch. Gone to play it today and it just won't load that world. It goes through the loading percentage, but then just the terraria logo, background and music remains.

All my other worlds seem to load. I've tried creating a new character, deleting the software and redownloading, loading different worlds. Not sure what else to try. I've sent a video to the Terraria logics twitter to see if they have any idea (link below).

MySimplePixel on Twitter

I'll be gutted if I've lost this world as I've spent the most time on it.

Any help will be appreciated.
 

Unit One

Moderator
Staff member
Moderator
So I've been playing an expert world on the Switch. Gone to play it today and it just won't load that world. It goes through the loading percentage, but then just the terraria logo, background and music remains.

All my other worlds seem to load. I've tried creating a new character, deleting the software and redownloading, loading different worlds. Not sure what else to try. I've sent a video to the Terraria logics twitter to see if they have any idea (link below).

MySimplePixel on Twitter

I'll be gutted if I've lost this world as I've spent the most time on it.

Any help will be appreciated.
Hi @Akradon, does docking it make any difference?
 

softpillow

Terrarian
I’m having the exact same issue! I took all the same steps. Docking doesn’t do anything. It’s such a bummer. :( I would love to know how to get my world back, I put a lot of work into it and was just starting to get the hang of things. Makes me wary of putting any more time into this game.
 

Rosterdam

Terrarian
I am having the same issue. So many hours into a large expert world... not loading... Makes me nervous to even start another world!
 

Batsu

Terrarian
Having the same issue... Really hoping I'll be able to recover it when ever you guys push out a patch.
 
I too had the same issue. Thankfully I only put about 7 hours into it but I get it if you spent tons of time on it. I just assumed it was a corrupted world and I just made another with the same character. Sorry about your losses bros, it really sucks
 

ClearConscious

Community Manager
Staff member
Pipeworks Studio
This is related to placing item frames and training dummies in your world. A fix for this should be included in the upcoming patch. Working on getting that out to everyone asap.
 
The same thing happened to me, but with this new patch, will we be able to get back into our worlds? I really don't want to start over, I already built a lot on my pre-hard mode expert world.
 

Nathan83

Terrarian
I too had the same issue. Thankfully I only put about 7 hours into it but I get it if you spent tons of time on it. I just assumed it was a corrupted world and I just made another with the same character. Sorry about your losses bros, it really sucks
So when the update comes out will we be able to get back into that world?
 

pyrowarz338

Terrarian
I have same problem, but I notice when I create dummy targets, thats when I realeze my world stop loading.
I too had the same issue. Thankfully I only put about 7 hours into it but I get it if you spent tons of time on it. I just assumed it was a corrupted world and I just made another with the same character. Sorry about your losses bros, it really sucks
 

NarwhalQueen

Terrarian
I’m also having this problem... I had put an item frame in my house, and the next time I tried to go on that world it wouldn’t load. I made a second world, but I would really like to use my other world again. Hoping that it is salvageable whenever the patch comes out
 

Unit One

Moderator
Staff member
Moderator
Im sorry but ive seen the asap response before and it took months to get bugs fixed.
I understand, and it can be frustrating waiting. Sometimes the duration of months IS as soon as it could possibly have been done. :merchantsmile: Game development and fixing bugs isn’t as easy as we sometimes think.
 

Akradon

Terrarian
Sorry I haven't been active. But thanks for all the responses. Hopefully the patch is out soon . On another note, I've noticed that the slimy saddle doesn't bounce off enemies?
 
Top Bottom