Tool TerraCustom for 1.3

R1ch4rd N1x0n

Terrarian
Something I've been wondering, if I want both types of ores, for say, both copper and tin, and keep their spawn rate at 100%, will I still see both the normal amount of copper, and the normal amount of tin? Essentially doubling how often I see that level of ore? Or will it be 50% tin and 50% copper?

Because I want both of the types of ores, but at the same time I don't want to be at an advantage by finding more ore.
 

jopojelly

Retinazer
tModLoader
Something I've been wondering, if I want both types of ores, for say, both copper and tin, and keep their spawn rate at 100%, will I still see both the normal amount of copper, and the normal amount of tin? Essentially doubling how often I see that level of ore? Or will it be 50% tin and 50% copper?

Because I want both of the types of ores, but at the same time I don't want to be at an advantage by finding more ore.
If you don't change anything, it'll be 50/50, the world won't have more ore tiles in total, just more variety
 

CandyApples

Terrarian
I get this when I try to make a world.



Microsoft.Xna.Framework.Content.ContentLoadException: Error loading "Images\TileCracks". File not found. ---> System.IO.FileNotFoundException: Could not find file 'E:\Program Files (x86)\Steam\steamapps\common\tModLoader\Content\Images\TileCracks.xnb'.
at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy, Boolean useLongPath, Boolean checkHost)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
at Microsoft.Xna.Framework.Content.ContentManager.OpenStream(String assetName)
--- End of inner exception stack trace ---
at Microsoft.Xna.Framework.Content.ContentManager.OpenStream(String assetName)
at Terraria.ModLoader.Engine.TMLContentManager.OpenStream(String assetName)
at Microsoft.Xna.Framework.Content.ContentManager.ReadAsset[T](String assetName, Action`1 recordDisposableObject)
at Microsoft.Xna.Framework.Content.ContentManager.Load[T](String assetName)
at Terraria.ModLoader.Engine.TMLContentManager.Load[T](String assetName)
at Terraria.Main.OurLoad[T](String path)
at Terraria.Main.LoadTextures()
at Terraria.Main.LoadContent()
at Microsoft.Xna.Framework.Game.DeviceCreated(Object sender, EventArgs e)
at Microsoft.Xna.Framework.GraphicsDeviceManager.OnDeviceCreated(Object sender, EventArgs args)
at Microsoft.Xna.Framework.GraphicsDeviceManager.CreateDevice(GraphicsDeviceInformation newInfo)
at Microsoft.Xna.Framework.GraphicsDeviceManager.ChangeDevice(Boolean forceCreate)
at Terraria.Main.SetGraphicsProfileInternal()
at Terraria.Main.SetGraphicsProfile(GraphicsProfile profile)
at Terraria.Main.LoadContent()
at Microsoft.Xna.Framework.Game.Initialize()
at Terraria.Main.ClientInitialize()
at Terraria.Main.Initialize()
at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
at Terraria.Program.LaunchGame_()

Edit: My enabled mods are: Calamity mod, Thorium mod, Mystic lands, and LargeWorldEnabler.

Edit2: I made the world smaller and changed some other settings and it worked fine.
 
Last edited:

Erebos

Terrarian
I can't build any world without either an Out of Memory error or just a straight up CTD.
Mods:
Thorium
Ancients Awakened
Elements Awakened
Extensible Inventory
HERO's Mod
Mod Helpers
Large World Enabler

World settings: anything larger than default "large" worlds, regardless of chest count (last attempt was less than 600 and got a CTD when it was almost done)


Update: I built a world with default height and exactly 10k width, but still had to turn down chests and ore spawn
 
Last edited:

Rgmemo

Spazmatism
I can't build any world without either an Out of Memory error or just a straight up CTD.
Mods:
Thorium
Ancients Awakened
Elements Awakened
Extensible Inventory
HERO's Mod
Mod Helpers
Large World Enabler

World settings: anything larger than default "large" worlds, regardless of chest count (last attempt was less than 600 and got a CTD when it was almost done)


Update: I built a world with default height and exactly 10k width, but still had to turn down chests and ore spawn
I think that's just to do with Terraria being 32-bit, having many large content mods and/or increasing the world size will lead to memory issues. I don't know if Terracustom has ever had the 64-bit support that would rectify this, and is still waiting on tModLoader 1.4
 

CalmMagma

Terrarian
Is there going to be a update for TModLoader v0.11.8.5? I really wanted to create a XL Calamity world, but i can't due to it's recent update requiring the latest version.
 

Zdog237

Terrarian
Will TerraCustom be updated to the latest tModLoader version? Calamity requires the latest version, and now I can't create an extra large world with it enabled.
 

jopojelly

Retinazer
tModLoader
Is it possible to negate the mod version check, as to load mods made for a later version of tmodloader?
No, there isn't a check, you are running into an error, the error is below the version reminder. The version reminder is just a hint as to the cause of the bug, not the bug.
 

R1ch4rd N1x0n

Terrarian
When Terracustom is out for 1.4, will it be possible to make custom worlds with the secret seeds, such as "For The Worthy" and "Drunk World?" Would be really cool to have a customized For The Worthy world.
 

Pewee

Terrarian
Hi! Thanks for terracustom and all youre other contributions to terraria it wouldn't be the same without.
I run in a weird problem, I created a world little bigger than a large world, with modified biomes etc. I have Thorium installed, when I play in solo or from a server I host on my PC everything is fine. But when I try to run the same World from a server from fragnet, The depth disappears, only water is left there, no pink tiles or anything else. The weapons and monsters from thorium are still there so its not the mod that isn't working, another mods that add tiles get the same problems (Furniture & fun), it add a garden. If I let the server create a world on its own everything is fine, the depth are there even if the world is way less interesting.... Your mod is the only way I know to have both evils on the map, and bigger temple/dungeon/ice biomes, more sky islands etc... Sorry for my english
I use the last version of terracustom and tmodloader, and the exact same moddlist. Same for the fragnet server.
Thank you again!

Here my moddlist:

[
"HamstarHelpers",
"PboneUtils",
"BossChecklist",
"SummonersAssociation",
"Fargowiltas",
"InventoryStations",
"ManaFruit",
"PlayerLocationSaving",
"VitalityMod",
"ThoriumMod",
"LookMod",
"BetterChests",
"ConfigurableMetalDetector",
"HEROsMod",
"WingsStatsAndHookStats",
"LansSharedMap",
"RecipeBrowser",
"NPCNameDisplay",
"BetterZoom",
"CheatSheet",
"BetterAutosave",
"ThoriumClassTagsConsistency",
"FishermanNPC",
"Terrarchitect",
"HelpfulHotkeys",
"WorldGenPreviewer",
"VeinMiner",
"WingSlot",
"EnemyMods",
"ReforgeArmor",
"AutoReroll",
"LargeWorldEnabler",
"WeaponOut",
"DirectionalMelee",
"BetterRespawn",
"SellSlotMod",
"MasterMode",
"SaveButton",
"FKBossHealthBar",
"PboneLib",
"NoHotbarPickup",
"W1KModRedux",
"MagicStorageExtra"
]

Edit: I just found that world not created by terracustom dont have modded tiles too, so its not related to terracustom, its a bug of the server itself. When the server create the world alone it works fine. If anyone as some information about this kind of problems, I 'll be glad to hear about it.
 
Last edited:

jopojelly

Retinazer
tModLoader
Hi! Thanks for terracustom and all youre other contributions to terraria it wouldn't be the same without.
I run in a weird problem, I created a world little bigger than a large world, with modified biomes etc. I have Thorium installed, when I play in solo or from a server I host on my PC everything is fine. But when I try to run the same World from a server from fragnet, The depth disappears, only water is left there, no pink tiles or anything else. The weapons and monsters from thorium are still there so its not the mod that isn't working, another mods that add tiles get the same problems (Furniture & fun), it add a garden. If I let the server create a world on its own everything is fine, the depth are there even if the world is way less interesting.... Your mod is the only way I know to have both evils on the map, and bigger temple/dungeon/ice biomes, more sky islands etc... Sorry for my english
I use the last version of terracustom and tmodloader, and the exact same moddlist. Same for the fragnet server.
Thank you again!

Here my moddlist:

[
"HamstarHelpers",
"PboneUtils",
"BossChecklist",
"SummonersAssociation",
"Fargowiltas",
"InventoryStations",
"ManaFruit",
"PlayerLocationSaving",
"VitalityMod",
"ThoriumMod",
"LookMod",
"BetterChests",
"ConfigurableMetalDetector",
"HEROsMod",
"WingsStatsAndHookStats",
"LansSharedMap",
"RecipeBrowser",
"NPCNameDisplay",
"BetterZoom",
"CheatSheet",
"BetterAutosave",
"ThoriumClassTagsConsistency",
"FishermanNPC",
"Terrarchitect",
"HelpfulHotkeys",
"WorldGenPreviewer",
"VeinMiner",
"WingSlot",
"EnemyMods",
"ReforgeArmor",
"AutoReroll",
"LargeWorldEnabler",
"WeaponOut",
"DirectionalMelee",
"BetterRespawn",
"SellSlotMod",
"MasterMode",
"SaveButton",
"FKBossHealthBar",
"PboneLib",
"NoHotbarPickup",
"W1KModRedux",
"MagicStorageExtra"
]

Edit: I just found that world not created by terracustom dont have modded tiles too, so its not related to terracustom, its a bug of the server itself. When the server create the world alone it works fine. If anyone as some information about this kind of problems, I 'll be glad to hear about it.
either your server is actually a terraria server, or you just forgot to copy over the .twld file in addition to the .wld file
 

PdizzleParker

Terrarian
I've been having a bit of a problem with actually getting to the world generation. Sometimes, when I click "create world" after I'm done customizing, It will crash and show an error message saying that access to favorites.json was denied. Sometimes this even happens when clicking "submit" after naming the world. I have attached the client.log file below. I doubt this crash has much to do with my list of mods, as not many of them change world generation, but I'll attach my mod list as well.
 

Attachments

  • client.log
    31.6 KB · Views: 31
  • enabled.json
    517 bytes · Views: 32

jopojelly

Retinazer
tModLoader
I've been having a bit of a problem with actually getting to the world generation. Sometimes, when I click "create world" after I'm done customizing, It will crash and show an error message saying that access to favorites.json was denied. Sometimes this even happens when clicking "submit" after naming the world. I have attached the client.log file below. I doubt this crash has much to do with my list of mods, as not many of them change world generation, but I'll attach my mod list as well.
earlier errors say access denied, so maybe there is some file permissions shenanigans happening. The favorites file mentioned can be renamed to favorites_backup.json as a test, that might make it work. Another issue might be an antivirus preventing the game from accessing files in the documents folder, but if it's not 100% of the time, that doesn't sound like it would be it.
 

PdizzleParker

Terrarian
earlier errors say access denied, so maybe there is some file permissions shenanigans happening. The favorites file mentioned can be renamed to favorites_backup.json as a test, that might make it work. Another issue might be an antivirus preventing the game from accessing files in the documents folder, but if it's not 100% of the time, that doesn't sound like it would be it.
Renaming the file worked, thanks!
 

123Nick

Terrarian
will this be updated to Tmodloader 0.11.8.6? right now its for Tmodloader version 0.11.8.1 IIRC, and when running terracustom i get an error that some mods are for Tmodloader version 0.11.8.5 and thus cant be used with Terracustom (which AFAIK IIRC is built on 0.11.8.1, right?)
 
Top Bottom