tModLoader The Spirit Mod!

Not sure if this is normal or a bug, but my summon minions cannot attack any of the new Ice Biome Above/Below ground enemies at all. Winterborns/Heralds are absolutely murdering me and for some reason cannot be targeted by summons.

Edit: I'll just keep updating bugs here instead of more posts. At this point im just continuing to see how broken the rest of it is, needs some serious work.

-Getting hit by Wyverns instantly crashes the game (Tested multiple times with/without the mod, it's only crashing with the mod)
-Dusking gets block locked in 2nd form when dashing forcing it to despawn (Tested twice, same result both times)
-Numerous weapons/Accessories don't actually follow their tool-tip effects, will make a full list for that as well.
 
Last edited:
Can't believe you changed the Seraph Armor to a non-summoner build, now yet again, Summoners are the only class with out an available upgrade at the start of Hardmode prior to mech bosses. I swear it's like re-logic personally messages the dev's and tells them to keep shafting summoners, was having fun with this mod until the start of hard mode where like always, summoning falls MASSIVELY off a cliff.
 
Last edited:
Just want to report an issue with the shadowmoor bow, I notice considerable frame drops after firing it too much, the framerate issues cease upon reloading the game.

No other weapon I've used so far has had this issue.
 
Crimbine got nerfed? I remember playing 1 year ago and the gun change bullet into lifestealing bullet, I checked the wiki and it says that crimbine shoot lifestealing bullets
 
I noticed that trying to craft the Winter's Wake, even when having 39 Cryolite Bars, won't happen. The weapon won't appear when being near the anvil. Bug?

Nevermind. The wiki says you only need Cryolite Bars, but you also need a Handgun from Gold Chests in the Dungeon. Hope it gets updated soon to reflect that tidbit of info!

Mod working on 1.4 ?

Also, no because tmodloader is still not working on 1.4. No tml mod will work on 1.4 until tml itself is working on 1.4.
 
Last edited:
oooooh i cant wait to see the new update, though i was a little spoiled when i looked at the open source mods... was that intentional....
 
Update 1.4.1 is out! Download it on the Mod Browser when updated, using the Tmodloader Direct Download Listing, or our Mediafire Link.
Brief Changelog
- 1 new boss, the Moon Jelly Wizard
- 1 new Event, the Jelly Deluge
- A new melee subclass, Clubs!
- A new sentry subclass, Arcane Zones
- Summoner Expansion, including 15 new weapons and a few special accessories and armor
- New Lore that can be found around the world in the form of books and artwork
- 98 new items
- 6 new enemies
- 7 new music tracks
- 3 new quests
- Numerous ambient changes in vanilla and modded biomes
- Dozens of bug fixes and improvements in both singleplayer and multiplayer

Direct Download Listing: http://javid.ddns.net/tModLoader/DirectModDownloadListing.php
Mediafire: SpiritMod

Full changelog attached below!
 

Attachments

  • 1.4.1changelog.txt
    10.2 KB · Views: 1,065
Hi! We are playing multiplayer with Spirit Mod and Thorium mod (only this two mods). We are still in pre-hardmode and we have issues.

Is it normal that EACH time we spend 30-60 seconds close to (or in the) marble biome it spawns a Beholder? Very very annoying. If it continues like this I will get a banner soon, lol. But... but... it is a mini-boss. We are tired killing him. It's not really fun after the 10th or 20th killed beholder...
Also when a beholder spawns, my Meteor summon from Thorium mod's Meteor Head Staff turns crazy, becoming immortal mob (and sometimes kills me if I forget to unspawn it).

And I have a suggestion. Decrepit Idol is a unique per world item, so in multiplayer only one person can pass its quest without visiting another world. Maybe making it not transforming in Scarab Idol is a thing?
 
Please update this page.
I know the Spirit Mod is amazing and all, but there's so much this page needs to update, it puts me off.
 
i'm not sure if i'm just really unlucky or my game is bugged, but i for the life of me cannot find the Interstellar shield core, i've killed 150 astral amalgams and have not found a single one
i'm plaything with spirit, thorium, magic storage and bosslist.
is anyone else looking for it and having any luck?
 
Back
Top Bottom