• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

tModLoader Magic Storage

Blazer Nitrox

Terrarian
Hey! This mod is awesome, and it takes care of a whole lot of issues I've had with vanilla Terraria (namely having all of my items immediately accessible via a single storage interface and being able to draw upon all of my storage for crafting materials). I've run into a problem however, which I can only reason is somehow tied to Mono. Specifically, Magic Storage, on a Linux server, with no mods enabled, causes... issues. I can place the Storage Heart and Unit, but interacting with the Unit causes all of my cosmetic equipment to be disabled (not unequipped; dyes still appear, however), and interacting with the Heart shows that no Units are connected. Logging out and back in causes a large chunk of the world to not load in properly on the client (note that no server restart happened; it's something about the communication between the client and server).

The reason I came to the conclusion I did is because of some testing:
Both the Windows client and the Linux server are running the most recent version of tModLoader (0.10.1.5 as of writing).
Testing in Singleplayer (on Windows) with my normal mod setup worked fine.
Testing in Multiplayer (via Host & Play) with my normal mod setup worked fine.
Testing in Multiplayer (on the remote Linux box) with only Magic Storage enabled still had the same problems.

I did notice, however, that trying to interact with the Storage Unit caused a message in the server console, something like "Error on Terraria.MessageBuffer" (I don't have the exact phrasing on hand; it seems to have subsequently deleted the log file that this showed up in).
The only difference I can think of between my version of Terraria and the Linux server's version is that the server is using Mono to emulate the .NET library, whereas Windows is running it directly.

If it is an issue with Mono, then those running MacOS should be able to reproduce the issue. If someone could get back to me on what's going on here, I'd be grateful (trying to play Calamity with my friends is going to be a lot more tedious without Magic Storage). I could also just be going insane and my guess as to what's happening is completely wrong, so feel free to correct me on anything I missed.
 
so i used to use the mod and it was great, recently i reinstalled terraria and tmodloader and loaded up and downloaded my old favorites, this one among them. however, when i put crafting stations inside the crafting interface, i can tell (i think) that they are connected, because it shows the number of items in my storage containers, but i cannot see any recipes. right clicking it also opens my inventory, and via the screenshots on the main page im not sure if that is supposed to happen?
upload_2019-4-13_21-0-39.png

it shows the word recipes, but i cannot see any and my inventory is taking up space above it. i can really only see half of the menu because my inventory opens up as well. i have tried disabling all mods besides magic storage and it is the same, even in a new world. i am running the fully updated terraria, tmodloader 10.1.5, and magic storage 4.3.3
 

Noobmaster

Terrarian
Hi i love this mod i just found it but i have a question you see i'm using a good amount of mods that add more crafting stations is there a way to hook up more then 10 stations to a magic storage? so like say i could have all the stations hooked up if the time comes i get them all?
 

Tsunami11

Terrarian
Doesn't work in multiplayer...... just toggles cosmetics when you try to open the " "chest" " ;(
I had this same issue with my friend, and i think it was because of a mismatch between the mods.
So i am hosting on a pc, but my friend is playing on a mac, and we found that he could not access the same storage that i could, but he could use the crafting interface. when he used the storage heart it would switch his vanity stuff. We also noticed that he could deposit things into the remote storage access (yellow one) and it would dissappear on his screen, but could be found in the storage on my screen.
dunno how or why, but just a couple of things that I found
we spent an hour 4/17/19 wondering why the storage was broke, before going back to the old chest basement
 

Blazer Nitrox

Terrarian
I had this same issue with my friend, and i think it was because of a mismatch between the mods.
So i am hosting on a pc, but my friend is playing on a mac, and we found that he could not access the same storage that i could, but he could use the crafting interface. when he used the storage heart it would switch his vanity stuff. We also noticed that he could deposit things into the remote storage access (yellow one) and it would dissappear on his screen, but could be found in the storage on my screen.
dunno how or why, but just a couple of things that I found
we spent an hour 4/17/19 wondering why the storage was broke, before going back to the old chest basement
You could be on to something. That sounds like the exact same issue I had. Let my try connecting to my Linux server from my Linux client box and see if I can reproduce the issue.

-----EDIT #1-----
It's definitely something related to non-Windows computers, then. I just tried connecting to both a Linux server and a Windows server via a Linux client, and both times the client failed to load. At this point I really do believe it's something with the Mono that Terraria ships with. Any chance you could get your friend to host a server with Magic Storage and see if you end up with the same issue?
 
Last edited:

nathan255

Terrarian
You could be on to something. That sounds like the exact same issue I had. Let my try connecting to my Linux server from my Linux client box and see if I can reproduce the issue.

-----EDIT #1-----
It's definitely something related to non-Windows computers, then. I just tried connecting to both a Linux server and a Windows server via a Linux client, and both times the client failed to load. At this point I really do believe it's something with the Mono that Terraria ships with. Any chance you could get your friend to host a server with Magic Storage and see if you end up with the same issue?
I'm having the exact same issue you guys have
My client is Linux, and I am connecting to my friends server (Windows)
He can use the storage fine, but my storage heart says "0/0 items"
 

Maxijaxus

Terrarian
How do I add more crafting stations to the crafting interface?

Really great mod btw. Couldn't get my head around it at first but it took away many storage problems while still being balanced and fair!
 

Blazer Nitrox

Terrarian
How do I add more crafting stations to the crafting interface?

Really great mod btw. Couldn't get my head around it at first but it took away many storage problems while still being balanced and fair!
From what I've seen, the only way you can have more crafting stations once you fill the UI is to build another crafting interface.
 

KungenSam

Terrarian
I shtere any way to move placed storage chests without emptying the whole thing? Realised too late that they are not in a place where I would like them to be.
 

Blazer Nitrox

Terrarian
I shtere any way to move placed storage chests without emptying the whole thing? Realised too late that they are not in a place where I would like them to be.
The only way I know of is to build out a new set and then hook them up using Storage Connectors. You'll need to move the storage heart though, since all the items will move to wherever the heart is. Otherwise, not as far as I know.
 

KungenSam

Terrarian
The only way I know of is to build out a new set and then hook them up using Storage Connectors. You'll need to move the storage heart though, since all the items will move to wherever the heart is. Otherwise, not as far as I know.
Would the items in the first unit not stay in that box? Would I need to actually empty it all out before moving it?
 

Nanobytez

Terrarian
None of the images load on the first page so half of the recipes are... well guessing games. Any way we can find the recipes or do I just start throwing stuff at the Guide until I get something? :p
 
Is there any plans to rework how recipies show up in the Crafting interface? It's a bit clunky to use it unless you know the name of the items you're looking to build

EDIT: I think adding a 'pages' option to the interface would probs be the best way to solve this sort of issue. Can be toggled too, in case people want the old style
 
Last edited:

alaswing

Plantera
Hello, i dont know why but iam getting this error everytime i open a heart, is a new world new pj.

upload_2019-4-30_16-33-27.png


does anybody know how to fix this?
 

Blazer Nitrox

Terrarian
Is there any plans to rework how recipies show up in the Crafting interface? It's a bit clunky to use it unless you know the name of the items you're looking to build

EDIT: I think adding a 'pages' option to the interface would probs be the best way to solve this sort of issue. Can be toggled too, in case people want the old style
I use Recipe Browser to make it a bit easier, but it still requires you to know at least one of the components you need, and you have to get it out of the storage, check it, put it in the storage, and then find the recipe. I like the idea though, recipe pages would at least make it a little more readable. Maybe sort by crafting station used, as well?

Hello, i dont know why but iam getting this error everytime i open a heart, is a new world new pj.

View attachment 220601

does anybody know how to fix this?
What versions of tModLoader and Magic Storage are you using? tModLoader's version will be in the bottom left of the title screen, and Magic Storage's version will be in the name in your Mod list. Also, are you running Windows, Mac, or Linux?

Does it come up every single time you try opening the storage heart? I've had it happen a few times, but immediately relaunching the game usually fixes whatever the issue is.
 
Top Bottom