• Labor of Love is here! Visit our Labor of Love thread for a special message from the team, a look at brand new Labor of Love merch, and the changelog (minus a few surprises 😉)

tModLoader Magic Storage

BryTerra

Terrarian
I used cheat sheet to duplicate a magic storage. Now i have a bugged one in the middle of my base and i cannot remove it. Trying to break it using pickaxe does not work and removing it by force using the paintbrush tool in cheat sheet will crash the game. Please help
 

MisterDjpookie

Terrarian
your mod is no longer on the tmod browser v 10.1.5, why is that ?
iwont use the newer version, its too buggy and a lot of mods are not up to date
 

StanleyABT

Terrarian
Been having a problem regarding the Crafting Interface. I know I'm not the only one with this problem, but none of the threads on multiple sites I've visited turned up any solutions.
Problem at hand:
-Crafting Interface is able to take crafting stations (anvil, furnace, etc.) but no recipes show. (Odd thing, not sure if this is always the case, but it takes any item, not just the stations, such as dirt.)
Yes, I have:
-the interface connected to the storage heart and storage components
-checked if all the settings within the interface work (the 'show uncraftable recipes','sort by item ID',etc.)
-the latest version of the mod
-other mods installed, but they shouldn't tamper with this mod

Everything else works to my knowledge, such as the Storage Heart, the only problem is the Crafting Interface.
20191021175023_1.jpg
 

josewups

Terrarian
Hey I just logged into my world and all of my storage units just went up and disappeared, what can i do to get all of my stuff back? I really don't want to grind the pillars again because the destroyer is still broken. I have auto-save on so is there a way to possibly use that old data to go back to?
 

Lostglaceon

Steampunker
Hi, is there any chance you can make the crafting unit take materials from the inventory?

Better idea, what if there was a button that would switch between the crafting interface and storage heart interface? It would only work if you had both connected to the system, of course. I honestly think that would be helpful if you were able to do that using the portable storage access too (requiring an upgrade to it, of course).
 

jukmifgguggh

Terrarian
I have a suggestion for a feature (sorry if this has been suggested already): an option in the crafting interface that lets you sort 'all recipes' by how close you are to crafting each recipe. As in it would sort by the ratio of materials you have to required materials. This might also need another option to omit craftable recipes
 

DarthNihilus

Terrarian
i'd really want 2 features:
1. a checkbox or smth to hide the vanilla madeable-by-hand recipes.
2. a "craft 10", "craft 100", "craft max" buttons
 

VagabondCrayon

Terrarian
I am encountering an issue and I am not sure if it is this mod or if it is a problem with conflicting mods. I just installed Magic Storage today, got it set up (I think?) correctly and moved all of my stuff into storage units. I then put down my Storage Crafting Interface and put different crafting terminals in it. When I went to craft something in it, nothing showed up as a crafting option. To give the benefit of the doubt, I tried multiple different search terms in the interface, going as basic as "chair", but nothing showed up. It is showing it connected to the rest of the computer, I am just not sure what is going on.
 

knooperpt

Terrarian
Is there a way to make magic storage region protected from hero's mod ? Hosting a multiplayer modpack , and that feature would be sick to have it
 

kiwiwikikwi

Terrarian
Once I place a crafting interface I can't mine it. Same issue in single player and a different multiplayer world. I'm assuming this is a bug?
 

Polymus

Terrarian
This has probably been asked already, but what's the possibility of adding in Quick Stack option to the Storage Heart(s)? At the very least while inside it? o:
 

Truthowl

Terrarian
Same as @kiwiwikikwi said. Once placed I cannot pick up the crafting interface. I only play single player so I don't know if it's the same in multiplayer. Am I missing something or is this a bug?

tModLoader v0.11.5
Magic Storage v0.4.3.5
Terraria v1.3.5.2
 
Last edited:

Speeder

Terrarian
I got a bunch of "out of index" erros on the UI (not internals it seems) when using the crafting, most often when adding new statations to it.

On my world, that was mostly unmodded (no big content mods) I added workbench, then alchemist table, then imbuing table, as soon I added the imbuing table I got that error.

Later I tried various mixes and always got that error until I settled to having only the alchemist and imbuing tables, no workbench.

It USUALLY worked, but I still got that error seemly at "random" while crafting items.
 

Barefoot Beast

Terrarian
I saw that white listing/ blacklisting features were on the to do list. Sounds great! I would like to request a simple config option to only allow stackable items to enter the storage system. I'm may be wrong, but I assume this would be a good deal easier than blacklist by individual items. Thanks for the fantastic mod!!!
 
Top Bottom