• Journey's End on PC - Find info here and here. Please report bugs and issues for PC 1.4 and 1.4.1 to Re-Logic here.
  • Journey's End on Mobile - Find info here. Report bugs for Mobile 1.4 to DR Studios at this link and give as much detail as possible.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Console and Switch - The latest news can be found here. To report a bug, please use this link.

Tool TEdit - Terraria Map Editor

POPoppet

Terrarian
I know it will take some time if he is planning to update, but does anyone know if the creator IS planning to updates this for 1.4?
 

Tunnel King

Terrarian
Administrator
I know it will take some time if he is planning to update, but does anyone know if the creator IS planning to updates this for 1.4?
I'm fairly sure that he is in the process of assessing what needs to be done. 1.4 is new to him as well, please give him time to make his decisions.
 

Feralwolf44

Terrarian
As of now, you can only view your world. Saving is broken, so you can't edit. I imagine that will be first priority next time BC is working.
 

Meltman

Skeletron Prime
Each time I open Beta4, it tells me that my version is not up to date. If I say "no", then manually check for updates, it gives me the same message again, but after I close it it gives me another message saying it is indeed up to date.
 
Last edited:

Flor3nce2456

Duke Fishron
Each time I open Beta4, it tells me that my version is not up to date. If I say "no", then manually check for updates, it gives me the same message again, but after I close it it gives me another message saying it is indeed up to date.
It's an early Beta, just ignore that message. It thinks that since you are not on the latest stable release, you surely must be behind. It didn't get the memo about early beta builds.
 

Samalas

Terrarian
Was curious if anyone could help see if there's a possible fix or if I'm just out of luck. I have the latest version, and have been backing up my worlds every time I make an edit, so far it hasn't been a problem but now I'm coming across something weird, not sure exactly what it is.

Using my backup world, if I load it in to Tedit everything comes up as it should. I can interact with the world through the mod like normal, saving works fine, opening those saves back up works fine. The problem seems to come in whenever I take a character in to that world in game, and it saves itself whenever I exit. If I do this and then open the world up in Tedit everything is broken, and saving the world in this state gives me a corrupt world message when trying to join it with a character.

The sky goes brown despite being the sky wall tile, nothing above hell loads correctly whenever I zoom in within the tool, it just stays the static colors instead of being the item models, and the 'World Properties' values are all completely wonky. I'm not sure if that last is the cause of the problem or a result of loading a corrupted world.

These pics are what I'm talking about if it helps any. The only edits that I've really done on the world up to this point was clearing/building a runway to fight the Wall of Flesh, and purifying corruption/hallow.

I can't seem to recreate the bug with other worlds. If i join them/exit and save in game I can open those up in Tedit just fine, so it's something I've done with this world in particular. Not the end of the world if it's just broken, I only just beat the WoF so very early all things considered.
 

Attachments

darthmorf

Moderator
Staff member
Moderator
Just wanted to say how glad I am to see this being updated to 1.4, and so quickly after launch too!
 

wym92

Terrarian
Was curious if anyone could help see if there's a possible fix or if I'm just out of luck. I have the latest version, and have been backing up my worlds every time I make an edit, so far it hasn't been a problem but now I'm coming across something weird, not sure exactly what it is.

Using my backup world, if I load it in to Tedit everything comes up as it should. I can interact with the world through the mod like normal, saving works fine, opening those saves back up works fine. The problem seems to come in whenever I take a character in to that world in game, and it saves itself whenever I exit. If I do this and then open the world up in Tedit everything is broken, and saving the world in this state gives me a corrupt world message when trying to join it with a character.

The sky goes brown despite being the sky wall tile, nothing above hell loads correctly whenever I zoom in within the tool, it just stays the static colors instead of being the item models, and the 'World Properties' values are all completely wonky. I'm not sure if that last is the cause of the problem or a result of loading a corrupted world.

These pics are what I'm talking about if it helps any. The only edits that I've really done on the world up to this point was clearing/building a runway to fight the Wall of Flesh, and purifying corruption/hallow.

I can't seem to recreate the bug with other worlds. If i join them/exit and save in game I can open those up in Tedit just fine, so it's something I've done with this world in particular. Not the end of the world if it's just broken, I only just beat the WoF so very early all things considered.
Tedit doesn't support version 1.4.0.3 yet, guess the latest update changed world file somehow.
 

Samalas

Terrarian
Tedit doesn't support version 1.4.0.3 yet, guess the latest update changed world file somehow.
Huh, seems that was it. I honestly don't remember seeing any update being pushed through Steam so I didn't think of that being an issue. Tedit 5 is out and supports 1.4.0.3, everything seems fine now!
 

The Atroxious

Terrarian
I've been trying to use TEdit to convert my world to Journey mode after realising how nice Journey mode actually is. Problem is, every time I try to load my world that contains a build I'm proud of so far, the loading just stops at "Calculating Colors...". I've waited for an hour+ to see if anything changes, but no, it's just stopped. The program isn't frozen. I can load fresh worlds, but the world I have a base on just stops mid load.

I tried making another build on a Journey mode world, which loaded into TEdit just fine after generation, but after I finished my main structure, I wanted to import some nice landscape features in because the surface of that world was flat and boring. When I tried to load that into TEdit, I got the same refusal to load past "Calculating Colors...". It seems as though the more you modify the world in-game, the less likely it is to load in TEdit. Is anyone else having this problem? Am I doing something wrong, or is this just a result of the utility being in beta?
 
Top Bottom