• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Begin your search for Journey's End information here and here. Please report bugs and issues for Journey's End here.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

Tool TerraCustom for 1.3

piousminion

Terrarian
I have not been able to run TerraCustom since May 16th at least. To try and solve the issue, I've uninstalled, wiped the folders manually, cleared the download cache, and reinstalled both Terraria and tModLoader from steam.

If I run TerraCustom from the Terraria Folder, it complains about "House_Banner_0.xnb", etc missing.
TerraCustom_v0.7_kRITBN2QHc.png

If I run it from the tModLoader folder, it complains about "TileCracks.xnb, etc missing.
TerraCustom_v0.7_6T4O0eIl0S.png

I think this should be added to this issue tracker on github if it has not been already, but let me know if I'm wrong. Thanks.
 

tanpro260196

Terrarian
I have not been able to run TerraCustom since May 16th at least. To try and solve the issue, I've uninstalled, wiped the folders manually, cleared the download cache, and reinstalled both Terraria and tModLoader from steam.

If I run TerraCustom from the Terraria Folder, it complains about "House_Banner_0.xnb", etc missing.

If I run it from the tModLoader folder, it complains about "TileCracks.xnb, etc missing.

I think this should be added to this issue tracker on github if it has not been already, but let me know if I'm wrong. Thanks.
Are you running it with 1.4?
 
Are you running it with 1.4?
I got the same error, when running it from the 1.4 installation folder. A different error occurs if you try to run it from the steam TModLoader folder. Right now, the only way to run TerraCustom is if you downgrade Terraria to 1.3.

In any case, I had notified Jopojelly early this morning, so they are aware of the problem. TerraCustom will need to be updated in order to work with Steam tmodloader.
 

Anubis

Terrarian
Can't wait for the update, been dying to make a custom world again for my boss arena. Keep up the good work!
 

Causener

Terrarian
Can't wait for the update, been dying to make a custom world again for my boss arena. Keep up the good work!
Same, I wish they would have included the option to generate a world with both Crimson and Corruption. I know the release date seed is available but too many other zany changes.
 

Hamburger

Eye of Cthulhu
I wish this was a feature in the console edition. I've made around fifty worlds, and none of them fit the criteria I have for a decent world. I know I'm replying to a five year old post, but I just love this and I wish I could be a part of it. Also, my favorite setting that I would use:
  • Blue dungeon on the right, surrounded by a forest
  • Normal moon
  • Glacier background
  • Corruption on the right side, with crimson right by it
  • A giant, open jungle with easy access to the temple
  • All of the ores possible
  • No living trees
  • An enchanted sword shrine
  • An oversized ocean
  • Round trees for the entire map
  • Snow biome, with evil bordering it, not in it
  • All of the land about as flat as a pancake, with the occasional slight hill
  • Water bolt at the front of the dungeon
  • One pyramid, facing the left in a single large desert on the left of the spawn
 

adizu

Terrarian
A quick fix (until its officially fixed) that worked for me:

Copy the Terraria (1.4) folder,
copy the tModloader folder into the copied folder and replace.
Then run TerraCustom from that folder.
 

Causener

Terrarian
A quick fix (until its officially fixed) that worked for me:

Copy the Terraria (1.4) folder,
copy the tModloader folder into the copied folder and replace.
Then run TerraCustom from that folder.
This lets you make a world but doesn't incorporate any world gen changes from 1.4 so rip.
 

Anubis

Terrarian
Same, I wish they would have included the option to generate a world with both Crimson and Corruption. I know the release date seed is available but too many other zany changes.
Not sure if you're talking about terracustom or 1.4, Because you can do that in terracustom it's an option in selecting the world evil.
 

Karretch

Terrarian
Since the drunk seed made it work, do you think it will be easier/possible to generate worlds with both evils without cheating around the system?
 

shyvor

Terrarian
Any suggestions what i'm doing wrong?
I'm trying to generate a world for XL however it keeps telling me there will be too many chests causing it to fail.
Estimated chests keeps at 1500 even when i put all sliders at 0%, its roughly at 1600-1700 with all the sliders at default (100%)
 

Riddix

Terrarian
Any suggestions what i'm doing wrong?
I'm trying to generate a world for XL however it keeps telling me there will be too many chests causing it to fail.
Estimated chests keeps at 1500 even when i put all sliders at 0%, its roughly at 1600-1700 with all the sliders at default (100%)
do you have mod that enables XL size?
 

jopojelly

Retinazer
tModLoader
Any suggestions what i'm doing wrong?
I'm trying to generate a world for XL however it keeps telling me there will be too many chests causing it to fail.
Estimated chests keeps at 1500 even when i put all sliders at 0%, its roughly at 1600-1700 with all the sliders at default (100%)
look at underground cabins, that's what is using all the chests.
 

_Majo_

Terrarian
I have not been able to run TerraCustom since May 16th at least. To try and solve the issue, I've uninstalled, wiped the folders manually, cleared the download cache, and reinstalled both Terraria and tModLoader from steam.

If I run TerraCustom from the Terraria Folder, it complains about "House_Banner_0.xnb", etc missing.

If I run it from the tModLoader folder, it complains about "TileCracks.xnb, etc missing.

I think this should be added to this issue tracker on github if it has not been already, but let me know if I'm wrong. Thanks.
this is because it isnt compatible with 1.4, the exact same error will pop out, when you try to run TModLoader
 
Top Bottom