1. For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
    Dismiss Notice

Switch Terraria Launches Today on Nintendo Switch!

Discussion in 'Console - 505 Games/Pipeworks Studio' started by Loki, Jun 26, 2019.

  1. Imatron

    Imatron Terrarian

    Just out of curiosity, what world sizes are people playing on? Im running on a small world, and it's ran mostly smoothly up until post Wall Of Flesh. Seems to save more often now, causing a temporary framerate drop, but other than that it's running well. If you guys are having trouble with larger worlds, might want to give a small world a try until they patch it.

    My game screen seems to be constantly zoomed in just a bit when docked though, cutting off the edges of the screen and a good chunk of the UI is obscured. I cant seem to zoom out, and it's like that in Terraria's main menu loading the game. Anyone else having this issue?
     
  2. TinyPantsAndrew

    TinyPantsAndrew Terrarian

    I’m not referring to that. On the PS4/Vita versions there was a singular yellow block to show where you would be placing an item. Now there is a grid that appears hovering behind the cursor which is crosshair and not the same cursor from PS4. Can this be changed?
     
  3. K1ngsl1me

    K1ngsl1me Terrarian

    Hey guys.

    Is there a way to lock on to enemies on the Switch version? I know you can use the touch screen which (kind of) auto aims, but this isn't very effective when fighting for example the WOF. I've tried all the buttons and can't see anything in the options. Please can anybody tell me if this is currently an option?

    Thanks
     
  4. GalaxyShard

    GalaxyShard Terrarian

    If theres keybinds on the switch version, check them all and you should find Lock On.
     
    K1ngsl1me likes this.
  5. Dannyxv8

    Dannyxv8 Terrarian

    Amazing, huh? Paying $30 for a 8 year old port and there's a world corruption bug that still hasn't been patched for more than a week.
     
  6. Acetheboss

    Acetheboss Plantera

    And yet I still see no reason NOT to buy the game, sure it has a few bugs, but it is still Terraria. If you didn't love terraria, then what are you still doing playing an "8 year old port", as you called it? They will fix bugs in time, I'm sure, but in the meantime, why can't we enjoy the game for what it is, not what it isn't?
     
    InstaFiz likes this.
  7. danknoodle

    danknoodle Terrarian

    Im having trouble with the metal detector not showing anything. Is there something wrong with it?
     
  8. Unit One

    Unit One Moderator Staff Member Moderator

    Hi @danknoodle, do you perhaps have the visibility of the metal detector turned off?
     
  9. Loki

    Loki Consigliere Staff Member Re-Logic Administrator

    Don't know - that is a question more for Pipeworks. My understanding is that performance was very sub-par... so that will have to be the focus there, raising the bar on those optimizations to get it to an acceptable level.

    Best way to sort that for now is via overscan settings on the TV itself (feel free to PM me if you want some help figuring out how)

    They are not corrupted, they just will not load - until the item frames/target dummy bug is patched (it is already fixed on the dev side, just waiting approval on that)

    This sounds like the known "Settling Liquids" thing - for now, docking the Switch can be a workaround. However, the fix for that is already in on the dev version, so just awaiting approval on that first patch so that it can get out to everyone.

    It is already fixed on the development side. You cannot just "release" things on consoles... there is a first party approval process that often takes several days.
     
    TheWorfer27 and ClearConscious like this.
  10. K1ngsl1me

    K1ngsl1me Terrarian

    Had a bug with the lantern. Doesn't appear above the players head. Submitted but wondered if anybody else has this issue? I have tried turning it on and off in the menu.
     
  11. Unit One

    Unit One Moderator Staff Member Moderator

    Hi @K1ngsl1me, I've seen others have this problem as well. As a workaround, try using the Magic Lantern from your hotbar (instead of equipping it in your light pet slot).

    You can send in bug reports straight to Pipeworks (the console developers) here: Terraria: Console & Mobile Bug Form
     
    K1ngsl1me likes this.
  12. Alathreon

    Alathreon Skeletron Prime

    Hi, I have an issue with the Imp Staff, because the Imp only last for one minute, I already reported that to the bug form.
    But I wanted to know if it is an intended behaviour, for only the Imp Staff and only for the Switch / Mobile?
     
  13. K1ngsl1me

    K1ngsl1me Terrarian

    Thanks very much I'll try that
    --- Double Post Merged, Jul 10, 2019, Original Post Date: Jul 10, 2019 ---
    Had this happen several times. The water flashes and I have to reset the game from the switch menu. It seems to happen when I've left it a long time in standby mode.
     

    Attached Files:

  14. TinyPantsAndrew

    TinyPantsAndrew Terrarian


    I really hate that I spent $30 on this for it to be ruined by the stupid intrusive grid cursor they chose to use. What a joke.
     
  15. InstaFiz

    InstaFiz Slime Collector

    You can change cursor modes, you know.
     
  16. Unit One

    Unit One Moderator Staff Member Moderator

    It’s not intended behavior. Thanks for sending in a report using the bug report form @Alathreon. Here it is for any others stopping by: Terraria: Console & Mobile Bug Form

    I’ve seen a few others with this problem @K1ngsl1me, and I think you’re on the right track correlating it with the game being left on for a bit. If you have a moment, I’d suggest sending in your pic with a bug report.
     
  17. TheWorfer27

    TheWorfer27 Retinazer

    It's sadly first has to be approved first, so it may take a while. And of course, it still has to be polished enough to be usable.
     
  18. GalaxyShard

    GalaxyShard Terrarian

    Its 2 years old, not 8. The worlds arent corrupted they just dont load due to a bug (which is fixed, the fix is being released soon.) and do you expect a bug to be fixed moments after a game releases?

    When1.3 comes there will be nothing exclusive to other devices. it is a bug

    There are other cursor modes. smart cursor, manual cursor. They are both great for different occasions, smart cursor is great for fast aiming or mining, manual is for building, breaking specific blocks, or if your aiming in just one direction
     
  19. K1ngsl1me

    K1ngsl1me Terrarian

    I sent a report already, thanks for the reply.
     
    TheWorfer27 and Unit One like this.
  20. Imatron

    Imatron Terrarian

    I see no responses to indicate that you've been told or have located the button to swap between curser modes. There are multiple controller schemes, so I don't know if this is the case for every scheme, but clicking the left thumb stick in (Would be called L3 on a PS3/4 controller I believe) will swap between the faster direction aim that I find good for fighting/non precise mining, and the grid curer mode on "Redigits Choice" control scheme. That should let you swap between the two as needed, particularly out of it when you have it selected.

    Using the Dpad seems to bring up the grid curser too, but I think using one of the thumb stick moves it back to the fast aim curser when the Dpad was used to select it.
    Edit: Nope, have to us the left thumb click to get back out in either case.

    So far the most control trouble I've had was having to manually map the toss button to throw a guide doll into the lava. That could really use a function to be tossed when "used" from the quick access bar without having to remap buttons.

    Have beaten Moon Lord multiple times on a small world, non-expert mode now. I'd say the game is running pretty smoothly, though I suspect the saving/screen lag that gets somewhat irritating during hard mode is because the faster spread is creating more save file updates to be quantified, and tapers off in severity once most of the world is fully hallowed/etc and has no spreading or updates to report.

    Still having trouble with docked screen cutting off UI and part of the game's view. Can't seem to get the achievement for touching the top/bottom of the world, but that may be because I couldn't see and assumed I had reached the top/bottom-most limit.
     
    Last edited: Jul 11, 2019
    TheWorfer27 likes this.