1. For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
    Dismiss Notice

tAPI Ingame Cheat Menu

Discussion in 'Released' started by PoroCYon, Sep 29, 2014.

Thread Status:
Not open for further replies.
Thread was lock by: Jeckel
Reason: Locked at Thread Creator request.
Lock date: 00:51 05-08-2016
  1. ShadowTiger

    ShadowTiger Plantera

    You don't have to build the latest version for tAPI r11. Just pop it right into the "Local" folder and you're good to go, as long as you have also very very recently installed tAPI r11 and the MCT recently as well. ... into their correct folders and all, of course.


    ... ... uh .. EDIT: Ninja'd. >.>
     
  2. Captainjellocube

    Captainjellocube Skeletron

    oh maybe I should read the posts I download things from
    sorry
    EDIT: I got it working
    btw good mod
     
    Last edited: Oct 19, 2014
  3. PoroCYon

    PoroCYon Terrarian

    Please don't double-post, edit the previous one.
     
  4. Captainjellocube

    Captainjellocube Skeletron

    for some reason I only have half of the mod?
    I can edit my player and world but I don't get ingame cheat menu function?
     
  5. Nim

    Nim Steampunker

    I'm having the same problem, I disabled all my other mods but still nothing
     
  6. zadum4ivii

    zadum4ivii Official Terrarian

    Please make another Time Changing. It is difficult to change time pressing +/- buttons...
    --- Double Post Merged, Oct 21, 2014 ---
    And yes. Only half of mod is working =\
     
  7. ImPaCtive

    ImPaCtive Terrarian

    'tAPI has stopped working' <- Everytime i try to enter a server
     
  8. phenox124

    phenox124 Terrarian

    Same problem here. I'll get an error log and post it, Unless, of course, you intentionally blocked multiplayer Use.

    Never mind, it's the same error I posted on your MCT thread(first screenshot you said wasn't related)
     
  9. PoroCYon

    PoroCYon Terrarian

    The 'I can't see the ingame buttons' bug seems quite common, but I cannot seem to reproduce it.
    If there is anything that could help me, could someone give me a minidump? (using either the task manager or Visual Studio, this requires admin privileges!)
     
  10. Kazzymodus

    Kazzymodus Lunatic Cultist

    I'm getting a division by zero error every time I set the game time speed to 0 after I sufficiently messed around with the world tab (mainly events like Pumpkin and Frost Moon), although that could just be a coincidence. First time I set it to 0 (before the messing around) everything worked as intended.

    [​IMG]
     
  11. PoroCYon

    PoroCYon Terrarian

    Looks like this (vanilla) bug isn't fixed in r11...

    EDIT: fixed in 12
    Code:
    * tAPI-Bot ([email protected]) has joined
    <tAPI-Bot> [tAPI] yoraiz0r pushed 2 new commits to master: http://git.io/1AB7FQ
    <tAPI-Bot> tAPI/master b769162 Yoraiz0r: dayRate = 0 fixes
    <tAPI-Bot> tAPI/master d09e7d6 Yoraiz0r: Merge branch 'master' of https://github.com/Arkhalis/tAPI
    * tAPI-Bot has left
    <Yoraiz0r> there we go
    
     
    Last edited: Oct 22, 2014
  12. Stereox

    Stereox Plantera

    Is this already updated for r12 ?
     
  13. PoroCYon

    PoroCYon Terrarian

    Not yet, becauseI was alseep. It's quite hard to code when sleeping.

    I'll update it, it'll be finished in a few hours.
     
    Wisp likes this.
  14. Eikester

    Eikester Official Terrarian

    but it still works fine in r12
     
  15. PoroCYon

    PoroCYon Terrarian

    Not quite, it'll throw some FieldNotFoundExceptions in the buff menu (BuffDef.name is renamed to BuffDef.byType, etc). (which is fixed now).
     
  16. Captainjellocube

    Captainjellocube Skeletron

    yessss I finally got full mod working for r11 I downloaded MCT for the 100 time and it showed up in game on the mods list
     
    Last edited: Oct 24, 2014
  17. Stereox

    Stereox Plantera

    lol, you're so fast
     
  18. I don't know how to install it. Can you please help me.
     
  19. Kazzymodus

    Kazzymodus Lunatic Cultist

    Getting this error when I attempt to reload my mods.

    System.NullReferenceException: Object reference not set to an instance of an object.
    at PoroCYon.ICM.Controls.ModFilter`1..ctor(ModBase base)
    at PoroCYon.ICM.Controls.NpcFilter..ctor(ModBase base)
    at PoroCYon.ICM.Menus.NpcUI.Init()
    at PoroCYon.MCT.UI.MctUI.AddCustomUI(CustomUI customUI) in C:\Users\x\Dropbox\PoroCYon.MCT\Mod Creation Tools\UI\MctUI.cs:line 202
    at PoroCYon.ICM.IcmMod.OnAllModsLoaded()
    at TAPI.Hooks.Call(Action[] ts)
    at TAPI.Mods.Load()

    (Put that x in the file path for privacy reasons)

    Using MCT 2.0.2.1 (updated today). Didn't have this problem before. No problems when ICM is disabled.
     
  20. PoroCYon

    PoroCYon Terrarian

    This is clearly an ICM bug.
    Can you download the PDB file of ICM and reproduce the bug (and give me the stack trace), so I can get the line number of the error?
     
Thread Status:
Not open for further replies.