tModLoader Magic Storage

Discussion in 'Works-in-Progress' started by blushiemagic, Apr 6, 2017.

  1. Creeper da Snek

    Creeper da Snek Plantera

    I'm pretty sure bluemagic can't do much about that; When you unloaded the mod, all the blocks turned into Test Objects (tModLoader's failsafe for unloaded blocks). Losing all the contents doesn't seem too far-fetched given the blocks were technically "replaced".
     
  2. Flamadragon

    Flamadragon Terrarian

    So do you think there is anything I can do to fix it?
     
  3. blushiemagic

    blushiemagic Retinazer

    That actually sounds like a bug with tModLoader, rather than this mod. We could try to find out what's going on and fix it for the next tModLoader update.
     
  4. Nighthawk

    Nighthawk Terrarian

    bluemagic123 do you have any idea what's causing the issue with the mod not working in multiplayer? I have v0.9.2.2 and it was working fine yesterday but now it's just toggling cosmetics and posting Error on message Terraria.MessageBuffer in the server console. CasperDaGhost had the same issue but "we fixed it now" and i have no idea what he means by his solution. Otherwise great mod, can't wait for a remote access to the inventory like a money trough.
     
    Last edited: Apr 9, 2017
  5. Dan Yami

    Dan Yami Skeletron Prime

    No, its your fault, the tile entities were destroyed when u loaded the world without the mod :p rip items
    --- Double Post Merged, Apr 9, 2017, Original Post Date: Apr 9, 2017 ---
    There is a remote access already :V
     
  6. Creeper da Snek

    Creeper da Snek Plantera

    Nighthawk means an object like the Money Trough, aka something to access the storage without having to place down a block to do so.
     
  7. blushiemagic

    blushiemagic Retinazer

    Hmm, does the server console give any more details than that?
     
  8. I found a crash

    How to reproduce: Search for anything such that only a single item shows up (I did this twice accidentally with Guide Voodoo Dolls, and a Blowpipe). Then, right click that item out of the storage. Instant crash to main menu. This also functions on stacks of items, so long as you take out all the items with right click. Notably, this also functions as a dupe glitch, because you still get the items back out of your storage but they'll still be in the storage when you log back in because it failed to save.
    Untitled.png
    Right Click the blowpipe (or any item you're removing the last of, leaving the storage "empty" during the search)


    Result
    Untitled2.png
     
  9. gunqqer

    gunqqer Terrarian

    When ever I try to open my system if my inv is closed all that happens is my vanity armour goes invisible. If my inv is open it flashes the storage window but it vanishes instantly. I'm using the latest version of tmodloader and the only other mod I have is reduced grinding
     
  10. Also, I had a bit of a request. Can you make it possible to search for things in the description of an item?
    For example, if I wanted to find the Grappling Hook but for some reason didn't remember its name, I could still search for the description in its tooltip, so that if I typed "Get over" then it'll show up.
    Similarly, I could type "Material" to show all stored materials, or maybe search for "Melee Damage" if I wanted to find my melee weapons.

    Could this sort of functionality be added? Is it even possible?
     
    neoselket likes this.
  11. Matakor

    Matakor Terrarian

    So, odd bug that may be caused by this mod, if I constantly place an item without letting up, I will crash. Easy to dupe, just place a wall constantly and fill a spot, but don't let up on the mouse. Then crash. :/
     
  12. blushiemagic

    blushiemagic Retinazer

    Thanks for the detailed error report! This bug has now been fixed for the next update.

    I'm not really sure what causes this, but in the next update I'll add some diagnostics that will hopefully pinpoint the problem. Do you still get this bug when reduced grinding is disabled?

    That's possible, but it would be pretty hard to actually implement (mostly because it would require copying over a huge chunk of code from the vanilla source then renaming all the variables).

    That's really odd. I'm unable to replicate the bug; does the game give you any error message?
     
  13. Dan Yami

    Dan Yami Skeletron Prime

    Great!
    Cant wait for da patch
     
    Joost8910 likes this.
  14. Matakor

    Matakor Terrarian

    It's a CTD, so not really. Might be a compat issue. I have a lot of mods.

    EDIT:: Actually, I think I found it.
    Index was out of range. Must be non-negative and less than the size of the collection.
    Parameter name: index
    at System.ThrowHelper.ThrowArgumentOutOfRangeException(ExceptionArgument argument, ExceptionResource resource)
    at MagicStorage.StorageGUI.SlotFocusLogic()
    at MagicStorage.StorageGUI.UpdateItemSlots()
    at MagicStorage.StorageGUI.Update(GameTime gameTime)
    at MagicStorage.MagicStorage.PostUpdateInput()
    at Terraria.ModLoader.ModHooks.PostUpdateInput()
    at Terraria.Main.DoUpdate(GameTime gameTime)
    at Terraria.Main.Update(GameTime gameTime)
     
    Last edited: Apr 10, 2017
  15. blushiemagic

    blushiemagic Retinazer

    v0.2
    -Now requires at least tModLoader v0.9.2.2 to load
    -You can now deactivate Storage Units with the new Storage Unit Wand
    -Vastly improved spritework
    -Fixed massive slowdowns on certain occassions
    -Fixed crash when right-click-withdrawing last item in display
    -Added logging to help diagnose errors
    -The storage GUI now displays item count and capacity across the entire network

    Huge thanks to @AdipemDragon for the spritework in this update!
     
  16. Caseratis

    Caseratis Skeletron

    So does this mean there is no fps drop? Because if so then this means I can actually play with this mod! Keep up the great work bluemagic!
     
  17. StarOcean

    StarOcean Terrarian

    Oh man have i got a funny story for you. Playing some modded terraria with my friends. 50 mods in total, including yours. And we are having this irritating issue, loot bags aren't dropping from mobs, summon npc potions don't summon, and a bunch of other issues. So i spend 2 hours going through the list removing mods one at a time to see which one is causing the issue, and by some dumb unluckiness your mod is the last one on the list, and also the one causing the issues. So i come here to make a bug report to try and solve the issue and boom. While i am TYPING THE REPORT... you post an update that fixes the issue. Do you hate me? Excuse my rudeness, i'm a little salty atm.
     
  18. Matakor

    Matakor Terrarian

    So, probably a minor issue, but shift-clicking items doesn't work from inventory to storage.
     
  19. Sapharan

    Sapharan Plantera

    Is it safe to update with all items in the network?
     
  20. Matakor

    Matakor Terrarian

    Yup, works fine.