• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

tModLoader The Thorium Mod

Lildev47

Terrarian
Hey when I try to enable the mod it says
error occured while loading ThoriumMod
System.Refelction.ReflectionTypeLoadException:Unable to load one or more of the requested types.
Retrieve the LoaderExcpetions propety for more information.
System.Reflection.RuntimeModule.GetTypes(RuntimeModule module)
at System.Reflection.RuntimeModule.GetTypes()
at System.Reflection.Assembly.GetTypes()
Can anyone help? Sorry if this isn't the place to post this.
ps,love the mod!
 

rdgd95

Terrarian
Haven't played thorium in a few months and when I came back to play it i updated the version and near my spawnpoint most of the background blocks are invisible, some crafting stations are missing the part of the tiles.
Where can I download older versions of this mod so I can play again on my world?
 
Is the MediaFire download up to date? I'm trying to upgrade my mod file to the newest version (1.6.1.4 at the time of writing), but no matter how many times I reinstall the mod or make sure tModLoader's up to date (which it doesn't seem to be, but I can't really fix that either), my game is still stuck on version 1.5.0.4. What should I do?
 
Last edited:

Senpai

Terrarian
This may seem like a silly question, but is there a way to install this without java? I know it's easy to get and install and use, but still.
 

Anej00

Terrarian
I don't know if this is the place to say this but, I have a error with Thorium mod. I can download it but when I try to enable the mod I always get the same error. I tried everything. I deleted evrything, I deleted tmodloader completely a couple of times, error persists. I have tried manually downloading Thorium mod, but I got the same error. I really don't know what to do it works fine for my friends but not me. I saw a couple of complaints on the internet of people getting this error, but I never found a solution anywhere, like it's this thing that happens to almost nobody.
This is the error:
[18/ERROR] [tML]: An error occurred while loading ThoriumMod
The mod(s) have been automatically been disabled.
System.Reflection.ReflectionTypeLoadException: Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information.
at System.Reflection.RuntimeModule.GetTypes(RuntimeModule module)
at System.Reflection.RuntimeModule.GetTypes()
at System.Reflection.Assembly.GetTypes()
at Terraria.ModLoader.Core.AssemblyManager.Instantiate(LoadedMod mod)
at Terraria.ModLoader.Core.AssemblyManager.<>c__DisplayClass10_0.<InstantiateMods>b__1(LoadedMod mod)
at System.Linq.Enumerable.WhereSelectListIterator`2.MoveNext()
at System.Collections.Generic.List`1..ctor(IEnumerable`1 collection)
at System.Linq.Enumerable.ToList[TSource](IEnumerable`1 source)
at Terraria.ModLoader.Core.AssemblyManager.InstantiateMods(List`1 modsToLoad, CancellationToken token)
at Terraria.ModLoader.Core.ModOrganizer.LoadMods(CancellationToken token)
at Terraria.ModLoader.ModLoader.Load(CancellationToken token)

I would really appreciate some help...
 

bloomcode

Terrarian
After a year i could play again with mods, i obviously installed the thorium mod and remember my lil' boy abbysion
A humanized fanart of the hermit crab boy
abb.png
 

Vangormel

Terrarian
Simple Broom does not give the relevant pet buff, so the only way of removing the pet is quitting the game.
I have not tested any other pets, just something I noticed with that one.
 

Backrevol

Skeletron Prime
Sorry for off topic but does anyone know an accessory that blocks natural health regeneration?That you have to heal will only potions and buff from the campfire / heart lamp
 
I saw a few people above with this problem but ill post my issue too, after coming to my thorium world, which I haven't played since September, furniture disappears when I walk up to it, but when I walk away from it, it appears again. Now, this is purely visual but I have a glitched Thorium Anvil and Grim Pedestal which only the top half of the blocks show and when I try to break them, it crashes the game. I had a hellforge and piggy bank on top of crafting table there as well but I could remove those with t-edit. I made a copy of my world and tested to see if it was thorium's problem and it was. I disabled all other mods, went on the world with thorium only, and the furniture glitched. disabled the thorium mod and went on the copy world, everything is vanilla, everything was fine. Also, were the butterflies removed? I come on to see they are now unknown items
 

Attachments

notjoji

Terrarian
Thorium seems to make it so that when I try to generate a new world, it just gets stuck on "Placing Statues", is there a fix to this?
 

Nyther

Terrarian
After a few days without playing as a healer I come back to see that my healing bonus is just gone. I have paladin armor and some other items but I have 0 bonus healing and my healing is worse than drinking potions. I dont think the class received a mass nerf, does anyone have a solution please?
 

Vaugher

Terrarian
I have an oddly specific issue. I play on my friend's server, and I just got the Whispering set, which is supposed to spawn tentacles around you. It works as stated in singleplayer and multiplayer if I host - but when I connect to my friend's server all I see are the particle effects of the tentacles trying to spawn continuously, without ever spawning. Any ideas why? The server modlist is as follows:

Thorium
Recipe Browser
No More Tombs
Faster Tools
Begone, Evil!
Crystilium
Critter Craze
Boss Checklist
 

Grimwolf

Terrarian
The bat minions from Viscount's Cane prevent any weapons from harming an enemy while the bat is attacking them. From trying to look into it, this seems to be an issue caused by the bats dealing rapid hits of "piercing" damage. When an enemy is taking lots of piercing damage, it prevents damage from other sources.
 
Top Bottom