Not open for further replies.
Sorry to already be posting a complaint but... It's a bit... "Bleached"? the whole thing feels so pale, the text is hard for me to make out in places because there's not enough contrast. QwQ
I have, it's better at least. Also, the Tweaks List, the button to start did not show up for me until I clicked it. Also, the entire thing goes blank/white if I tab over to something else, which may have been what turned my Tweak button invisible.

Edit: The mint theme doesn't seem to extend to every menu, some of these are incredibly hard to read. QwQ;
Last edited:
There is a small typo in the tutorial for creating a backup where it says "Your backup will be thus be non-vanilla."


  • tt2.png
    38 KB · Views: 2,213
I really think that this thing needs an option to make permanent modifications like the old one had. I'm not too fond of having to make shortcuts or load up the tweaker every time I want to run things. Also... is there a way you can make it where we can outright delete a field from an item in the omnipatcher so it reverts to a default value? I want to delete the tileboost field of the shroomite digging claw and see if it gets rid of the range penalty since it'd likely revert to default of no benefit nor penalty.
Last edited:
One annoying thing I have noticed is that the 'buffTime' variable is artificially limited to 100000 in TT2. The game supports higher, and some items ingame have higher than that by default (Pumpkin Pie has 45 min or 162000 for example). Tried to make all food items last an hour (or 216000), and it obviously was not possible in TT2 (but was possible in TT1).

From a usability perspective, it would also be nice to be able to add custom names to 'Modify Any Item' Omnipatcher tweaks. If you have several entries, and want to find some specific item, it can get confusing fast. Even showing just the ID in the name would be nice.

If you have 10 items now, and want to change a specific one, you have to press 'Edit' and then press 'Show/Hide' on each and every one until you find the ID you are looking for.

Beyond that, the new approach is much nicer. Thank you for your hard work. :)
I noticed that you made it where you can change the book of skull's penetration amount. Can you do the same with Golden Shower? I really miss it's infinite piercing ability that it used to have before it was nerfed.
Either way I really have to say I appreciate all the hard work and effort you've put into this utility. Frankly, the fact they've nerfed stuff with the 1.3 patch after literally years of people thinking was final is just...I dunno..wrong almost. Being able to unnerf most of the stuff that was nerfed really breathes new life into this game. And the funny thing is, even with everything entirely unnerfed, in expert mode, it's still a challenge, even the mightiest of gear is not enough to simply carry you through the game.
Hi, this tool has been working great so far! Love it. I did run into a problem though, whenever I open the tweaked version of terraria, the whole game is muted. The audio settings are all set to full, I checked. Still no sounds.

Anything I can do to fix this?
Here's the system info. This is what you meant, right?
The blacked out parts with scribbles are just censors of my name.

The log file's here too.


  • ptlc_log_2017-07-18-
    96.9 KB · Views: 422
Was there ever talk about set bonuses on armours and things such as the nerf of the specter hood being removable? Things such as mining speed bonuses being applied to anything, say i want to make the Architect Gizmo Pack the ultimate building tool so i give it a mining speed bonus as well.

You know like the Celestial Stone.

Edit: Also is there a way to make this strictly expert mode?
Im noticing that Duke Fishron has 50000 hp in normal but in expert he has 60000. I would like to only modify his expert mode values. has some fun new features, one of which that looked exceptionally cool, that being the Modify Prefixes option added.
Unfortunately, using this modification at all will cause the TTApplicator to respond with "The tweak ID: 3200 failed to patch successfully" when launching.
Upon some investigation, it seems that this will always happen when this modification is present, even if it didn't change anything.

For example:
- I select the first prefix on the list, 'Hard.'
- In the list below, I touch nothing, and leave it with just "Defense: 1"
- None of the boxes are checked and the number fields are left blank
- Press 'Done."
- Save and then launch.

Even having done nothing to modify any prefix, this option just refuses to boot. Could I be doing something wrong here? Am I mistaken?
I cannot tell you how completely tickled pink I am that you added golden shower like I requested. I can finally enjoy the unnerfed infinite piercing version once more. Thank you, thank you, thank you.
Not open for further replies.
Top Bottom