PC 1.3.2 Changelog

Discussion in 'PC - Re-Logic' started by Safeman, Jul 19, 2016.

Thread Status:
Not open for further replies.
Thread was lock by: Aurora3500
Reason: Thread Purpose has been Served
Lock date: 15:09 23-11-2016
  1. FairyPrincessSerenity

    FairyPrincessSerenity Headless Horseman

    Wait, wait, wait, hold up now. He's a lizard man? I never even noticed. I knew he was inhuman, but...
    Well what do you know, maybe he'll run for public office.
     
  2. Ilmarinen

    Ilmarinen Santa-NK1

    And also maybe a restless ghost.
     
  3. Exodus Starlit

    Exodus Starlit Dungeon Spirit

    Angler don't die but run away, if he could die game could be for +18 years old people.
     
  4. CthuluIsSpy

    CthuluIsSpy Terrarian

    Did you miss the 1.1 update, when Clowns could destroy blocks with their bombs?
    It was a frustrating time. It will not be missed.
     
  5. CthuluIsSpy

    CthuluIsSpy Terrarian

    Throwing weapons need an upgrade in general.
    Thrower update when :D?
    --- Double Post Merged, Jul 22, 2016 ---
    If you have a world that's already in hardworld when the patch hits, it won't trigger the choose-your-evil option.
    What you need to do is make a small world, and go kill the WoF. Then exit that world, go to create a world. The option should be available after world size.
    I find that the Drill Containment unit is useful for this purpose, as you can quicky go to hell and kill the WoF. Remember to take a voodoo doll with you from your completed world.
     
  6. Exodus Starlit

    Exodus Starlit Dungeon Spirit

    It is nice that phaseblades and phasesabers have now different item ID.I forgot they same item ID, it isn't only item what got different item Id like beggining ore Pickaxes, shortsword, broadswords, axes and hammers.
    Since they have now different item ID they can have too different sprite, phasesabers with new sprite look like a upgraded version for sure.
     
  7. Hundjäger18

    Hundjäger18 The Destroyer

    You just need to load a hardmode world to unlock the choice menu.
     
  8. CthuluIsSpy

    CthuluIsSpy Terrarian

    Didn't work for me. I loaded my world, tried to get the menu on a new world. Didn't work.
    I killed the WoF on a new world and then it worked.
     
  9. Hundjäger18

    Hundjäger18 The Destroyer

    Weird, was the world you loaded on expert or normal? Mine was expert and worked.
     
  10. CthuluIsSpy

    CthuluIsSpy Terrarian

    Mine was expert as well. Maybe it was because it was in hardmode for a while or something. I had already killed the moonlord about 2 days before the patch hit.
     
  11. Hundjäger18

    Hundjäger18 The Destroyer

    Mine had ages of beating moonlord, my world was crimson, yours?
    Trying to identify the problem.
     
  12. CthuluIsSpy

    CthuluIsSpy Terrarian

    Ah, I had a corruption world. Might be a weird glitch.
     
  13. Blender Nova

    Blender Nova Terrarian

    Inside the treasure bag
     
  14. zenmai

    zenmai Terrarian

    by the way ···
    Jungle mimic is still not been introduced?
     
  15. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    Just verified again, and *loading* a hardmode world should be enough to trigger it. I reset my data so that I'd lose the option, re-opened a HM world, and it popped back up again.

    Jungle Mimic was cut in 1.3. The code for it is just still in the game.
     
  16. Voyager

    Voyager Headless Horseman

    If they added a jungle mimic they would have to add an underworld mimic and a desert mimic.
     
  17. zenmai

    zenmai Terrarian

     
  18. Feaw

    Feaw Spazmatism

    I found a bug;

    [​IMG]

    Just used painted stone blocks and lava buckets.
     
  19. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    I've got this bug reported already from some time ago, but good catch. :)

    Have to? Is there a rule book somewhere I don't know about? :p
     
    Hundjäger18 and Exodus Starlit like this.
  20. BatMoon

    BatMoon Terrarian

    Party hard!!!!
     
Thread Status:
Not open for further replies.