Tool TerraCustom for 1.3

Not sure if this has been answered before, but does anyone know if there is a way to fix this:

I don't mind if it is another mod or something, but it just been kinda bugging me slightly... ^-^"
Also, world is a 16800×2400 world
I read the mac readme.txt, and I couldn't find where to put the .dll files. am I just blind, or are the instructions somewhere else? Thanks for any help!!
mhh - with tmodloader going 64bit .... it is now possible to have "MUCH" bigger worlds ?? - would be nice ;)

On this note, I would actually like to request a 64-bit version of this made using the 64-bit tmodloader.
As of right now, it's pretty much impossible for me to use this to create worlds for the mod packs I use in the 64-bit game, as I run out of memory too fast.

I understand if it might take a while or if you might not want to, but I would very much appreciate it. If not, maybe you could ask if somebody else wants to try.
I get this error every time i try to make a world

Index was outside the bounds of the array.
at Terraria.WorldGen.GrowEpicTree(Int32 i, Int32 y)
at Terraria.WorldGen.<>c.<generateWorld>b__261_75(GenerationProgress progress)
at Terraria.GameContent.Generation.PassLegacy.Apply(GenerationProgress progress)
at Terraria.World.Generation.WorldGenerator.GenerateWorld(GenerationProgress progress)
at Terraria.WorldGen.generateWorld(Int32 seed, GenerationProgress customProgressObject)
at Terraria.WorldGen.do_worldGenCallBack(Object threadContext)
at Terraria.WorldGen.worldGenCallBack(Object threadContext)

What does it mean and how do i fix it?

Edit: It stopped happening when set the tree height down so it was probably that
Last edited:
When ever I try to create a world using TerraCustom i always get this error:
Exception of type 'System.OutOfMemoryException' was thrown.
at Terraria.WorldGen.clearWorld()
at Terraria.WorldGen.do_worldGenCallBack(Object threadContext)
at Terraria.WorldGen.worldGenCallBack(Object threadContext)

EDIT: I tried it with just the normal settings but have it so it saves it in the tmodloader world folder and it worked for a couple of seconds then crashed with no error message!

EDIT2: I fixed it by disabling Large World Enabler and World Gen Viewer
Last edited:
u should add "No Surface" in challenge option so u can spawn in cave.
[doublepost=1554426579,1554426198][/doublepost]but,thx JopoJelly finally i can make a world with DESERT and ANTHILL
Top Bottom