• Switch 1.4: New patch released Jan 18, details are here. Read the full release details here. Report bugs here.

**REPORTED** Replaced Journey's Beginning Song Weirdness with Music Packs

Clooless

Empress of Light
Steam or GOG
Steam
Single Player/Multiplayer
Single
Operating System
Windows 10
Terraria Version
1.4.2.2
Controls Used
Keyboard/Mouse
So as I understood how the "Journey's Beginning" song worked pre-1.4.2, based on this small statement in the second paragraph of this tool page: Tool - Quick Wave Bank - An easy, no-hassle Wave Bank creator
As of Terraria 1.4, the Title screen track is now split into an Intro and Main parts (numbers 50 and 51).
The Intro plays for a fixed length of time until the Main track begin playing. The Intro track will not loop. Meaning you will be met with silence until the fixed time has passed.
The version of the song including the intro (50) would play for 1:24, which is the exact duration of the vanilla song, before it would start the version without the intro (51) to permanently loop.

I had edited my tracks for a 1.4.1 wavebank to suit this, with 50 being cut at 1:24, and 51 being cut from 1:24 to a point that loops well. The music would work like this, without problem.

EDIT: Apparently, as per MadaxTheShadow's findings, this was always wrong, and track 50 could be any length in wavebanks and work fine. The whole 1:24 thing is pointless and can be disregarded.

Upon the 1.4.2 update, I converted my wavebank to a Music Pack, and continued to include my specially-edited versions of 50 and 51, however this time things were strange: upon boot-up with the pack enabled, there would be a skip in 50 at the point the vanilla intro would normally end, but it would continue as regular afterward. More concerning is that when 50's 1:24 duration had elapsed, it would continue to loop 50 instead of ever playing 51, and 51 would only play when the title screen is re-entered from in-game or the pack is reloaded.

Upon some experimenting, I made a version of the pack in which 50 is only my song's intro, instead of cut at 1:24, and 51 is a loop stemmed from the intro. This version of the pack actually showcases the problem much better: 50 will skip upon the Re-Logic fadeout, but continue as normal, until it ends, in which it will continue to loop 50 instead of playing 51.

Here is downloads to the packs, with just tracks 50 and 51 for testing convenience:

Cut at 1:24 version:
Intro only version:

My songs are using the .wav format.
(EDIT: I've tried the songs in .ogg as well, same thing happens...)
 
Last edited:

Clooless

Empress of Light
So it seems, clarifying everything above, that track 50 in any music pack will always loop (and skip slightly on the Re-Logic fade-out), and 51 will only ever play by re-entering the title screen in-game or reloading the pack.
I verified this using this pack, which features 2 different songs for 50 and 51:
 

MadaxTheShadow

Official Terrarian
I would to clarify that track 50 does NOT need to have a fixed length. I don't know how trigger segfault came to that conclusion, but I have had track 50 in older versions be both a minute long and only a few seconds, worked perfectly for each. Music packs do loop 50, though, rather than transitioning to 51
 

Wammyve

The Destroyer
I have this problem as well. My custom file for 50 is only a few seconds long and the idea was that it's supposed to transition into 51 for a (hopefully) flawless loop. However, the game keeps on looping 50 which results in the player never getting to hear the intended loop. Also not sure if it's just me, but after the Re-Logic intro fades to black, the game lags slightly which causes the custom title music to freeze for a split second and then continue playing. The game never seems to lag like that when track 50 is left to default.
 

LuciousTPK

Skeletron
I am having this issue myself, I tested all three audio formats, I tested different lengths, I even tested it by recording the intro audio and then replacing the intro audio with the intro audio itself within the resource pack and the same issue comes up. I also downloaded other resource packs with track 50 replaced as well and the same issue comes up. I get this distinct feeling that track 50 is hard coded in some different way that sets it apart from the other tracks that got looked over when the resource pack system got implemented. My theory is that the code that tells the game to loop audio isn't the code that is used when playing audio from the resource pack in question (especially when the resource pack uses three different audio formats while terraria uses the .xmb format instead). Instead enabling a resource pack likely flags what triggers are used for the tracks that are being replaced as disabled and instead a seperate line of code tells the game to call for the audio from the resource pack and loops that audio instead. I believe the issue is that this extension to the triggers calls for the track to be looped, which makes sense since 99% of the tracks are looped, but when that bit of code was copied into each trigger with minor edits the specification that when track 50 is called that it should only play once might have been skipped over. This is just a theory from someone who has not seen the code, nor understands how it works at all, but seems like a reasonable assertation of how such an issue could exist.
 

Clooless

Empress of Light
I've done a bit of testing in the most recent version, 1.4.2.3, and it appears this bug is fixed for all but ogg format. If Music_50 is a wav or mp3, the track will properly* change to whatever is chosen for Music_51, but only if it is an ogg will it continue to loop. However, Music_50 will still experience a small skip if it is longer than the Re-Logic intro, regardless of filetype. Also, and maybe it's just a symptom of using different filetypes in the same music pack, but it seems mp3 and wav are a bit rough with looping- there's a little skip I hear on looping Music_51 that only happens with wav and mp3. *There's also a skip when transitioning from Music_50 to Music_51, however due to the looping bug still being present with ogg formats I am not able to see if this particular skip still happens when using ogg.
 
Top Bottom