• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Begin your search for Journey's End information here and here. Please report bugs and issues for Journey's End here.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

Vipix' Toolbox

Antares

Terrarian
Greetings. Just stopping by to show my interest in this mod. Wish I could use it, but since we don't play alone, it is unfortunately unavailable for us. Hope that can be remedied. Cheers!
 

Echoherb

Terrarian
Swap Pickaxe no longer works as far as I can tell. I haven't gotten it to swap anything at all no matter what I try it on and what I have in my inventory.
 

StickyQuote

Spazmatism
Ooooh~! Idea~! Do you think something like a sort of reverse rocket launcher would be possible? You know how explosives blow up terrain? Well, what about a gun where you put in a tile you want(uses said tile as ammo or condense the explosive radius in number of tiles displaced and craft them into a singular 'rocket') and it basically explodes INTO whatever that tile you selected was. If it would be too much, could always make it work for only dirt, stone, maybe a couple other blocks, etc. Essentially, a way to quickly fill areas with blocks for big building projects, filling with sand, dirt, stone, etc.

Could end up being like rope in how that if rope wouldn't fit in that space, it won't spawn, and maybe it drops the 'wasted' blocks from the created rocket! Sounds like a weird and complex idea, but basically TL;DR: Sand Gun but better and not meant to be an actual weapon.
 

Kolaris8472

Terrarian
I'd so much love to use this mod if you ever get it working in multiplayer. Though in fiddling with it in SP, I can't seem to figure out how to work the Rattlesnake Wand. There is no icon when hovering over sand, no effect, and the rod is invisible when doing the weapon "swing" animation.
 

Maxijaxus

Terrarian
Just wondering, when does the painter sell the Color Pallete? In your post, it said that he sells it (I think) but when I checked on him, he only sells the classic stuff. Help?
 

Liam Molloy

Terrarian
Enjoying the mod so much especially the smart hammer, would be good if it had a feature that repeats the last block change to make hoiks easier :p.
Also, cannot figure out how to use the smart pick... might be bugged?
 

ZephaniahNoah

Terrarian
I love this mod! The unstable staff is super useful. I had an idea for the smart-hammer. Instead of clicking to change the shape of a block you could right click to set the shape. Then left click would hammer the block to the set shape without reopening the menu. I feel like right now it's just as fast as using a normal hammer. Great mod anyways! That's my only critique. I have a request though. Could you add a tool like an upgrade to the Actuation Rod that can change the state of blocks without needing an actuator on that block?
 

Hidden Tetrahedron

Steampunker
Suggestion:
Create a "block placing wand" or "BiomaFormer" (as i nickname it)
When you right click with it, it opens an interface(fixed, not around mouse) with an item slot and 3 "bulbs" you can click to activate.
What it does when you left click with it is: It places the block that sits on its item slot as long as you have some in your inventory. And it places in a area starting form 2x2, 3x3, and 4x4 depending on how many "bulbs" you have activated.

It could be crafted with some drop from post Moon Lord and the Greater Wand.
Suggestion: Make ML drop a new gem "Moon gem" that drops only once per player, said gem would be the crafting ingredient.
 

Cirom

Plantera
Has the latest tModLoader update (...1.4?) broken the mod? I can't seem to get the Palette to work anymore, and I definitely have paints in my inventory. Tried red, black and brown (brown definitely worked before) but no results, I'm just unable to paint anymore.

EDIT: Hm. Inexplicably it's started working again. I'll have to look further into this one.
 
Last edited:

Wintar

Duke Fishron
The TModLoader's Mod Browser has an outdated version. Server's won't work with it, but TModLoader itself seems to. The download on this page is not outdated, though
 

Lyrael Rayne

Terrarian
Hi all. I wanted to use this on a server and managed to make a version which loads using the source on GitHub. I've submitted my patch to Vipix on GitHub, but until then I've put up a working build here: LyraelRayne/VipixToolBox

Very minimal testing has been done other than starting the server and checking that the tools appear to work. YMMV. Your World Might Corrupt. But it might not.
 

Lyrael Rayne

Terrarian
It's been months since I asked this question and no one answers. I would like to know if this is a bug on my computer or is it the creator of the mod that should fix the bug.

It doesn't work. It looks like the code to register it isn't there. I tried adding it but the game crashed every time I tried to trigger the UI. I assume that the feature wasn't finished. Vipix hasn't touched the mod (at least on GitHub) for two years so I think it's safe to say that it won't be finished.

If you mainly just want to change the colour of grass you could try using regular grass and painting it using the palette, which does work quite nicely.

EDIT: This is inaccurate, see my next reply for fixed version.
 
Last edited:
Top Bottom