Mobile Terraria Mobile Bugs & Issues Status

Not open for further replies.


505 Games
Important Note: We will keep these posts updated as further information comes in from the community and/or development team. Please read the fixed and reported bug lists below before submitting this form to reduce duplicates. The form is the most efficient way for the dev team to sort and address each BUG entry. For all other issues please use the Customer Support Portal:
Hi everyone,

Well, it’s been a crazy week since the 1.2.4 update was launched on mobile, to say the least! :) We’ve been thrilled to see what players have been discovering, but that also means there have been a number of new bugs coming up that our teams need to squash. As part of our mission to communicate as clearly and openly with you as possible, we will be using this thread to keep track of and update issues with the mobile versions of Terraria, so that you can see where we stand on each of them.

We’ll also include general updates at the top about some of the biggest issues affecting each individual platform, and where we currently stand. We all believe it’s just as important for you to know about what’s being fixed as it is to know when we still can’t reproduce a problem or don’t have a solution yet.

Things may seem slightly messy at first as we filter all the data and get everything organized and vetted against our own internal systems, but again, this will serve as a great one-stop place for you to see what’s going on with the current version and future updates.

With that being said, let’s jump in, shall we? Hope you brought your Flippers!

Top Platform-Specific Issues:

Apple iOS:

  • December 18, 2015: New patch for iOS released. It addresses the iOS 7 cloud save issue below, as well as the "confirmed" list of bug fixes. :)
  • UPDATED! iOS 8+ cloud save issues -- It turns out that recent iOS updates have turned the iCloud Drive setting to "OFF" in Settings > iCloud on some devices. Please check your settings, and if it's Off, turn it On! :) This is for users who were stuck at the endless "updating cloud" message. Thank you very much to user @Zach Wright for bringing this to our attention. Sometimes the solution is right there under your nose!
  • iOS 7 cloud save issues -- Because the new cloud system is only compatible with iOS 8 and above, and iOS 7 devices still received the update, this has caused incompatibility issues resulting in cloud saves not being accessible. Your data should be safe! However, we are currently working on a solution with Re-Logic that will be a good compromise in ensuring you can play with those saves, even if your device doesn’t support iOS 8 and above.
  • Everyplay is currently disabled, so video recording is not possible. We are awaiting a new SDK and will have this re-implemented in a future update.
Google Play (Android):
  • January 4, 2016 Update: Good news! We will be releasing new version of both the free and paid versions of Terraria on the store shortly. This should both fix the in-app purchasing issue as well as contain the bug fixes that were in the last update for iOS. Again, we apologize for the delay, but we are excited to finally bring this to you!
Windows Phone:
  • Crashing at launch -- Unfortunately, try as we may, we have yet to reproduce this issue internally. However, we believe to have narrowed down a root cause, and are working directly with Microsoft on a solution. We know that this has been ongoing for several weeks now, but it has been a difficult bug to isolate and address.
Amazon (Android):
  • Hello, where is our update? -- The latest update was delayed to ensure the new bug fixes make their way into the release. We apologize for the delay, but rest assured that it is coming!

Confirmed & Potential Bug Fixes:

Confirmed fixes and potential fixes for the next patch (most of these should already be in on iOS, with other platforms coming soon):

  • Fix for 'Don't place Demon Altars outside of Crimson biome'
  • Fix for iOS7 scaling and misalignment in menus issues
  • Fix for Arch Demon gore sprite transparency
  • Fix for issue with items being deleted while drag/dropping and switching tabs in some situations
  • Added check for iCloud login on device, prompt displays telling them to log in
  • Added check if cloud upgrade already ran during session, preventing a 2nd prompt on iOS
  • An even more elegant solution for the delay experienced with iCloud deleting data after the conversion has completed
  • Removed inactive close button from cloud character menu on iOS
  • Fix that removes the black bars on the iPhone 5 build
  • Fix for 'Builder Potion permanently causing a glitch on that character'
  • Fix for 'Trying to manually take things out of chests (like platinum supply)'
  • Fix for 'All Items acquired from Chests disappear'
  • Fix for missing entries for 6x4 wall paintings/objects - animal skins and treasure map now drop their proper items when pickaxed
  • Fix for honey color on the minimap (blue -> yellowish honey color)
  • Fix for dungeon being destroyed by world gen in some cases
  • Fix for 'No long dig tunnels through Ebonstone and Crimstone'
  • Fix for Corruption biome being destroyed by world gen in some cases
  • Fix for iOS build name and debug menu in tutorial (1.2.11252)
  • Fix for Traps not doing damage to enemies or critters
  • Fix for Timers not working
  • Fix for Truffle worms not spawning on all platforms
  • Fix for No Spider Armor / Fangs not dropping on all platforms
  • Fix for Slimes not dropping gel and Black Recluse on all platforms
  • Fix for Plantera music playing while the Frost Moon event occurs
  • Localization: Zombie Elf's have their names replaced with Zombie
  • Fix for crash occurring on Player inventory
  • Fix for Travelling Merchant message & spawn
  • Fix for Beetle Armor not giving the "beetle hovering" set bonus that absorbs damage (Beetle sprites were not displaying correctly)
  • Fix for fishing issues (Cavern layer fish in Oceans)
  • Fix for iOS scaling issues on large retina screens
  • Fix for Updated support information
  • Fix for Don't place Demon Altars outside of Crimson biome
  • Fix for No long dig tunnels through Ebonstone and Crimstone
  • Fix for Corruption biome being destroyed by world gen in some cases
  • Fix for dungeon being destroyed by world gen in some cases
  • Potential Fix for Android Try & Buy issue
  • Potential Fix for Amazon certification issues
  • Potential Fix for Windows Phone issue
By Design / Unable to Reproduce:
  • Switches and Levers not working consistently: We need to look at this more closely, but they are working as expected in code.
  • You cannot open a chest when you have a pick in your hand: The game logic tries to mine the chest instead of opening it. Works as designed.
  • Shroomite gloves do not like opening chest: Same as Pickaxe issue above.
  • Builder Potions can be found in chests: This is in the original game code, and is by design.
  • Picksaw doesn't work: Confirmed by QA as working correctly.
  • Asphalt doesn't work: Confirmed by QA as working correctly. Clarification in 12/16/15 update below.
  • Ocram Trophies are converting to Ice Queen Trophies: QA was unable to reproduce this.
  • Looms seem to duplicate rather than disappearing: QA was unable to reproduce this.
  • Angler doesn't give any fish quest: QA was unable to reproduce this.
  • Flame Dyes still don't work: By design, as these complex dyes are not supported on mobile.

Issues Reported to QA & Development (Status Pending Further Investigation):

Newly Collected and Reported to QA/Dev on December 16, 2015:
  • Clarification: The Asphalt bug mentioned in OP is only for asphalt that was placed before the new update, and fixed by replacing the asphalt. This is not really an issue, but a little annoying since some structures have lots of asphalt.
  • The discount card doesn’t work (it doesn’t affect prices). Also, it increases prices for re-forging. (Android/iOS)
  • As soon as a world is loaded, user crashes. They did some testing and figured out that the crash might be due to chests. Their game is having trouble rendering them. They tried the same on an older iPad, and they can open chests, but only with an empty slot.
  • Mech Bosses do not drop their respective drops.
  • Living Loom is not present on living trees.
  • Wiring is not working properly.
  • Spears do not work properly.
  • Corruption's generation isn’t working correctly.
  • Must have Candle and Battle Potion in order to get high spawn rate.
  • Guide does not have Recipe Guide (maybe due to limited memory of mobile devices?)
  • Players and NPC/enemies cannot go down Stair platforms, they are pushed upward.
  • Spawning of critters and even enemies can spawn right in front of you (supposed to be off-screen).
  • Auto-aim feature malfunctioning, only detects closer enemies, unable to detect far enemies.
  • NPC Glitch (spawning in a solid place).
  • Beetle armor: Set bonus reads "Minion damage +"
  • Spectre armor (mask): Set bonus reads "Mana usage -"
  • In MP, items you take from worlds other than the ones in your device disappear when you return to your world. Any changes to the character also appear to not be saved.
  • HP hearts have lines in the middle.
  • Bosses in MP: When the person who the boss is focused on teleports, the boss follows it and de-spawns. Happened with Queen Bee.
  • Pre-Hardmode Crimson does not convert grass or trees to spread. Crimson will only spread on dirt blocks (Galaxy S4, Lollipop 5.0.1). Related, you can try to plant Crimson Seeds on grass, and the seeds will be used, but no Crimson is planted.
  • Wall removal is limited to the PC’s waist. Excavating is tedious when you have to remove the background for your own walls one tile at a time.
  • Immediately following a power off due to battery, game enters a failed download/install loop. (Android)
  • Magic Mirror needs to sometimes be used several times for it to take player home.
  • Fishing: Items in inventory will randomly be considered bait with the tooltip "10% bait power." Seems to happen on stackable items only. User had it happen with a big stack of Cobwebs. Suddenly had 400+ bait to use.
  • Sometimes switching from a Bug Net or Fishing Pole to another item (weapon, pick, etc.) will randomly place a number in the hotbar next to that item, and you will not be able to swing it. Shortly after, the game will crash.
  • I found that when an Arch Demon is killed, the head has a white box around it.
  • Chairs have a horizontal purple line through the middle (chairs placed before update).
  • Created several new worlds, defeated all bosses until Plantera. However, no Plantera Bubble spawns inside the Jungle biome (iPhone 6 128GB iOS 8).
  • When I use the Sonar Potion to save on my bait by seeing what is biting, my bait still dwindles away. Bait isn't supposed to be used until it is reeled in, but while bait is sitting in the water, it will dwindle away every time user gets a bite.
  • All of the new light furniture are not emitting the right color of light (e.g., Boreal Wood Candelabra emitting yellow light instead of blue, Ebonwood Lamp not emitting any light at all, etc.)
  • Bottled butterflies graphical glitch: corrupt graphics sometimes show in place of original animation.
  • Ultrabright Torches from the Traveling Merchant don’t produce light when held, and when you break them, the item doesn’t drop.
  • The NPC heads in the mini-map appear to be too big.
  • Worm Duplication Glitch using Rainbow Bricks.
  • Torches have substandard animation.
  • Tooltips appear to be wrong (e.g. Naugthy Present: “15% bait power. Use as bait.”).
  • Firefly animation bug (light source).
  • Vanity Accessory Slot? (Q1 Update)
  • Worms and Grasshoppers are quite slow to spawn.
  • Enemy Spawn Rate is too low.
  • Sunflowers bloom their light before nightfall.
  • Maps show wrong color when viewed.
  • Traveling Merchant arriving message.
  • Rain becomes fast when using touchscreen on point placing.
  • Destroyer's laser and healing orbs given by the Spectre Armor are too big.
  • Hammer (Joystick Coordination)
  • Terrain Generation (Q1 Update)
Reported to QA/Dev on December 14, 2015:
  • The game decided to consume a bee mount as a potion, and it disappeared (Nickxy)
  • Using Builder Potion and placing bars will cause item to duplicate (dark_lord)
  • The Hardmode dungeon mobs besides the teleporting caster skeletons are not attacking the player. They only seem to do contact damage but they don't aim for the player. Also, the paladin doesn't attack the player and he only do contact damage. (Android)
  • Picksaw doesn't work/disappears after being used (Nickxy)
  • Robes do not appear fully on mannequins
  • Torches sometimes don't appear in hand when selected
  • Enchanted swords seem to appear far more frequently
Reported to QA/Dev on December 13, 2015:
  • “Failed fetching download URL" (Android) - Player crashes after notification.
  • Animal capturing not working properly (iOS) - If host captures animal, animal is still visible on guest devices and able to be killed.
  • Pirate Invasion, Frost Legion, and Goblin Invasion not summoning in world (iOS) - Able to summon the Pirate Invasion and Frost Legion one time in my world, but was able to only once, and the Goblins can't be summoned at all.
  • The top and bottom 20-30 blocks have become inaccessible since the last update (Android) - Stuff is inaccessible at the top of the world and the bottom of the world that was originally fine. Players have chests and items at the bottom of the world.
  • Player can't open any web-covered chests, water chests, shadow chests, sky chests, gold chests, or any if the dungeon biome chests (Android) - Player can only open the wooden ones and the ones they have placed themselves.
  • Game freezes and crashes seemingly at random (Android) - Freezes for about 3 seconds, animation stops, but player can still hear music and fighting/killing/getting hurt sounds, so the game still plays, but they can't see anything because the animation is frozen. After that 3 seconds, instant crash.

Whew! Did you get all of that? :) Apologies for any typos, duplicates, or other errors, but we wanted to make sure to get this out there for everyone ASAP. Additional updates coming soon, although you may very well receive the next patch before we get this mammoth post updated. That's what we're hoping for anyway. :)

Thanks again for your patience and understanding, and Happy Holidays everyone!
Last edited by a moderator:


505 Games
Brand-spanking new list (to be reported to dev/QA in the future):
  • Game thinks that the jungle and the hallow are the same thing. When in hallow, jungle music plays and some jungle enemies spawn. Confirmed that jungle and hallow are far from each other on map.
  • Fishing improvements don't work. Having the best gear doesn't do anything to improve fishing.
  • If your inventory is full and you start the game after updating, game might crash making your player unusable.
  • If the jungle biome is under the ocean, the fish you get are jungle fish instead of ocean fish.
  • Vanity pants are being deleted constantly.
  • Pirate summons walk a little bit inside the blocks instead of staying on top of them.
  • The gleam effect for newly discovered recipes no longer occurs.
  • Creating a jungle biome in the ocean does not cause jungle monsters to spawn (only get orcas, sharks, jellyfish, and squids). However, lining the ocean bed with lizard bricks does cause arapaima to spawn underwater, along with all manner of gels and wraiths that swim up from the depths where they should not have spawned.
  • Can't remove my vanity items and armor to replace with better armor.
  • Face monster-chan, undead viking-chan, goblin army-senpai , nymph-san and others are always facing left or right and NPCs are bugged when hitting a wall.
  • Mounts: It seems like the enemies that are supposed to drop them do not seem to drop them.
  • I had my Fisher of Souls in the 4th spot in my hotbar, and if I put anything else in the fourth spot, the description would be for the Fisher of Souls' description, and it would render the item unusable. Not major, but I lost my Bug Net to it.
  • Summoning the Frost Legion and the enemies of the invasion are not attacking me, they're just walking around.
  • No new obsidian furniture in hell houses.
  • Skeletron Prime’s difficulty: While the arms were all dead in about 20 seconds, the head flew far away, to the point where when it did the spike spin thing, it wasn't even reaching me. Almost ran out of time. Don't know if this was an AI change, but in the past it has always stayed much closer.
  • Duke Fishron trophy doesn’t seem to drop. Players have tried hundreds of times, not getting it.
  • If you have a chest at the edge of a drop off and try to place a pine tree block next to it, it will duplicate the chest. The longer you hold it, the more it duplicates. Once you let go, it will not do it again on that chest. And you can't mine it away.
  • Armored cavefish can be caught from any height.
  • Player-placed pressure plate sprites are replaced by goldfish heads, bone blocks.
  • Some accessories are still useless, such as the Depth Meter
  • Very few ice chests.
  • Minions sometimes disappear and need to be summoned again.
  • Capes bought from travelling merchant cannot be equipped.
  • Angler gives anchor (weapon) instead of wall anchor.
  • Pine blocks seem to be unbreakable with pickaxes.
  • When changing biomes on iOS, biome backgrounds/textures sometimes fail to load, leaving ugly holes in the world. Waiting long enough fixes said issues.
  • Duke Fishron sometimes spawns Cthulunados in his first form and Sharknados in his second form.
  • The stylist and travelling merchant are changing their names every time the world is loaded.
  • Can't plant Shiverthorn Seeds into Clay Pots.
  • Fishing on honey makes no difference. Can't complete Angler's Bumblebee quest. Couldn't fish on lava though.
  • Angler doesn't spawn on worlds that were made during or before the Hardmode update.
  • The builder potion (adding on to the bars glitch) doesn't decrease the number of things in inventory with coins, bars, blocks, furniture, lights, background walls (occasionally subtracts from background walls). Doesn't work with actuators and I haven't tested with wands (living wood etc.). Actually, the glitch works on ANY placeable thing. If it says "can be placed", then the glitch will "work" with that item. So coins duplicate, as do blocks, walls, furniture, light sources, bars, ores, gems, etc.
  • Putting weapons in a weapon frame shows a glitchy shark statue.
  • Solar eclipses: After 3 eclipses, got 300+ Reapers, 150+ Vampires, 1 Eyezor and not even 50 of Frank or ST.
  • Bugs can’t be caught in multiplayer and also after summoning a pirate invasion, summoning any other invasions will fail for days (like a Terraria month, related to other summon issue possibly).
  • Flying slimes don't drop loot.
  • After Pirates fight, a truffle worm in burrowing mode was flying in circles around my screen. This was odd, as I thought truffle worms were supposed to burrow AWAY from you. So, I quickly got my bug net and captured it. My arena is about 300 blocks below my artificial mushroom biome.
  • Trying Pirates again, I took my pirate map and tried to use it. It didn't work. I tried about ten more times, and it still didn't work. I tried different characters, still didn't work. Using a new world works, but I have to make a new world every time I try the Pirates.
  • Ectoplasm doesn’t drop in Hardmode dungeon and living fire blocks don’t drop either.
  • NPC Santa’s Xmas Tree can't be decorated.
  • Whenever I try to remove a glass bowl, it turns into a normal bowl, when I try to remove chalices, they turn into golden chests, and ultra bright torches drop nothing when removed.
  • Low enemy damage from traps (like 1 damage or so).
  • Santa won't move into another house after I've demolished the one he used to live in. He's just walking around.
  • The ground will vibrate up and down a pixel. The background and UI don't move, just anything in the foreground.
  • If you are holding the fishing rod and then switch to the magic mirror and then back to the fishing rod, the fishing rod will be used even if you don't have any bait.
  • If you use the magic mirror then quickly tap an item, it will do a full circle, (melee) and then use the item.
  • Background removal is only an issue when using the joystick auto aim. You can remove any blocks in range with the point selection.
  • Normal grass has precedence over crimson.
  • When fishing in a minecart, the fishing rod slowly floats upwards, separating from the player.
  • When zooming out, the screen flickers between the world and the map before showing you the map.
  • Creatures stuck in a corner perfectly (so stairs made of any block material) will flicker their left and right sprites really fast.
  • When you are perfectly on the background changeline for corruption and jungle, the background flashes jungle green and purple.
  • Smart cursor has trouble picking between two blocks when you dig diagonal, so the yellow highlight block flashes back and forth between the two bricks until one is destroyed.
  • Random hit points. Sometimes, I'll see damage numbers pop up, even though it's in the ground. For example, I'll be walking then 47 appears out of nowhere. I look at where the number pops up, but there are no traps, no mobs, nothing is there.
  • Sometimes mobs will be spawned in the blocks themselves. Example, a slime spawned in a two by two dirt pile.
  • Shadow Hammer drops Silver Chandeliers instead of Cobalt Bars, Mythril Bars and Adamantite Bars.
  • Slimers don't turn into the Second form (Shadow Slime). Instead, he is just killed and doesn't drop anything.
  • Corrupt Slimes don't turn into Slimelings.
  • Light Mummy doesn't drop money.
  • Menu Theme doesn't play. Instead, the Overworld theme plays.
  • Ambient Rain sound doesn't play. Only the Rain Theme Music plays.
  • Destroyer is nearly impossible, since his lasers are utterly huge and it can deal tons of damage (it wasn't like this before).
  • Snow Legion's enemies don't have walking animations.
  • Snow Legion's enemies don't turn to the Right when walking in this direction, which cause them to "Moon Walk" and walk backwards.
  • If you click the clock, the game thinks you clicked it 3 times, which will cause the time to appear 3 times.
  • Water doesn't flow when doors are opened.
  • Jungle's surface background doesn't appear. It's just the greenish Overworld background.
  • The Santa Claus' arriving message appears as "the Santa Claus has arrived!" instead of "<NAME> the Santa Claus has arrived!"
  • Santa Claus' housing banner doesn't appear to show that it's occupied.
  • Shroomite armor: Stealth mode doesn't wear out when moving.
Last edited by a moderator:


Staff member
Loving these "issue status" threads for 3DS and mobile! This will make tracking things SO much easier for everyone. :)

Terrarians - where bugs haven't been able to be replicated, remember that any additional info or images or whatever that you can provide could help unlock the mysteries of any one of these pesky bugs! Help 505 help you! ;)

Ninja Army

All of the new light furnitures are not emitting the right color of light (boreal wood candelabra emitting yellow light instead of blue, ebonwood lamp not emitting any light at all, etc) iphone 4 iOS 7.12 something

Also I deleted my old world so I could enjoy the new update
Last edited:


Also bottled buterflies might glitch out and go crazy making it load a bunch of distorted graphics in place of original animation. Another bug is that the superbright torches (Traveling merchants sell item) dont produce light when held, and when you break them the item doesnt drop


I do have a fairly critical bug I have encountered, basically I will load up my game, and as soon as I load a world I will crash. I did some testing and figured out that I crash because of chests, for some reason my game can't render it or something. I tried the same on an older iPad, and I can open chests, but only with an empty slot have D:.
Not open for further replies.
Top Bottom