1. We have hub threads for known bugs/issues and statuses of fixes for Mobile, 3DS, and Console platforms (UPDATED):
    Click here for Mobile
    Click here for 3DS
    Click here for PS3/PS4/PS Vita/XBox 360/XBox One

1.3.1 Feedback and Bugs Section

Discussion in 'PC - Re-Logic' started by Loki, May 20, 2016.

Thread Status:
Not open for further replies.
  1. Loki

    Loki Consigliere Staff Member Re-Logic Administrator

    Congratulations on acquiring 1.3.1! We would love it if you gave us feedback on the update and reported any issues you have here!

    Here are a few tips for reporting bugs:
    1. Explain What you See, Not What You Suspect
      • Explain exactly what was happening and how to reproduce an issue with an image or gif.
      • Generally, it is far easier for the devs to find and resolve an issue if it is clearly explained: where you are, what is going on, and how to reproduce it; than if you made an assumption of what is going wrong, and were in fact incorrect.
    2. Be Specific
      • Don’t say “I was building.” Say “I was placing a block of dirt.”
    3. Be Concise
      • Having a long drawn-out description may seem necessary, but often times it is not.
    4. Capture All the Details You Can
      • Things like Error Message, Screenshot/GIF, Operating System, Build Version, File Name of Build, Tile or Item Used, NPC Fought or Spoken to, etc. are all vital details for finding bugs.
     
    Last edited by a moderator: May 22, 2016
  2. ✪NightSong

    ✪NightSong Terrarian

    Controller does not work, what to do?
     
  3. eaglestorm13

    eaglestorm13 Terrarian

    Have you went to settings and swtiched from Mouse and Keyboard to Controller
     
  4. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    Could you please provide more information, such as the type of controller you are attempting to use, as well as operating system?
     
    Dreamtree likes this.
  5. ✪NightSong

    ✪NightSong Terrarian

    Controller - Torid Wireless. System - windows 7 64bit. How to enable controller? I searched in the settings, but did not find such a.
    --- Double Post Merged, May 22, 2016, Original Post Date: May 22, 2016 ---
    How?
     
  6. Yoraiz0r

    Yoraiz0r Lead Developer Re-Logic

    The options menu ingame won't help you - the gamepad support should enable itself as soon as you try clicking anything on the gamepad.

    According to this page I found on google, looks like your gamepad has a setting for XInput or DirectInput, try setting it to XInput and then try using it =o
     
    RAGNAR, Lazure and Dreamtree like this.
  7. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    @✪NightSong, I'm unfamiliar with the Torid Wireless. However, from what I'm reading, it has a button toggle to switch between Xinput and DirectInput. If possible, try to identify this button and make sure you are set to Xinput, which is what Terraria uses for Gamepad support.
     
  8. zenmai

    zenmai Terrarian

    bug
    During start-up, it can not be determined in a click
     
  9. Aceship

    Aceship Terrarian

    terraria got error after teleporting to the whole different place

    i used steam controller and tried to reset to default the controller config, Pressing the right trigger, suddenly the texture got buggy and teleport to the whole new place, and i tried to press it again several times, got out of the menu, tried to move , and then it got crash.

    i tried to recreate the problem the second time, but i cant make it again, probably not gonna help
    [​IMG]

    Using Windows 10 64 bit, Terraria v1.3.1


    also can i give a feedback here too ?
    since i have steam controller , id like to use the mouse on the steam controller, but it keep on changing from K&M and controller mode
    and also the smart mode for the controller doesnt work nicely since its got recenter everytime on using joystick like mouse

    and i like to have the grid overlay like the controller even if im using mouse mode on the right touchpad of steam controller


    Thanks for the great update :D
     
    Yoraiz0r likes this.
  10. Gigavoir

    Gigavoir Spazmatism

    I don't quite understand, can you explain? I've been playing a bit this morning and haven't found any startup bugs
     
  11. ✪NightSong

    ✪NightSong Terrarian

    I switched to XInput mode , but it still does not work
     
  12. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    Have you closed and re-launched Terraria with the Gamepad already set to Xinput?
     
  13. ✪NightSong

    ✪NightSong Terrarian

    @Leinfors @Yoraiz0r How to check whether it is included at all in Terraria ?(controller)
     
    Last edited: May 22, 2016
  14. Yoraiz0r

    Yoraiz0r Lead Developer Re-Logic

    If the version number shows v1.3.1 you have the gamepad support, by simply using the gamepad it auto-activates it - as long as the gamepad is actually detected.
    You may want to update your gamepad's drivers or look for XInput solutions for it, you may also need the official windows gamepad drivers? not sure
     
    RAGNAR likes this.
  15. SpaceCore_374

    SpaceCore_374 Terrarian

    When using the kimono as a female character and jumping makes the clothing on the legs extend.
     

    Attached Files:

  16. mipin5

    mipin5 Steampunker

    Got this when in my server and chose "Crafting" when talking to the Guide using a xbox360 controller.
    I wave win7 64bit

    22/05/2016 11:27:33
    System.Collections.Generic.KeyNotFoundException: La clave proporcionada no se encontró en el diccionario.
    en System.Collections.Generic.Dictionary`2.get_Item(TKey key)
    en Terraria.Initializers.UILinksInitializer.<>c__DisplayClassef.<Load>b__3a()
    en Terraria.UI.Gamepad.UILinkPage.Update()
    en Terraria.UI.Gamepad.UILinkPointNavigator.Update()
    en Terraria.Main.Update(GameTime gameTime)
    en Microsoft.Xna.Framework.Game.Tick()
    en Microsoft.Xna.Framework.Game.HostIdle(Object sender, EventArgs e)
    en Microsoft.Xna.Framework.GameHost.OnIdle()
    en Microsoft.Xna.Framework.WindowsGameHost.RunOneFrame()
    en Microsoft.Xna.Framework.WindowsGameHost.ApplicationIdle(Object sender, EventArgs e)
    en System.Windows.Forms.Application.ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FDoIdle(Int32 grfidlef)
    en System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
    en System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
    en System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
    en System.Windows.Forms.Application.Run(Form mainForm)
    en Microsoft.Xna.Framework.WindowsGameHost.Run()
    en Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
    en Terraria.Program.LaunchGame(String[] args)
     
  17. God13th

    God13th Terrarian

    hello, i'm trying to start the game over steam, but nothing happens.. What should i do.? Win10x64
     
  18. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    That looks like the normal female leg sprites for the Kimono to me. :)

    @mipin5, has this happened multiple times, or just once? I was unable to replicate it on my end.
     
  19. NLZ

    NLZ Terrarian

    Not sure if its new, but when I'm shooting the hook above my head (upper 45°), some graphics glitches.
    Like the Nebula Blaze moves into my head, the Magic Cuffs moves up, and when I hold another weapon in my hands, the Ancient Cultist Mask became broken, my eyes become visible.
    But if I equip the Nebula Arcanum then everything is fixed.
    Not sure what is the root of the cause, right now I cannot test it further, but later I can send you pictures and/or my save if needed.

    Bug numero 2 is that when you mix the hooks (is it an intended feature?) you can shoot the Static Hook two times.
     
  20. Leinfors

    Leinfors Quality Assurance Staff Member Moderator Re-Logic

    This is actually something that can be done with other hooks, and has been for a while. The Static Hook just behaves a bit differently, due to its unique mechanics. Not sure what can be done about it, but I'll note it!
     
Thread Status:
Not open for further replies.