Terraria 1.3.1 Now Available for PlayStation 4 & Xbox One!

Discussion in 'Console - 505 Games/Pipeworks Studio' started by 505Games, May 6, 2019.

  1. ED209

    ED209 Plantera

    Out of interest, did you back your world up to the cloud as the update was installing?
     
  2. AtreyusMaximus

    AtreyusMaximus Terrarian

    Hi, I'm new to the forums. Just love this game. But I I'm a little confused. For starters I play on Xbox one. When I look at manage game it says Version 1.0.0.24, and in Game along the bottom right corner it says v1.0.1372.6. Just curious if that's what 1.3.1 is. I apologize for this being a stupid question.
     
  3. Omega Derpling

    Omega Derpling Spazmatism

    The console has it's own version numbers separate from PC. 1.3.1 is the name of the equivalent PC update that console just got.
     
  4. Gumbi

    Gumbi Terrarian

    didnt have this problem... nbut now, my main world always make the game crash when loading. :(
     
  5. Safeman

    Safeman Community Manager Staff Member Re-Logic

    There isn't a release date for the mobile 1.3 update yet but it is in alpha and we'll have news for you soon :)
     
  6. BloodPuddles

    BloodPuddles Terrarian

    I've been lurking for a while, and I noticed since the change to Pipeworks PC progress has slowed a lot, and console has sped up massively. Is this because of plans for cross-play and servers? That would be incredible. I don't really socialize much anyways, but the lack of real things happening around me in-game makes it pretty lonely.
     
  7. Phemt666

    Phemt666 Terrarian

    Finally 1.3.1...I was waiting for this update impatiently. Even if it required a while, thanks to everyone who worked on it for the great job ;)
    I played it a couple of hours today and enjoyed it, so far so good. Just noticed a little bug about the Grand Design: it doesn't place wires on sloped blocks and, if I'm placing a long section of wires and the cursor pass on a sloped block, it interrupt the placement, wich is a bit frustrating. I don't know if is clear what I mean, but I'll try to make a video and explain it better in the bug section if I'll play tomorrow
     
  8. Was hoping for the Cog wall to come out on ps4, guess it didnt...
     
  9. Phemt666

    Phemt666 Terrarian

    Was hoping that too, but unfortunately it didn't
     
  10. Proto Persona

    Proto Persona Brain of Cthulhu

    Cog walls are in patch 1.3.2.
     
  11. Tunnel King

    Tunnel King Administrator Staff Member Administrator

    Re-Logic works on the PC version, not Pipeworks (console/Switch)

    While cross-play would certainly be a desirable goal, the console manufactures can't seem to agree on a plan to make it a widely available option for the majority of games. There's not much we can do to 'plan' for crossplay until/unless they make a serious effort to allow that.
     
  12. Hey, thank you for info!
     
  13. Warper

    Warper Terrarian

    :sigh:RIP fishing glitch :(
     
    Last edited: May 15, 2019
    Blue_M4ge and ED209 like this.
  14. GalaxyShard

    GalaxyShard Terrarian

    i need that cube, especially after i just finished portal 2
     
    Warper likes this.
  15. MOBILE GAMER

    MOBILE GAMER Terrarian

    The devs are close in beta or not??? `:happy:`:happy:
     
  16. ED209

    ED209 Plantera

    @Loki @ClearConscious here's a list of the latest bugs, plus the bugs leftoveer that weren't address from the previous patch(es). Instead of making you another list of the latter, it was way quicker to copy and paste the old list and delete the few things you did actually fix (seriously, who does the testing for these releases?):


    New 1.3.1 Bugs
    1. My main world gets 99% loaded and the the app quits with an error code. I then have to start it again, load a different world (which seems to only only work with 1.2.4 worlds), quit that world, THEN load my main world. Massive ball-ache when you consider the slow loading speed bug from the previous patch.
    2. The cursor for place-able items (from RoD to wrenches to summon items to projectile weapons) stays where it was in relation to the player once you stop moving, instead of resetting back to the centre of the screen. Very annoying when you've got lots of switches close together which you could previously kust stand on top of to operate.
    3. The Grand Design UI keeps moving you along the hotbar 1 slot to the right every time you select something, because you press R2, which navigates the hotbar: who came up with that? Why not select wire colour etc. with "X" like in the paint sprayer etc.? It's a great example of the difference between logic and common sense. Also, id it meant to reset itself after every world load?
    4. Travelling Merchant fails to appear some days.
    5. Dart traps (super or otherwise) aren't triggering teal pressure plates. Speartraps do.
    6. I know that pets can set off teal pressure plates, but are minions meant to as well? The UFOs keep hitting it as I'm building and mesing the whole farm up.
    7. One tile's worth of wire will suddenly vanish without being cut. This happens anywhere on the map, even in areas I haven't been to for months. It's been breaking loads of my farms.

    Disruptive bugs:
    1. Stuttering lag:
      I know you're probably inundated with reports of this, but here it is again. The lag interrupts many features of gameplay, including movement inputs (causing solar armour to perform unwanted dashes, vortex armour to go into stealth without wanting to etc). Its also causing visual layers to render slowly. This is apparent when you're in a UFO mount and the edge of the screen takes a half second to show solid blocks. Also, when teleporting, it takes a while for the tiles to all generate. I've stopped doing frost moon altogether as it just can't cope.
    2. Game loads:
      The "drawing maps" part of loading a map now take even longer, roughly around 1% per second
    3. Mobs are spawning halfway inside blocks:
      This one is fairly niche, but it's still worth a mention. I auto-farm using UFO minions, with the spawn surface being 40 tiles below me. I have been killed a few times by mobs that stand still and use projectiles (Rune Wizard, Desert Spirit, Skeleton Sniper, Tactical Skeleton) being halfway inside a solid wall, where they are not detected by the UFOs. I tried to fix this by removing the bottom block of the wall and filling it with lava kept in place using a bubble (which are no longer solid and I'm loving it). They still spawn there and are actually being burned by the lava. As mobs cannot spawn on lava, I'm guessing that the spawn tile the game chooses is on the wrong side of the 2x3 space for a mob to generate (again, just a guess).
    4. Shutdown with error code CE-34878-0:
    5. This has only happened once [EDIT: three times] since the patch, instead of three times a day, but I thought I should mention it. [EDIT 1.3.1] This now happens when a world is 99% loaded around 1 in 5 times
    6. Frost Moon vanishing loot:
      When finishing the Frost moon, the loot begins to disappear as you walk toward it. It has nothing to do with the loose item limit, as no other loose items are being created. It literally vanishes before your eyes.
    Non-disruptive bugs:
    1. D-Pad binding:
      This still needs to be redone every time you load a map, instead of being permanent. Also, by binding the "UP" key on the D-pad to "quick heal", it renders all other D-pad bindings inert. Lastly, binding is based on slot, whereas before it was based on item; if I move my bound pickaxe two slots down it's no longer bound to the D-pad.
    2. Vanishing campfires: [Not tested by me since 1.3.1]
      Bone campfires and ultra-bright campfires both vanish when removed with a pickaxe. I'm not sure if this is because they're both made with the only non-craftable torches, or whether they are early items from 1.3.1.
    3. Wire stacks:
      If I have a full inventory, with incomplete wire stacks in my ammo slots, the bits of wire I've just cut aren't being picked up into the wire stacks, and just stay on the ground. However, if I delete something from my inventory, the wires are picked up, and go into the stacks in my ammo slots.
    4. Silt exploit:
      Sometimes silt is not consumed at the extractinator, but it still kicks out loot. I know this might ruin some peoples' fun, but it could be part of a larger issue. Sorry everybody!
    5. Blocked mounts:
      This carried over from before the patch. Whenever I'm stood in front of something I can stand on that's one block high (platforms, anvils, work benches, dynasty tables) I can't summon a mount.
    6. Waxing moons:[Not tested by me since 1.3.1]
      The moon phases always say "waning", regardless of which side of a new moon/full moon they are. As they are both equal in terms of fishing power etc. it's not a huge issue, but worth a mention anyway.
    7. [EDIT] Dungeon mobs:[Not tested by me since 1.3.1]
      All types of dungeon mobs are spawning in all dunegon areas, regardless of the type of wall (slab/brick/tiled) This makes it three times harder to farm for specific items. Also, the mobs are spawning in normal caverns if I'm in the dungeon, which I'm fairly sure shouldn't be the case.
    Aesthetic issues:
    1. Flickering doors:
      Doors, tall gates and trap doors all strobe when near the player.
    2. Water surfaces:
      Sometimes the surfaces of underground water bodies are visible as a white line, despite being in total darkness.
    3. Track Junctions:
      When hammering minecart track junctions, the sprites are the wrong way around; the cart goes over the "gap" in the tracks.
    4. Paint on dummies:
      I think this might be the case on PC too, but paint is being consumed on dummies, but not showing. The same applies to weapon racks.
    5. Bubble bug:
      Liquids on top of bubbles flash in and out of a "waterfall state", where the liquids act, for a split second, like they are on top of a block that's been hammered once into the flat position to create waterfalls. This flickers in and out rapidly.
    6. NPC map icons:
      These are very small, and make sit difficult to find NPCs or other players.
    7. Slime Rain background:
      When a slime rain occurs, the animated slimes drop behind the mountains, making them seem the size of a large stadium.
    Questions:
    1. Loading time:
      Is there a reason the game takes so long to load now, compared to 1.2.4? I understand that large maps are now LARGE maps, but the whole loading process is around seven times longer. It seems even longer since the last patch a few months ago. Also, is there a reason that the game saves for such a long time in between selecting a character and selecting a map? What is it saving that wasn't saved when exiting the previous session?
    2. Mini-grid:
      The circle of white squares around the cursor is great for tools, but does it have to be on everything? I don't need it on weapons for example, and it does spoil the aesthetic when taking screenshots.
    3. Cursor speed:
      Is there any chance that weapons' cursor speeds can be sped up? It's very hard to hit a Martian saucer with a Lunar Flare or Star wrath because it's going at a tool's speed.
    4. Opacity in build mode:
      As I mentioned, I love the UI slider. Have you considered making it automatically going to 50% when clicking "R3" in build mode? Then going back to the user's preference once the item has been placed?
    5. Item sorting:
      I don't really know what "sort items" does, but in chests in seems to not sort anything at all. Shouldn't the same types of item all be next to one another?
    6. Map cursor:
      Is there any way that the movement of the map cursor can be improved? At the moment it's very difficult to hold it over anything because it's too sensitive, as if the grid that the cursor movement is based on has squares that are far too large. It makes using wormhole potions or identifying object all but impossible. Also, in 1.2.4 we were able to move it diagonally, and everything was one fluid movement. Now we have to go left/right, stop, go up/down, stop, go left/right and so on.
    7. Keyboard:
      Is there any way we can go back to using the PS4's keyboard? The in-game one is nowhere near as good.
    I hope this helps, and if I find anything else I'll let me know. As I find more I'll let you know.

    Thanks.
     
    Last edited: May 15, 2019
    DFA_2Tricky likes this.
  17. Safeman

    Safeman Community Manager Staff Member Re-Logic

    It is still in alpha. We'll announce once we start choosing testers, move to beta, etc :) Stay tuned!
     
  18. Cyberra

    Cyberra Skeletron Prime

    The traveling merchant only has a chance of spawning every day, between 6am and noon. He is not and was never guaranteed to arrive every day
     
  19. ED209

    ED209 Plantera

    Before the patch he turned up every day, and often way before 6am.
    --- Double Post Merged, May 15, 2019, Original Post Date: May 15, 2019 ---
    Does that mean you outsource Terraria players to test the game, instead of in-house?
     
  20. GalaxyShard

    GalaxyShard Terrarian

    I didnt read the whole thing, but while im on inventory, if i press UP (or down, it doesnt really matter) and then press right (on dpad, xbox one) then the mini map will open (Note: My minimap keybind is set to right on dpad, but in inventory you have to press up/down and right. I think it should just be totally disabled for inventory, as i use dpad to navigate it.)