• Switch 1.4: New patch released Jan 18, details are here. Read the full release details here. Report bugs here.

Official The Ultimate Guide To Content Creation And Use For The Terraria Workshop

ItalianDonut

Terrarian
I've been having a problem where no matter what I do to my music pack, the game just doesn't recognize it. I don't know how it happened, since it was working for me before, and I can still use ones from the Workshop, but when I use my own file, the original music plays.
 

Kirby737

Retinazer
I've been having a problem where no matter what I do to my music pack, the game just doesn't recognize it. I don't know how it happened, since it was working for me before, and I can still use ones from the Workshop, but when I use my own file, the original music plays.
I suggest you share your file. I'm not an expert, but that should help.
 

TheMoonTitan

Steampunker
I made a music pack using WAVs (converted from mp3s in Audacity), and they sound fine when I go into the resource pack folder and listen, but in-game the music sounds terrible, unrecognizable, and glitchy. I had a modified wavebank with the same WAVs prior to the workshop/resource pack release, but I don't think this should conflict, especially since the wavebank seems to have been replaced with the default when 1.4.2 was downloaded. The only possibly major change was renaming from a format like "01 Overworld Night" to "Music_1". Any idea what might cause this?

Edit update (June 1): After replacing all the wavs with identical mp3s in the My Games version of the folder, it worked and didn't glitch. But by that point, it had already copied the pack over into the steam Workshop folder, and changing *that* to mp3s had no effect, so it preferred My Games? Still no idea why wavs borked but mp3s didn't. It'd be nice to figure this out.
 
Last edited:

ItalianDonut

Terrarian
As suggested, here's my test file that's supposed to replace the Classic Title theme with some shovel knight music I found laying around on my computer, it's having the same issue as my bigger packs
 

Attachments

  • New folder.zip
    2.4 MB · Views: 36

RedSentry27

Steampunker
how can i open XNB files? or in what program, i don't know if this was covered in the guide.

nevermind found it
Whoops!
 
Hi, I am having some problems with a pack I am working on. I am currently putting Big Floppa into the game, replacing the Bast Statue with him. I have gotten the textures to work fine, but the localization does not seem to be working for me. I will attach a few screenshots if that helps.

1622954700787.png

Figure 1: My file structure. Terraria/ResourcePacks/DrPrinterExperience/Content/Localization/.


1622954487820.png

Figure 2: The contents of the "en-US_CatBast.csv" file.


1622954548202.png

Figure 3: What actually shows up ingame.


1622954648369.png

Figure 4: The statue's texture, working properly.


Let me know if I am missing anything here in terms of info. Thanks.
 

Criddle

Moderator
Staff member
Moderator
I couldn't get it to work either, even after I tried changing the "en-US" in the top row to "Translation", so I'm not sure what the issue is.

However, I got it to work by using the comma divider method, like this:
Code:
Key,Translation
ItemName.CatBast,Big Floppa Statue
ItemTooltip.CatBast,Big Floppa is real?
BuffDescription.CatBast,You feel awe in his presence
BuffName.CatBast,Big Floppa

Which looks like this:
excel.png


And show up like this ingame:
flopp.png


It's not a perfect solution but I hope it helps!
 
I couldn't get it to work either, even after I tried changing the "en-US" in the top row to "Translation", so I'm not sure what the issue is.

However, I got it to work by using the comma divider method, like this:
Code:
Key,Translation
ItemName.CatBast,Big Floppa Statue
ItemTooltip.CatBast,Big Floppa is real?
BuffDescription.CatBast,You feel awe in his presence
BuffName.CatBast,Big Floppa

Which looks like this:
View attachment 325394

And show up like this ingame:
View attachment 325393

It's not a perfect solution but I hope it helps!
It worked! Thanks a bunch!
 

Loveme

Terrarian
Is it possible to change the backgrounds? Like replacing the native forest background with another set of parallax -- like a city background or something
 
Still having problems with changing the Minimap's name from "Golden" to "Copper" not sure if they have any special way of being formatted or something...

For my texture pack, NeoTexturas, by the way.
 

Attachments

  • en-US Localization.json
    3.4 KB · Views: 42

Criddle

Moderator
Staff member
Moderator
Is it possible to change the backgrounds? Like replacing the native forest background with another set of parallax -- like a city background or something
Yes, it's possible to change backgrounds.

Still having problems with changing the Minimap's name from "Golden" to "Copper" not sure if they have any special way of being formatted or something...

For my texture pack, NeoTexturas, by the way.
This should do it:
Code:
"UI": {
    "MinimapFrame_Golden": "Copper",
},
 

Simple

Official Terrarian
I made a pack once and it worked, so I decided to make another pack that changed localization instead of a texture. It wouldnt work and I literally copy and pasted all the files from the other pack except localization. Since I thought my localization was formatted wrong I added the tutorial localization and it STILL wouldnt work, so now im confused since I copied all the other stuff from a working mod I made, AND I copied the localization from this guide. Im sending the file in hopes that someone could tell me what Im doing wrong.
In your pack.json file, there are extra quotation marks in one line.
JSON:
    "Description": "changes death message to "get rekt".",
Due to this, Terraria reads the description as "changes death message to ", but then comes across an error because it doesn't recognize get rekt".", and expected an apostrophe at the end of the second quotation mark.

One alternate option you can use instead of a quotation mark is a double apostrophe, as both look identical.


I hope this has helped!
 
Top Bottom