Standalone [1.3] tModLoader FNA (32bit/64bit) (Branch of tML)

Discussion in 'Works-in-Progress' started by Desenrrollado, Jan 17, 2019.

  1. lyonels

    lyonels Terrarian

    Ohh god, incrible this is everything i want for years, 64 bits will change all perpective for use mods <3 thank you modders, cheers.
     
    Dradonhunter11 likes this.
  2. gabrieldoekhi

    gabrieldoekhi Terrarian

    Is there away to make it work for the gog version tho ?
     
  3. Dradonhunter11

    Dradonhunter11 Official Terrarian

    no
     
  4. EXRibbon

    EXRibbon Spazmatism

    I'm getting the error where I should buy the game and stuff.

    I have the game though? and have replaced the file in the terraria folder, etc. :(

    do I have to re-install terraria to get this to work or something?

    UPDATE: fixed it. I just had to reinstall terraria :)
     
    Last edited: Feb 6, 2019
  5. Robbier2713

    Robbier2713 Terrarian

    i keep on getting a terariahooks error, i assume its not supported?
     
  6. For some reason, the music is not loading or working at all, making it seem VERY weird, almost as if something bad is going to happen, anyone know a fix to this?
     
  7. Dradonhunter11

    Dradonhunter11 Official Terrarian

    It's integrated in, I would need to do some really weird sorcery

    You dropped ffmpeg.exe in the content folder? Also make sure the music conversion mode in tmodloader settings is set at Convert on Demand.
     
  8. Yup, I did all of that, and its not working. Any thing else I could do? (I also just found out weather sounds don't work ither)
     
  9. Dradonhunter11

    Dradonhunter11 Official Terrarian

    Join the discord, I'll be able to give you a better help here without flooding the thread ^^ I'll see what I can do there, probably will ask for a of couple detail.
     
  10. Alright, thank you, I will move over there now!
     
  11. Dradonhunter11

    Dradonhunter11 Official Terrarian

    New update is out and is actually more stable than any other update :D
    It fix a tons of thing too ^^
     
  12. Nova Dee

    Nova Dee Spazmatism

    Maybe someone knows why the RecipeBrowser mod conflicts with some other mods, causing an error?
    RecipeBrowser works fine with many mods, but Mod of Redemption, for example, causes the following error:
    [​IMG]
    ===
    EDIT
    ===
    Very strange, but this error probably always occurs when I try to add a new mod to my build. The error also works with N.E.F. and Crit Sound Effect
     
    Last edited: Feb 21, 2019
  13. Dradonhunter11

    Dradonhunter11 Official Terrarian

    So recipe browser need a special version to work, N.E.F and Sound Crit Effect probably use some method that got removed from 0.11 (since 64bit is based on a very early 0.11 commit, which was the most stable at that time, even more stable than the release build).

    Also, running the latest version?

    64bit Recipe browser : https://cdn.discordapp.com/attachments/502354710909419522/503326638759608321/RecipeBrowser.tmod

    Edit: I just did a pull request into recipe browser so let's hope next version fix it :D
     
    Last edited: Feb 21, 2019
    Nova Dee likes this.
  14. Nova Dee

    Nova Dee Spazmatism

    Dradonhunter11, Now there are no problems. Thank you very much for your help. :dryadsmile:
    (I have checked so far only on Mod of Redemption, there were no problems)
     
    Dradonhunter11 likes this.
  15. Nova Dee

    Nova Dee Spazmatism

    Be careful! Crit Sound Effect does not work correctly with this. When you try to enter the world - it crash the map forever.
     
  16. Dradonhunter11

    Dradonhunter11 Official Terrarian

    do you get anything in the crash log?
     
  17. Nova Dee

    Nova Dee Spazmatism

    No, only the following error when trying to enter the world.
    [​IMG]
    After the mod is disabled, the map will also not be able to start.
     
  18. Dradonhunter11

    Dradonhunter11 Official Terrarian

    map can be solved trough config, as of the mod not working, it's honestly super weird (it seem to also crash world gen too)
     
  19. AlucardShadow

    AlucardShadow Terrarian

    Error in world generation, using only mod Tremor and stands still in this part.

    [​IMG]
     
  20. Dradonhunter11

    Dradonhunter11 Official Terrarian

    blame tremor, not us. There is a working version on the discord but I just strongly discourage using that mod as it's extremely buggy (even on 32bit)