• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Begin your search for Journey's End information here and here. Please report bugs and issues for Journey's End here.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

1.3.1 Feedback and Bugs Section

Status
Not open for further replies.

Ilmarinen

Terrarian
Hi! I found a bug. So I'm reporting it. I bought a few of those Pink Team Platforms from the Travelling Merchant and when You place a torch on them it seems to duplicate.
I just tried this with yellow team platforms and it everything functioned normally. What exactly did you do when the torches duplicated? Do you have any of the other team platforms to test this on?
 

NanoPi

Steampunker
when using a controller, the controller menu binds for favourite and transfer/sell/trash sometimes doesn't work when I press the button.
found out why. my framerate was below 60.

if frameskip is on and fps is 50, there's a 1 in 6 chance of the button press doing nothing.
frameskip on and 40 fps = 2/6 chance of the button press doing nothing.
 

Maxwellpc

Terrarian
I found a bug:
When lowered the bar which is the world's menus side is the same with a black line (or is broken, I can not specify which options) see picture annexed.
Also I think it would be good to buy bottles, rabbits and worms at some npc.
I used google translator: I do not speak english.
 

Attachments

MantasX12

Official Terrarian
So before v1.3.1 my fps was mostly stable 60.Now some kind of a problem accured.Whenever i am playing singleplayer my fps drops to 30 and stays that way unless I ALT+TAB (then it goes back to 60), but after like 5-10min it goes like that again :(.I am using both of my cores and with "high" priority as I always did (None CPU and or RAM heavy programs are running [Btw frame skip options do not seem to change anything]).Hope it's getting fixed,if my problem dissapears i'll edit this post.
 

Dandeloreon

Terrarian
I'll start off with a general suggestion that is not tied to any specific Terraria version... Allow users that own Terraria on Steam to get a copy on GOG (Good Old Games) with GOG Connect.

Now for some previous Suggestions I made...
 
Last edited:
So I've been trying to figure this out and I think I'm getting something confused. Is there a way for controller users to move the character around with the inventory open and still manipulate their items?

I usually build projects with my inventory open for convenience. I want to be able to move my character with the left stick and move the selector around my inventory with the d-pad. The right stick would move the cursor to place the item picked up from my inventory.

I can do all this fine with M&K but I like being able to use a controller, it's more comfortable for my hands.
 

CathodeCat

Terrarian
So I've been trying to figure this out and I think I'm getting something confused. Is there a way for controller users to move the character around with the inventory open and still manipulate their items?

I usually build projects with my inventory open for convenience. I want to be able to move my character with the left stick and move the selector around my inventory with the d-pad. The right stick would move the cursor to place the item picked up from my inventory.

I can do all this fine with M&K but I like being able to use a controller, it's more comfortable for my hands.
Try using the "Build" button.
It seems not properly labeled at keybinding settings for menu controls.

[Sample keybindings]
keybindings.png


[Using "Build" button]
build_controls.png
 
Last edited:

Rick Astley

Terrarian
I just tried this with yellow team platforms and it everything functioned normally. What exactly did you do when the torches duplicated? Do you have any of the other team platforms to test this on?
As a matter of fact I have. But now it doesn't seem to happen, even with the Pink ones... IDK if it was my Terraria's problem...
 
Status
Not open for further replies.
Top Bottom