• Journey's End on PC - Find info here and here. Please report bugs and issues for PC 1.4 and 1.4.1 to Re-Logic here.
  • Journey's End on Mobile - Find info here. Report bugs for Mobile 1.4 to DR Studios at this link and give as much detail as possible.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Console and Switch - The latest news can be found here. To report a bug, please use this link.

Standalone [1.3] tModLoader FNA (32bit/64bit) (Branch of tML)

if anyone ask for version 0.11.7.7 after this post just go to the discord server dont be lazy, please the devs stated that their more active there than here on the forums.
 

Wormscarf67

Plantera
Yo, Is the current TmodLoader on Steam available to be upgraded to 64 bit, or is it already so. If not, do you just have to download this separately?
 

FreezingNow

Terrarian
Hey. I have a question. Discord seems unable to help me so I turned here. I am using the 64 bit version of tmodloader on my laptop. I downloaded a somewhat big map so it slows down when I play it. I decided to switch to my dedicated gpu to help out with this. I use amd gpu. I switch to high performance in graphics settings, which does the trick for other games and for tmodloader 32 bit, but not for 64bit. The console reads that it is still using my non-dedicated gpu. How can I make it read my dedicated gpu?
 

direwolf420

Terrarian
Hey. I have a question. Discord seems unable to help me so I turned here. I am using the 64 bit version of tmodloader on my laptop. I downloaded a somewhat big map so it slows down when I play it. I decided to switch to my dedicated gpu to help out with this. I use amd gpu. I switch to high performance in graphics settings, which does the trick for other games and for tmodloader 32 bit, but not for 64bit. The console reads that it is still using my non-dedicated gpu. How can I make it read my dedicated gpu?
If your terraria/tmodloader uses your integrated GPU instead of the actual NVIDIA GPU, this fix might work: NVIDIA Control Panel -> Adjust Image Settings with Preview -> Use the advanced 3D image settings -> Apply -> Click "Take me there" -> Under "Preferred graphics processor" switch to "High-performance NVIDIA processor" -> Apply

If you are on an amd GPU, there might be similar settings
 

FreezingNow

Terrarian
If your terraria/tmodloader uses your integrated GPU instead of the actual NVIDIA GPU, this fix might work: NVIDIA Control Panel -> Adjust Image Settings with Preview -> Use the advanced 3D image settings -> Apply -> Click "Take me there" -> Under "Preferred graphics processor" switch to "High-performance NVIDIA processor" -> Apply

If you are on an amd GPU, there might be similar settings
I appreciate the response. Unfortunately, I have already tried switching my gpu using the standard method for amd gpu.
 

occuckle

Terrarian
how do I turn it off. everything is slower. Switch to vanilla button thing in bottom right doesn't work. I would like a response I am planning on recording
 
Last edited:

desolatorpk

Terrarian
Hello Dradonhunter11 !
Thank you, for your work!!!
Thank you for x64 version of tmodloader.
You help many peoples to get good time with modded terraria!

But, why we not have x64 tmodloader on steam?
Can x32 autors connect you to that project?
(idk what with your relationships with x32 devs)
 

BRSaura

Terrarian
I would be very grateful if someone can help me out here, I always played tmodloader 64 with the Host & Play option, mostly because it allows for steam invite, I can't make the "tModLoaderServer.exe" work with steam, if I enter the config '-steam' and '-lobby friends' it will connect but recognized as Terraria, the vanila version in steam, and all my invites will be of that game instead of tmodloader when in the server. I saw the other option being standard IP connection but I was wondering if there is some way to make it work with steam.
 

wahoo

Terrarian
Hello, the great developers, Dragonhunter11!
Thank you for your work!

I don't want 64bit tmodloader to recognize the gamepad.
I'm playing Terraria by assigning keyboard input to my gamepad.
but, 64bit tmodloader recognizes the gamepad and behaves like a console version. I don't like it very much.
Can we turn off this feature?
(Sorry for the machine translation.)
 
Just installed 11.8 and the app wasn't running in 64bit, even though I was using that specific launcher. Turns out the Steam .zip files for 11.8 were missing the "CSteamworks.dll", "steam_api.dll" and "steam_appid.txt" files, so I had to copy them over from my vanilla install folder, and everything works now. If anyone else is having that problem, there's your fix for it.
 

Borris

Terrarian
I have a problem with my 64bit, it opens and begins running but when it begins to instantiating the mods, it locks up. It doesn't freeze the application (the background still moves) but I am unable to make it to the main menu of 64bit tmodloader. Any input would be greatly appreciated.
 
Top Bottom