1. For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
    Dismiss Notice

Standalone [1.3] tModLoader - A Modding API

Discussion in 'Works-in-Progress' started by blushiemagic, Jul 7, 2015.

  1. ozoahameg

    ozoahameg Terrarian

    guys i have a major problem
    some of my mods is only updatable on 0.11 tmodloader
    and 0.11 tmodloader wont work on my terraria it just when i open terraria it wont do anything
    i tried looking at the task manager and when i open terraria it just vanishes after a few seconds it wont even error or warning it just instantly stop please help
    please update 0.11.3 here some mods are already putting their update there and im getting a lot of bugs cause i updated my mods accidentally but it says 0.11 tmodloader needed
     
  2. jopojelly

    jopojelly Retinazer

    tModLoader v0.11.3 Released

    Hey everyone, it's been a long time since the last official update to tModLoader, over 1 year in fact. We are happy to tell you that tModLoader v0.11.3 is now out to everyone. In the past few months we've been testing earlier versions of 0.11 and now it is ready for everyone.

    There are way too many changes to list here, so feel free to check out the changelogs from v0.11 to 0.11.3.

    The biggest change is ModConfig. ModConfig allows modders the ability to allow users to configure the behavior of their Mod. ModConfig settings are automatically synced in multiplayer, and can easily be changed in-game through the user interface.

    A good example of this new feature is my mod Shorter Respawn Time. Previously, it was up to me what the definition of "shorter" should be. Now, on 0.11, users can customize the Shorter Respawn Time mod to customize how long they should be dead for. See the video below for a quick example.


    I hope you can see how convenient ModConfig is. If ModConfig is applicable to a mod you are making, I hope you take the effort to update your mod to 0.11 to take advantage of it.

    Another huge feature is the GOG version of Terraria is now officially supported.

    There are 100s of bug fixes as well that have been hampering 0.10.1.5 playthroughs, we hope our fixes make your modded Terraria experience even better.

    Most current mods should work on 0.11.3, with a few exceptions (If you notice any broken mods, encourage the modder to fix their mod). If you need help updating the code to your mod, see the 0.11 migration guide and come to the discord chat.

    Below are links to the download, the discord chat in case you have any questions, our Patreon which motivates us to spend our free time on tModLoader, and a link to the Github for tModLoader.


    Direct Download Links:
    Steam/GoG: Windows | Mac | Linux

    tModLoader Discord chat: Join the tModLoader Discord Server!
    [​IMG]


    Donations are always appreciated! The tModLoader team is creating tModLoader | Patreon

    Open Source
    In case you want to see how messy my code has become, tModLoader is now open source! Feel free to suggest features either on this thread or over Github.
    Github Repository Link
     
    Solo-Ion and DRKV like this.
  3. ozoahameg

    ozoahameg Terrarian

    HELLO

    i have a major problem on 0.11 tmodloader
    my terraria wont run, it instantly stops after a few seconds not even a warning or an error
    i tried looking at the task manager and it just instantly vanishes and stops loading before the game appear on my screen please help
    --- Double Post Merged, Jul 24, 2019, Original Post Date: Jul 24, 2019 ---
    also 1 more thing why does the 0.11 dont have the ModComile folder? is it the reason it wont work on my terraria?
    i tried following the instructions word per word it wont work please help me
     
  4. jopojelly

    jopojelly Retinazer

    We need log files to help you. You'll find the log files in the logs folder. Look for client.log.
    Windows Logs: C:\Documents\My Games\Terraria\ModLoader\Logs
    Linux Logs: ~/.local/share/Terraria/ModLoader/Logs/ or $XDG_DATA_HOME/Terraria/ModLoader/Logs/
    Mac Logs: ~/Library/Application support/Terraria/ModLoader/Logs/
    --- Double Post Merged, Jul 24, 2019, Original Post Date: Jul 24, 2019 ---
    actually, we pretty much never come on the forum, anyone wanting real help should come to the discord.
     
  5. ozoahameg

    ozoahameg Terrarian

    where can i give you my log files?
     
  6. jopojelly

    jopojelly Retinazer

    here.
     
  7. Azgodriel

    Azgodriel Terrarian

    In an attempt to make my mod ran into a problem like for an object with the" placed" property specify sprite (the problem is that when I put this object, instead there is a dirt block).
     
    Last edited: Jul 24, 2019
  8. ender596

    ender596 Skeletron Prime

    I think that the new modloader is glitched out. Whenever I exit fullscreen it looks like I set my UI to the max, and everything is zoomed in. (Including the title screen)
     
  9. Milkoloid

    Milkoloid Terrarian

    I faced the same problem as ozoahameg. I would like to ask how to solve this.
     
  10. Firere012

    Firere012 Steampunker

    I also have the same problem as ^.
    Unfortunately, the program cuts out so fast that it doesn't even write a log.
     
  11. ozoahameg

    ozoahameg Terrarian

    hello
    the new tmodloader only runs on original terraria not cracked
    luckily im planning to buy the terraria in steam after the 1.4 update so its ok for me ill stay on 0.10 tmod until the 1.4 update is released
     
  12. marshall.

    marshall. Terrarian

    i'm trying to reinstall tmodloader but the installer is not the right file. what do i do? (nvm i fixed it)
     
    Last edited: Jul 26, 2019
  13. xRaiizy

    xRaiizy Official Terrarian

    eh,the old one's interface was kinda better :(
     
  14. Pieseł Damaton

    Pieseł Damaton Steampunker

    im new and i need help with tmodloader so i guess i need to post it here, so anyway when i start up terraria and i want to get some mods mod browser says like check your connection and so on, i dont know what to do now, i have newest tmodloader and terraria and sorry for my crap english
     
  15. Malaruxa

    Malaruxa Terrarian

    Hello :)

    I'm having some problems getting Terraria to work with tModLoader. I installed Terraria only a few days ago and haven't used mods in any game at all before so it's all a bit new to me.
    I downloaded tModLoader.Windows.v0.11.3.zip and did my best to carefully follow the GOG Manual Install instructions in the README.txt, but when I try starting the game the normal way I get an error message that I don't understand, and the game won't start at all.
    If I instead start the game from the renamed vanilla exe the game works, but no mods of course.
    The error message starts with "System.DllNotFoundException: Unable to load DLL 'CSteamworks': The specified module could not be found. (Exception from HRESULT: 0x8007007E)"

    I'd really appreciate getting some advice if anyone happen to know what's going on :)

    I'm on Windows 7, bought the game from GOG.com (I have no Steam client), have no mods at all yet, and here is the client.log from My Games / Terraria / Modloader / Logs in case it helps :)

    [15:35:09] [1/INFO] [tML]: Starting tModLoader v0.11.3 Windows client
    [15:35:09] [1/INFO] [tML]: Running on NetFramework 4.7
    [15:35:09] [1/INFO] [tML]: Executable: C:\GOG Games\Terraria\Terraria.exe
    [15:35:09] [1/INFO] [tML]: Working Directory: c:\gog games\terraria
    [15:35:09] [1/INFO] [tML]: Launch Parameters:
    [15:35:09] [1/DEBUG] [tML]: Assembly Resolve: -> MonoMod.RuntimeDetour, Version=19.5.19.1, Culture=neutral, PublicKeyToken=null
    [15:35:09] [1/DEBUG] [tML]: Assembly Resolve: MonoMod.RuntimeDetour, Version=19.5.19.1, Culture=neutral, PublicKeyToken=null -> MonoMod.Utils, Version=19.5.19.1, Culture=neutral, PublicKeyToken=null
    [15:35:09] [1/DEBUG] [tML]: Assembly Resolve: MonoMod.Utils, Version=19.5.19.1, Culture=neutral, PublicKeyToken=null -> Mono.Cecil, Version=0.10.3.0, Culture=neutral, PublicKeyToken=50cebf1cceb9d05e
    [15:35:10] [1/DEBUG] [tML]: Assembly Resolve: -> Newtonsoft.Json, Version=10.0.0.0, Culture=neutral, PublicKeyToken=30ad4fe6b2a6aeed
    [15:35:10] [1/DEBUG] [tML]: Assembly Resolve: -> Steamworks.NET, Version=9.1.0.0, Culture=neutral, PublicKeyToken=null
    [15:35:10] [1/WARN] [tML]: Silently Caught Exception:
    System.DllNotFoundException: Unable to load DLL 'CSteamworks': The specified module could not be found. (Exception from HRESULT: 0x8007007E)
    at Steamworks.NativeMethods.SteamAPI_RestartAppIfNecessary(AppId_t unOwnAppID)
    at Terraria.Social.Steam.CoreSocialModule.Initialize()
    at Terraria.Social.SocialAPI.Initialize(Nullable`1 mode)
    at Terraria.Program.LaunchGame_()
    at Terraria.Program.LaunchGame(String[] args, Boolean monoArgs)
    at Terraria.WindowsLaunch.Main(String[] args)


    [15:35:10] [1/FATAL] [Terraria]: Main engine crash
    System.DllNotFoundException: Unable to load DLL 'CSteamworks': The specified module could not be found. (Exception from HRESULT: 0x8007007E)
    at Steamworks.NativeMethods.SteamAPI_RestartAppIfNecessary(AppId_t unOwnAppID)
    at Terraria.Social.Steam.CoreSocialModule.Initialize()
    at Terraria.Social.SocialAPI.Initialize(Nullable`1 mode)
    at Terraria.Program.LaunchGame_()
     
  16. Zenki

    Zenki Skeletron Prime

    I install manually the new version and follow the instructions, but when I open the Terraria.exe (The one with the jungle tree icon), the Windows Defender opens up, I continue with open the game, it never opens, I've been waiting half an hour and it doesn't open. Please, help
    `:cry:
     
  17. AlexRO

    AlexRO Terrarian

    @Zenki i had the same thing happen to me when i updated to the latest tmodloader version.I don't know what to do now.
     
  18. Malaruxa

    Malaruxa Terrarian

    Update to my problem: I tried several times yesterday but it didn't work and I'm sure I downloaded the right file since it said Steam/GOG and Windows, but I left it as it was and my friend and I played vanilla Terraria later (I renamed the folder with the mod files and used the backup I made of the whole install folder). But today when I renamed the folder back again to try one more time the game started and it looks like it works! I haven't tried playing yet since I don't have time today, but the game starts and now have Mod Browser and Mods in the options list as I have seen on screenshots that it should look like with tModLoader installed :) No idea why it didn't work before, the only thing I did was to rename the folder "Terraria mod" and play with my backup folder, and then rename the backup "Terraria vanilla" and rename the modded one back to just "Terraria" again.

    Oh and when trying to pick characters there is great information visible in game telling us why there are no characters there and it even opens the right folders we need to copy in our characters if we click. Really really user friendly! Thanks a million! :)
     
  19. Abadi

    Abadi Terrarian

    Hi there! I'm a Windows 7 user who plays Modded Terraria quite a lot. :happy:
    However, since v.11, I have a problem that nobody seems to talk about, and here is what I mean:
    When I open Terraria, The game doesn't start which some people say is quite normal as it takes a little bit for Terraria to load, though, I waited for 30 minutes and nothing happened, the game didn't run, the App Manager (a third-party app) said no startup process was even planning to run, I tested it on a different Windows 7 device, and same thing, I tried it on a PC tablet and same thing (I'm clearly stupid for using a PC Tablet). -_-

    I really like Modded Terraria and I really would like you to fix it. :D
     
  20. Isaiah863718

    Isaiah863718 Terrarian

    Hello i was wondering if the calamity mod will be getting updated to the mod browser because i am unable to download it from the discord or wiki. Any help would be appreciated.