• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

Standalone [1.3] tModLoader - A Modding API

Malaruxa

Terrarian
Update to my problem: I tried several times yesterday but it didn't work and I'm sure I downloaded the right file since it said Steam/GOG and Windows, but I left it as it was and my friend and I played vanilla Terraria later (I renamed the folder with the mod files and used the backup I made of the whole install folder). But today when I renamed the folder back again to try one more time the game started and it looks like it works! I haven't tried playing yet since I don't have time today, but the game starts and now have Mod Browser and Mods in the options list as I have seen on screenshots that it should look like with tModLoader installed :) No idea why it didn't work before, the only thing I did was to rename the folder "Terraria mod" and play with my backup folder, and then rename the backup "Terraria vanilla" and rename the modded one back to just "Terraria" again.

Oh and when trying to pick characters there is great information visible in game telling us why there are no characters there and it even opens the right folders we need to copy in our characters if we click. Really really user friendly! Thanks a million! :)
 

Abadi

Terrarian
Hi there! I'm a Windows 7 user who plays Modded Terraria quite a lot. :happy:
However, since v.11, I have a problem that nobody seems to talk about, and here is what I mean:
When I open Terraria, The game doesn't start which some people say is quite normal as it takes a little bit for Terraria to load, though, I waited for 30 minutes and nothing happened, the game didn't run, the App Manager (a third-party app) said no startup process was even planning to run, I tested it on a different Windows 7 device, and same thing, I tried it on a PC tablet and same thing (I'm clearly stupid for using a PC Tablet). -_-

I really like Modded Terraria and I really would like you to fix it. :D
 

Isaiah863718

Terrarian
Hello i was wondering if the calamity mod will be getting updated to the mod browser because i am unable to download it from the discord or wiki. Any help would be appreciated.
 

jopojelly

Retinazer
This is a reminder that the best way to get help is on the discord chat. It's pretty impossible to help here. Come to discord: tmodloader.net/discord
 

this is NOVA

Ice Queen
When I build a mod this error comes up frequently:
error:
Compiling ModName.XNAdll failed with # errors and C:\LocationOfModSourceFolder\ModName\obj\net45\ModName,AssemblyInfo.cs(13,11) : error CS0579: Duplicate 'System.Reflection.AssemblyCompanyAttribute' attribute warnings

I check the file and there doesn't seem to be a duplicate as far as I'm aware and I just delete the obj folder everytime this error appears and it's pretty annoying.
Not sure if this is a bug with tModLoader, or if there's something wrong with the mod.

This error usually comes up after I add something such as a item or recipe to the mod.
 

SpirirOfDoom

Terrarian
Hey is there any way to disable auto loading?
I went to update/download mods and it auto enabled and loaded them, my potato didn't like that very much when i updated large mods with overhaul.
 

jopojelly

Retinazer
When I build a mod this error comes up frequently:
error:
Compiling ModName.XNAdll failed with # errors and C:\LocationOfModSourceFolder\ModName\obj\net45\ModName,AssemblyInfo.cs(13,11) : error CS0579: Duplicate 'System.Reflection.AssemblyCompanyAttribute' attribute warnings

I check the file and there doesn't seem to be a duplicate as far as I'm aware and I just delete the obj folder everytime this error appears and it's pretty annoying.
Not sure if this is a bug with tModLoader, or if there's something wrong with the mod.

This error usually comes up after I add something such as a item or recipe to the mod.
we've heard reports of deleting a Properties/AssemblyInfo.cs file, if you have that file, delete it and try again.
 

Inferno Gear

Terrarian
Hello there. I'm in need of help.

Back on v0.10.1.5, I could boot the game with no issues, the same applies currently with vanilla Terraria. However, the moment I try to play v0.11.3 TModLoader Terraria, the following occurs (log file supplied)
[06:17:41] [1/INFO] [tML]: Starting tModLoader v0.11.3 Windows client
[06:17:41] [1/INFO] [tML]: Running on NetFramework 4.7.2
[06:17:41] [1/INFO] [tML]: Executable: C:\Program Files (x86)\Steam\steamapps\common\Terraria\Terraria.exe
[06:17:41] [1/INFO] [tML]: Working Directory: C:\Program Files (x86)\Steam\steamapps\common\Terraria
[06:17:41] [1/INFO] [tML]: Launch Parameters:
[06:17:42] [1/DEBUG] [tML]: Assembly Resolve: -> MonoMod.RuntimeDetour, Version=19.5.19.1, Culture=neutral, PublicKeyToken=null
[06:17:42] [1/DEBUG] [tML]: Assembly Resolve: MonoMod.RuntimeDetour, Version=19.5.19.1, Culture=neutral, PublicKeyToken=null -> MonoMod.Utils, Version=19.5.19.1, Culture=neutral, PublicKeyToken=null
[06:17:42] [1/DEBUG] [tML]: Assembly Resolve: MonoMod.Utils, Version=19.5.19.1, Culture=neutral, PublicKeyToken=null -> Mono.Cecil, Version=0.10.3.0, Culture=neutral, PublicKeyToken=50cebf1cceb9d05e
[06:17:42] [1/DEBUG] [tML]: Assembly Resolve: -> Newtonsoft.Json, Version=10.0.0.0, Culture=neutral, PublicKeyToken=30ad4fe6b2a6aeed
[06:17:43] [1/DEBUG] [tML]: Assembly Resolve: -> Steamworks.NET, Version=9.1.0.0, Culture=neutral, PublicKeyToken=null
[06:17:43] [1/WARN] [tML]: Silently Caught Exception:
Microsoft.Xna.Framework.Graphics.NoSuitableGraphicsDeviceException: Could not find a Direct3D device that supports the XNA Framework Reach profile.

Verify that a suitable graphics device is installed.

Make sure the desktop is not locked, and that no other application is running in full screen mode.

Avoid running under Remote Desktop or as a Windows service.

Check the display properties to make sure hardware acceleration is set to Full.
at Microsoft.Xna.Framework.GraphicsDeviceManager.FindBestPlatformDevice(Boolean anySuitableDevice)
at Microsoft.Xna.Framework.GraphicsDeviceManager.FindBestDevice(Boolean anySuitableDevice)
at Microsoft.Xna.Framework.GraphicsDeviceManager.ChangeDevice(Boolean forceCreate)
at Microsoft.Xna.Framework.GraphicsDeviceManager.Microsoft.Xna.Framework.IGraphicsDeviceManager.CreateDevice()
at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
at Terraria.Program.LaunchGame_()
at Terraria.Program.LaunchGame(String[] args, Boolean monoArgs)
at Terraria.WindowsLaunch.Main(String[] args)

I've looked into other people having this issue, and I have tried all the suggestions.
Update Graphics Driver? It's already updated.
Delete Config.dat? That does not exist on my computer.
Delete Config.json? No effect.
Restart? No effect.
Re-install? No effect.
Delete Steam's AppCache? No effect.
Re-install the dependencies? No effect.

Here are my PC specs:
OS: Windows 10 Home
Processor: Intel(R) Core(TM)2 Duo CPU E7400 @ 2.80 GHz
RAM: 4 GB
System Type: 64-bit.
 

direwolf420

Terrarian
Try running Terraria.exe in compatiblity mode
1. Right click terraria.exe, properties, then compatibility
2. then set tick on compatibility mode and select win 8 (or try others)
3. Click Apply then relaunch Terraria
 
Modyfikacja (0.11.3), między innymi Spirit mod nie może być dobrze załadowany, gdy jest inny świat z modem tremor remasterowany i nie może być załadowany podczas tworzenia świata po szczegółach np. ruiny, w dodatku gdy masz świat i wejdę do niego nie mogę się ruszać nie działa klawiatura, gra w tle działa płynnie i mogę ruszać myszką i pisać na chacie ale nie działają klawisze podczas rozgrywki przez co mogę zamykać gry poprzez alt + f4. Bardzo bym prosił żeby te błędy zostały rozwikłane :(
 

Zaragan

Golem
Did anyone notice you cant use the coin gun with tmodloader on? Clean install, edit the char with it and it doesnt make any damage but can break grass/mushrooms...
 

Slimeboi300

Terrarian
So i'm not sure if this was covered anywhere else (I did see in-game that some mods were in-compatible with the new tmodloader update) but after like an hour or so testing some stuff, I found that loading Shadows of Abaddon (Sacred Tools) breaks the game with the new 11.3 update. I wasn't able to move or use anything at all, other than interact with the guide. Even pressing escape to get into the inventory wasn't working.

As far as I know this is the only mod that I've seen have this effect, but there could be more. I'm also not sure if I should be posting this here or not, but I figured why the heck not.:D
 

Spoody

Terrarian
Я спокойно играл себе в Террарию с модами, как вдруг мод Calamity перестал работать. Решил обновить tModLoader и на тебе: Terraria.exe не является приложением WIn32... Какого хера? Спасибо за минус игру и время. Надеюсь исправите. На всякий пожарный перевод: I calmly played myself in Terraria with mods, when suddenly the Calamity mod stopped working. I decided to update tModLoader on you too: Terraria.exe is not a WIn32 application ... What the hell? Thanks for minus the game and time. Hope to fix it.
 

Aliistrae

Terrarian
Last night I tried to set up Terraria after a long break and decided to download this mod loader. Sadly I can't open doors, and I tried one mod at a time to see if it was a mod I was using. I also tried disabling mods, and that didn't work either.

Edit: It isn't just doors it seems to be items that require right-click. I will have to forgo mods till there is a fix.
 
Last edited:
Top Bottom