1. For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
    Dismiss Notice
  2. For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.
    Dismiss Notice
  3. TCF will be undergoing a scheduled software and server upgrade on September 26, 2019 beginning at 9:00AM GMT. TCF may be unavailable for an extended period after this time. More information can be found here. We apologize in advance for any inconvenience this may cause, we will try to keep the downtime short.

Standalone [1.3] tModLoader - A Modding API

Discussion in 'Works-in-Progress' started by blushiemagic, Jul 7, 2015.

  1. HoodedBadger

    HoodedBadger Terrarian

    it wont let me update from 0.10.1.5 to the current one, is there a way to fix that?
    `:cry:
     
  2. personman19

    personman19 Terrarian

    Weird new problem; mine only launches in 32 bit, aka in the background. Unmodded Terraria works fine, but TmodLoader currently breaks it. I normally also run x64 version, but switching files around does nothing. I have the problem where it keeps the client.log.old file, which I can delete to get around that problem, but nothing else works. I've restarted steam, restarted my computer, reinstalled both Terraria and Tmodloader, the newest version, but nothings making any difference. I've also tried running the game in a couple different compatibility modes, and deleting my log folder to try and fix the old client file problem.

    Any suggestions?
     
  3. eggshells

    eggshells Plantera

    TModloader 64 bit is a different installation. Refer to the official 64 bit thread for the download link.
     
  4. Stephen Lynx

    Stephen Lynx Terrarian

    On linux I can't install any mods through the mod browser (I could install them by manually downloading the mod and copying them to the mod directory) and I couldn't save games. The whole thing would just not be there when I came back to it. I did ask to put the character in the cloud, if that helps.
     
  5. How to get to play many mods? ( mod 50+ )
     
  6. Gretrut

    Gretrut Terrarian

    Hello!

    I'm having trouble with Providence!
    Of course, I mean the boss from Calamity Mod
    When I start to attack him and get 10 seconds after starting the fight, the game crashes and turns off!

    Please help!
     
  7. Blood Crawler

    Blood Crawler Brain of Cthulhu

    Same as playing not many mods
     
  8. FROSTBYTE7PH

    FROSTBYTE7PH Terrarian

    Are you going to make or try to make modding for terraria mobile?
     
  9. jopojelly

    jopojelly Retinazer

    No.
     
  10. TitusPollo

    TitusPollo Terrarian

    Hello I just installed Tmodloader v0.11.4 and getting the following error message everytime I try to scroll through new mods in the Mod Browser.


    Code:
    See the end of this message for details on invoking
    just-in-time (JIT) debugging instead of this dialog box.
    
    ************** Exception Text **************
    System.NullReferenceException: Object reference not set to an instance of an object.
       at Terraria.ModLoader.UI.ModBrowser.UIModDownloadItem.IconDownloadComplete(Object sender, DownloadDataCompletedEventArgs e)
       at System.Net.WebClient.OnDownloadDataCompleted(DownloadDataCompletedEventArgs e)
       at System.Net.WebClient.DownloadDataOperationCompleted(Object arg)
    
    When I click *Continue* the indenting of the mod download button(s) settle in correctly.
     

    Attached Files:

    Last edited: Sep 16, 2019 at 9:04 PM
  11. Fnaf g

    Fnaf g Steampunker

    It will not let me update to the new version
     
  12. DrakeLyon

    DrakeLyon Golem

    Is this not fully compatible with 1.3.5.3? After installation, I'm seeing 1.3.5.2 in the lower left and that really throws off the vibe of the game. Does this downgrade Terraria or something?
     
  13. Fnaf g

    Fnaf g Steampunker

    First off I do not know how to downgrade the game
     
  14. Firefly Bree

    Firefly Bree Terrarian

    Hi, I followed this guide tModLoader - How to set up your mod using Visual Studio (MVS) to setup VS with Terraria, and I had some confusion about

    Right click Mod Sources --> Add --> New Project --> Visual C# --> Windows --> Classic Desktop --> Empty Project

    and chose a .net project. Not sure if this was right. I couldn't use a universal window, but my Solution Explorer looks like others. The problem I am having is when I run the program it looks for a main method, and I don't remember needing a main method to start the application. I referenced the Terraria.exe and .dll files. Any ideas would be useful.

     
  15. jopojelly

    jopojelly Retinazer

    tModLoader will say 1.3.5.2, that is expected. The only thing that matters is the tModLoader version it says.

    That guide is old, please follow the current guides, which are found on the wiki. Specifically this: tModLoader/tModLoader
     
  16. jopojelly

    jopojelly Retinazer

    we know, hopefully fixed next release.
     
    TakinTheHeat likes this.
  17. TakinTheHeat

    TakinTheHeat Terrarian

    thanks i love you