1. For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
    Dismiss Notice
  2. For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.
    Dismiss Notice
  3. TCF will be undergoing a scheduled software and server upgrade on September 26, 2019 beginning at 9:00AM GMT. TCF may be unavailable for an extended period after this time. More information can be found here. We apologize in advance for any inconvenience this may cause, we will try to keep the downtime short.

Standalone [1.3] tModLoader - A Modding API

Discussion in 'Works-in-Progress' started by blushiemagic, Jul 7, 2015.

  1. Milox97

    Milox97 Terrarian

    Search for your client.log on "C:/Documents/My Games/Terraria/ModLoader/Logs" and there will be the reason why, maybe you have a pirated version of the game (like me)
    --- Double Post Merged, Aug 16, 2019, Original Post Date: Aug 16, 2019 ---
    I already find the problem, thanks for the support!
     
  2. [Cloud9] bruh

    [Cloud9] bruh Terrarian

    please make 64 bit.
     
  3. ghostspy

    ghostspy Terrarian

    I installed this mode I get this error constantly when I open the game please help I can not figure out what I can not install a mode at all
     

    Attached Files:

    • wtf.png
      wtf.png
      File size:
      544.5 KB
      Views:
      134
  4. jopojelly

    jopojelly Retinazer

    try updating to 0.11.4, if you still have issues after that, edit the config.json and change
    "AvoidImgur": false,
    to true
     
  5. Kaos_

    Kaos_ Terrarian

    Hey guys!First of all I'm sorry if my English isn't that good. Ok,now to my problem:I wanted to play Terraria with tML but when I was in the menu, a message that said, that something went wrong while loading, the problem where unknown, and that I need to restart my tML showed up. But how do I do that, and what's the problem? By the way, I already re-installed tML, but this message is still there.I'm sure that I replaced ALL files in my Terraria folder.

    I hope, that somebody could help me! I would really appreciate it!;)
     
  6. blushiemagic

    blushiemagic Retinazer

    v0.11.4 has been released.

    Changelog:
    API
    -Projectile/NPC/PrefixDefinition classes, similar to ItemDefinition
    -ModConfig now supports default values for reference fields, greatly simplifying ModConfig code
    --(Also defaults to not allowing null values in UI, use NullAllowed to reverse this)
    -Fix Duplicate 'AssemblyTitle' attribute warnings when upgrading csproj
    -XML Documentation for MonoMod now automatically provided
    Fixes
    -Fix proxy issue to fix Mod Browser downloads for proxy users
    -Fix Coin gun damage issue
    -Fix Minion Targetting/Double hit issue with some weapons
    -Fix multiline Header in ModConfig
    -Fix zip file handling on Mac/Linux, should allow for ModCompile and TexturePack support fixes
    QOL
    -Pirated and broken GOG install message alerts
    -Installed filter on Mod Browser
    -Mods with chat tags can now be properly sorted and searched in Mod Browser and Mods menus
    -Search bar for ModConfig
    -Helpful message for deleting mods in game
    -Avoid Imgur config.json option if you know imgur is blocked in your country
    ExampleMod
    -Fix VoidMonolith PreDraw bug
    -Other small issues fixed
     
  7. upload_2019-8-18_6-59-0.png HELP ME :(
     
  8. jopojelly

    jopojelly Retinazer

  9. Gretrut

    Gretrut Terrarian

    Screenshot

    Hello! 1.11.4 doesn't work for me! It pops up when I run and when I got this new version I made and the same error was!

    Unfortunately, if you do not understand Polish, you can translate it to English, because I am from Polish and my computer is also in Polish.
     
  10. eugeny

    eugeny Terrarian

    avast found virus alexa51
     
  11. FerrisCG

    FerrisCG Terrarian

  12. Airito

    Airito Terrarian

    Let this mod to auto update.
    Now i can't run my terraria game
    Here's the message (watch sreenshot)

    Translation: impossible to create a file because it's already exist

    Any suggestions?
     

    Attached Files:

  13. naivety

    naivety Terrarian

    I have the same problem... v0.11.3 and v0.11.4 both give me the error shown in the image that I uploaded attached to my post. (I also attached the client.log file showing the issue.)

    For reference, I'm using an old PC, Windows 7, with pretty bad specs. I've installed and ran v0.11.4 successfully in two other Windows 10 PCs without problems, and v0.11.3 also works on them.

    On this PC, I was able to use v0.10.1.5 briefly, used it to install Thorium + a few quality of life mods and played for a bit, without any problems. However, recently an error whenever I attempt to start Terraria has been happening (gives no error message, but it does generate a Logs.txt file that I also attached). Terraria.exe starts normally, the mods seem to be initialized normally, but it crashes in the "Setting up..." screen.
    EDIT: got v0.10.1.5 to work again by going to My Games -> Terraria -> ModLoader and putting everything mod-related in a backup folder, then reinstalling the mods I wanted (sticking to the absolute essentials) and restarting.

    Vanilla works normally, as I am able to enter a world and play without any crashes.



    Any idea on what to do here? I've tried various versions, as well as reinstalling, and nothing solved either of the problems. If possible I'd like to make a version of v0.11 work, but if someone finds a workaround for v0.10 that'd be appreciated as well.



    Technical mumbo-jumbo aside, I'd like to thank the developers for this tool... enjoying it a lot in the other PCs I set it up. I'm glad to have a tool that makes modding this easy :)
     

    Attached Files:

    Last edited: Aug 20, 2019
  14. jopojelly

    jopojelly Retinazer

    you can try deleting the config.json file in the ModLoader/ folder. It might help with 0.11.4
     
  15. naivety

    naivety Terrarian

    This doesn't seem to work... you mean the folder accessible from Documents -> My Games, right? I tried deleting the file, reverting the Terraria to its original version (was 0.10.1.5 before) and switching to v0.11.4, but the same error message appears.

    I managed to make v0.10.1.5 playable again though, seems like it was a problem with a specific mod :)
     
  16. Spoody

    Spoody Terrarian

    Вышла новая версия, а Террария после обновлнеия всё ещё 64-битная... Когда будет 32?
    A new version has been released, and Terraria after the update is still 64-bit ... When will it be 32?
     
  17. Phaeton

    Phaeton Terrarian

    Has anyone ever figured out how to do glowmasking for armor pieces? I know it's possible for items, like weapons, but I have yet to see an example mod that uses glowmasking for armor.

    Does anyone have an example I could work from?
     
  18. Phaeton

    Phaeton Terrarian

    With the fantastic help of someone here on the forums (not sure if he wants credit), I was able to (well, he was able to) get the glowmasking to work with armor -

     
    DRKV likes this.
  19. ozoahameg

    ozoahameg Terrarian

    hello Tmodloader
    i have 1 suggestion that it would help a lot
    please announce your new update in the forums too, i encountered a bug and was scratching my head until i found the tmod was updated, please leave an announcement every update in the tmod please, it would help us a lot just post a simple message here in your forums and we will benotified
    THANKS!!
     
  20. Abelishe

    Abelishe Terrarian

    Yes, I was trying for the pirate game, but now I installed the original and it's all right. Thanks