• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • 1.4 will bring many changes to the PC version. We strongly advise making plans to back up your worlds and players prior to updating your game. More details here.
  • Begin your search for Journey's End information here and here. Please report bugs and issues for Journey's End here.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

Standalone [1.3] tModLoader - A Modding API

Zannypants

Terrarian
I keep getting an OutOfMemory exception every time I try to load a world through the updated tModLoader. It works fine in Vanilla Terraria, and I'm pretty sure I installed the new tModLoader correctly...

EDIT: Reverting back to tModLoader version 0.8.3.2 (I had the .rar on my desktop) allows it to work just fine, albeit in the non-updated form.
It's because you've got mods that haven't been updated to work with the new tmod

is it working for the latest version of terraria vanilla? thx
Read the page before this
 

LenIAM

Official Terrarian
it kept launching the vanilla terraria eventho i have rename the modded terraria to terraria.exe , why is this ? please help
 

Dragonpriest4

Skeletron Prime
There is a weird bug (at least for me) when I try to pick up a forbidden fragment my character freezes in place and can't die or do anything forcing me to reload the world.
 

goatfatdoc

Terrarian
On my tmodloader server, no mobs spawn on the surface. I know its not one of the mods, because it happens when all of them are disabled too. It does not happen on single player. Events don't even work. Please help!
 

ShirazEpic

Terrarian
tmodloader 1.3.3 as fast as possible pls
[doublepost=1473814265,1473814240][/doublepost]
IT DOESNT WORK IS 1.3.3?!
really?
[doublepost=1473814305][/doublepost]
Really? All you have to do is check the version on Terraria and then check the page.
It really isn't that hard.
all i have to do is that?!
[doublepost=1473814331][/doublepost]
Really? All you have to do is check the version on Terraria and then check the page.
It really isn't that hard.
there doesnt seem to be a 1.3.3 version :(
 

ShirazEpic

Terrarian
Dude... go into terraria and look in the bottom left. then go and check what version this is compatible with. See the difference?
yeah, terriria is 1.3.3.2 but this is 1.3.2
HOW DO I GET A 1.3.3 VERSION THAT WORKS WITH 1.3.3, I RE-DOWNLOADED IT SEVERAL TIMES AND NOTHING HAPPENED!!?
I'm triggered now. :(
 

ShirazEpic

Terrarian
after using my nerd powers i fixed it, just needed to manually do something

sometimes you can't trust a downloader that uses JUST javascript
I'm an idiot
[doublepost=1473815323,1473815299][/doublepost]
Yeah, I'm wasting my time here.
naw you triggered me which actually helped to ty
lol
 

Ryushusupercat

Terrarian
For the record, it says I'm using Terraria version 1.3.3.1, even though it says that both versions of Terraria I have (vanilla and tModLoader) are 1.3.3.0

error.png

Also I am still getting OutOfMemory exceptions, so I feel that I'm just going to have to wait until every mod I'm using is updated; I have no idea which ones are causing the errors and which ones are fine to use.
 
Top Bottom