• For issues you find with the Switch and Console releases, please follow this link and give as much detail as possible. This is the speediest way to get info to Pipeworks and get a hotfix in the works.
  • For issues you find with the Mobile 1.3 update, please follow this link and give as much detail as possible. This is the speediest way to get info to DR Studios to look at your issue. Also, some troubleshooting hints here.

tModLoader HERO's Mod - Terraria Creative Mode + Server Management + And Over 25 tools

HERO

Terrarian
I'm not sure how to replicate the reload issue but I was able to fix it by going into my mods folder and deleting the mod, closing terraria, reloading terraria, and re downloading the mod in the mod browser. I'm not sure which of these fixed it. I am still doing some testing.
 

venomterraria

Terrarian
I'm not sure how to replicate the reload issue but I was able to fix it by going into my mods folder and deleting the mod, closing terraria, reloading terraria, and re downloading the mod in the mod browser. I'm not sure which of these fixed it. I am still doing some testing.
I've already done that and still doesn't work.
 

HERO

Terrarian
Reloaded tMod and I still crash. I've also tried getting rid of HERO's mod from the folder and reinstall it.

What I'm doing is:
1. Open the game
2. Go to mods
3. Activate all
4. Game crashes almost instantly

But

If I

1. Go to mod sources
2. Build + Reload my mod
3. Everything works
BUT
4. HERO's mod is outdated.
I've already done that and still doesn't work.
Taking a look at your post it seems related to your mod. I got the same error about the object not being referenced that you linked and was able to fix it by restarting terraria. After that issue is done going back to you first report there seems to be a conflict between your mod and hero's mod. Do you have a file for your mod we can test? We can't fix comparability issues without a copy of your mod to test on.
 

venomterraria

Terrarian
Taking a look at your post it seems related to your mod. I got the same error about the object not being referenced that you linked and was able to fix it by restarting terraria. After that issue is done going back to you first report there seems to be a conflict between your mod and hero's mod. Do you have a file for your mod we can test? We can't fix comparability issues without a copy of your mod to test on.
I'll PM it to you
 

Enrimeus

Golem
If anyone is experiencing the following logged runtime error when trying to update the mod after downloading it from this thread:

Object reference not set to an instance of an object.
at HEROsMod.UIKit.UIComponents.ItemBrowser.Unload() in C:\Users\Javid\Documents\My Games\Terraria\ModLoader\Mod Sources\HEROsMod\UIKit\UIComponents\ItemBrowser.cs:line 310
at HEROsMod.HEROsModServices.ItemBrowser.Unload() in C:\Users\Javid\Documents\My Games\Terraria\ModLoader\Mod Sources\HEROsMod\HEROsModServices\ItemBrowser.cs:line 61
at HEROsMod.HEROsMod.Unload() in C:\Users\Javid\Documents\My Games\Terraria\ModLoader\Mod Sources\HEROsMod\Mod.cs:line 141
at Terraria.ModLoader.Mod.UnloadContent()
at Terraria.ModLoader.ModLoader.Unload()
at Terraria.ModLoader.ModLoader.Reload()
at Terraria.ModLoader.UI.UIMods.ReloadMods(UIMouseEvent evt, UIElement listeningElement)
at Terraria.UI.UIElement.Click(UIMouseEvent evt)
at Terraria.UI.UserInterface.Update(GameTime time)
at Terraria.Main.do_Update(GameTime gameTime)
at Terraria.Main.Update(GameTime gameTime)

All you need to do is re-install tModLoader (just replace all the current files with the new ones) and all the files it came with, then instead of getting the mod from this page get it from the list in the mod browser in-game (don't worry if the game freezes, its just loading all the mods) then install and it'll give you the latest version automatically. This fixed the issue for me.
 

jopojelly

Retinazer
Ok everyone, I figured it out. The Mod Browser had some internet connectivity problems, so the actual file that was served when it said 0.1.0.4 was actually still the old 0.1.0.3. This is why the Mod Browser still told you to update right after you updated. I've fixed it now.
 

Chn

Terrarian
I am having a slight issue... When I first installed the mod, it worked perfectly.. for 5 seconds. It then started bugging out. It was flashing and i couldn't click on anything. I deleted the mod and reinstalled it, which fixed that issue. Now, however, I am not able to open the item browser. If anyone else is having the same issue, please reply here with possible solutions.
 

HERO

Terrarian
I am having a slight issue... When I first installed the mod, it worked perfectly.. for 5 seconds. It then started bugging out. It was flashing and i couldn't click on anything. I deleted the mod and reinstalled it, which fixed that issue. Now, however, I am not able to open the item browser. If anyone else is having the same issue, please reply here with possible solutions.
I think there is a bug where your character needs items in their inventory and hotbar or the mod bugs out. Try putting some items on your character and report back.
 

Chn

Terrarian
I think there is a bug where your character needs items in their inventory and hotbar or the mod bugs out. Try putting some items on your character and report back.
I have tried your solution, but it is still not working. I am trying this on a world from my original terraria. Could this be the issue? I am using a brand new character however as my original was deleted.
 

HERO

Terrarian
I have tried your solution, but it is still not working. I am trying this on a world from my original terraria. Could this be the issue? I am using a brand new character however as my original was deleted.
Your original was not deleted. Go to 6:07 in my video and it covers how to copy your worlds and characters. Just load up your character with items and try a few test. You might need to restart terraria too.
 

Chn

Terrarian
Your original was not deleted. Go to 6:07 in my video and it covers how to copy your worlds and characters. Just load up your character with items and try a few test. You might need to restart terraria too.
I did copy the characters and worlds but something went wrong, although I'm not concerned about that. I am mainly focused on the mod itself right now. I ran multiple tests, and even restarted terraria. Still not working. Everything is fine except for the item browsing feature.
 

jopojelly

Retinazer
I did copy the characters and worlds but something went wrong, although I'm not concerned about that. I am mainly focused on the mod itself right now. I ran multiple tests, and even restarted terraria. Still not working. Everything is fine except for the item browsing feature.
So, I take it the Item Browser is the only issue, right? Are there any other mods installed?

You can try deleting "C:\Users\??\Documents\My Games\Terraria\ModLoader\HEROsModDatabase.json". Also, are you windows? Are you on the latest tmodloader and Heros mod?
 

Chn

Terrarian
So, I take it the Item Browser is the only issue, right? Are there any other mods installed?

You can try deleting "C:\Users\??\Documents\My Games\Terraria\ModLoader\HEROsModDatabase.json". Also, are you windows? Are you on the latest tmodloader and Heros mod?
Yes, that is the only issue. I am new to mods so this is the only one and I AM on windows, and I am on the newest versions. I have already tried deleting those files and reinstalling them.
 

jopojelly

Retinazer
Yes, that is the only issue. I am new to mods so this is the only one and I AM on windows, and I am on the newest versions. I have already tried deleting those files and reinstalling them.
I'm not quite sure what could be happening, but I'll keep thinking about it. There's another mod named Cheat Sheet that has an item browser in the mean time, you can run both at the same time.
I don't have three of those features for some reason.
Which ones? Are they some of the multiplayer only features?
 

PixelBoy

Terrarian
i like this mod a lot but it deleted every world and character and the tool bar bugged out every time i drop a idem i begun with
 

Flandre_Scarlet

Skeletron Prime
There is a slight spelling mistake when you open the spawner window and try to spawn a mob in. Instead of Knockback Resistance, it only is called "Kncokback Resist".
 

jopojelly

Retinazer
i like this mod a lot but it deleted every world and character and the tool bar bugged out every time i drop a idem i begun with
That's a temporary limitation in tmodloaders current version. Keep an item in your hotbar.
[doublepost=1466798681,1466798614][/doublepost]
There is a slight spelling mistake when you open the spawner window and try to spawn a mob in. Instead of Knockback Resistance, it only is called "Kncokback Resist".
Ok, thanks for letting us know. I'll be sure to fix it.
 
Top Bottom