Experimental Features - Texture Pack Support and World Seeds!

Discussion in 'PC - Re-Logic' started by Leinfors, Nov 17, 2016.

  1. Hax4Ever

    Hax4Ever Terrarian

    After my little episode with the clouds, Texture packs flat out stopped working for me.

    [​IMG]

    I have the files placed in the correct folders and everything with proper names and case sensitivity, as well as the experimental features enabled. Is it possible that files that "aren't supported" in texture packs simply don't allow the texture pack to be loaded?

    [​IMG]
     
  2. Rhoenicx

    Rhoenicx Terrarian

    With this new texturepack feature, can we make (example) moving armor/items with the gif extension?
     
  3. Hax4Ever

    Hax4Ever Terrarian

    Animated sprites with GIFs don't work,
    @Bad Musician discovered this last night
     
  4. Rhoenicx

    Rhoenicx Terrarian

    Alright! No problem, would be great if it worked!
     
  5. Hax4Ever

    Hax4Ever Terrarian

    Update on the clouds, I'm really glad because they actually do work, but I forgot to capitalize the Images folder, Is there a possibility that it could also load from "images" as well as "Images" just as a small detail to help those (like myself) who'd get worked up over nothing?
     
    Zilem likes this.
  6. How do you get the custom textures to work?
    Don't you have to have the images inside a folder named images/Images within the zip file or do you need the folder in the zip file?
     
  7. Zanderstorm

    Zanderstorm Skeletron

    Just take the zip file and put it in your asset folder
     
  8. Where is the asset folder?
    Cause there is no folder labeled by that name.
     
  9. Zilem

    Zilem Official Terrarian

    There is a still way to have Animation in armors, but it is done doing the Run/walk animation:dryadwink:
    like Molten Armor, where the fire effect breaths when you move
    and Fish Bowl, where the fish swims around when you move

    On Windows that should not have been a issue...
    but on a Mac it might, as i heard that you can have the same file name with the same file extension several times (or folder)
    as long as there is a difference in what letter are capitalized, Example:
    images
    Images
    IMages
    iMages

    I think the issue is in the code where the Directory is tagged with "Case sensitive" or "Exact" :dryadwhat:
    But also. this system is W.I.P. and in an early state, as it currently only support one .zip file-archive. one with a specific name.
    Having an auto detect and an in-game menu where you can turn on/off texture mods, and their load order is at this point a dream, one we can hope for will happen down the line :dryadgrin:

    By "Asset" he meant your "Terraria" folder within "Documents" Library :dryadrolleyes:
    well to be exact:
    C:\Users\{Your Username}\Documents\My Games\Terraria

    simply add the texture files you want into the Texture Pack.zip's "Images" sub-folder (have to be .png files though.)
    Short) \Texture Pack.zip\Images
    Full) C:\Users\{Your Username}\Documents\My Games\Terraria\Texture Pack.zip\Images
     
    Leinfors and Hax4Ever like this.
  10. It is setup like that but it doesn't work.
    So I'm unsure if it does work.
     
  11. Proxy

    Proxy Spazmatism

    actually no. it has to be named "Texture Pack", without the .zip behind it.
    and i was Wondering why it didn't worked...
    [​IMG]
     
  12. Zilem

    Zilem Official Terrarian

    You have put files into the .Zip archive?

    The altered textures within the example file, that was provided is "Wood Block" and "Wood wall"
    So basically chop down a tree and place some wood blocks, if they are "Blue" then it does work.:dryadwink:

    That is because file-extensions to you is "Hidden" since .zip a know file-extension as Windows comes with a plug-in to use .zip files.
    some of us prefers to have know file-extensions shown regardless, as it allows us to quicker recognize the file formats of files within a folder :dryadcool:
    and we often do forgot it Hidden by default is, as it likely one of the first things we toggle to show on systems we use :dryadrolleyes:
    (also if you look under "Type" in your folder window you will see "Zip-Komprimirete..." telling you it's a "Zip-archive")

    You can toggle it on so you will always see "know file-extensions" if you want:
    in a File explore window, hit the "Alt" key and select the "Tools" tab in the top of the window and then chose "Folder options..."
    in this new window, Click on the "View" tab, and tag-off "Hide Extensions for known file types"

    Sadly i have no idea the menu's are called in German.... %:sigh:
     
  13. Marcus101RR

    Marcus101RR Master of Ravens

    For those having trouble with getting texture to work, please make sure your images are Indexed with Transparency.
     
  14. I see one issue I'll have is that I don't use or even have photoshop nor gimp.
    Also I'm trying to use an existing texture pack that all the image files are in png format.
    But it's not working regardless of the image files being in the .zip file within an images folder.
     
  15. Marcus101RR

    Marcus101RR Master of Ravens

    Most likely because its not an indexed color format, what are you using to edit this with? Windows Paint will not suffice! Gimp is free, I suggest you get it if you cannot afford Photoshop!
     
  16. I'm not editing it.
    Though I did work it out, I had the folder as images instead of Images, but regardless that it worked.
    Tons of the images where broken or just showed up as pink boxes.
    But at least I figured out my error, now it's a wait on fixing that texture pack[if someone does fix it] or find another one.
     
  17. Techdude594

    Techdude594 Skeletron Prime

    I have a question. Do you need to have the zip file named Texture Pack for this feature to work?
     
  18. From what I've seen yes.
    Also for images have the folder named Images[with a cap I] for it to work.
    I'm uncertain if backgrounds, UI, or anything else would work in a folder separate from the Images folder.
     
  19. Techdude594

    Techdude594 Skeletron Prime

    Thanks for the help!
     
  20. Captain fabulous

    Captain fabulous Terrarian

    Hey, can anybody help me out?
    i'm trying to use the new texture pack feature (super hyped!) but it isn't working.
    and not as in the textures don't load, when i put a "Texture Pack.zip" file in the specified folder, Terraria stops running altogether...
    Terraria works fine when i remove it though

    I am running Linux mint.
    terminal output when attempting to run: http://pastebin.com/FDSEhmnR